none
explorer11의 video와 audio의 작동 오류 입니다. RRS feed

  • 질문

  • 안녕하세요

    커뮤니티에서 아래와 같은 질문을 하고 웹개발소스와 관련된 질문은 이곳에 하라는 답변을 받았습니다


    질문내용입니다.

    =====================================================================


    explorer11의  video와 audio의 작동 오류 입니다.        


    <head>
    < title>제목 없음 1</title>
    < /head>

    <body>

    <video  width="130"  autoplay controls poster="cfile263.uf.daum.net/image/27647F37546FD992103295" heigth="50">
      <source src="yseongho.smilecast.co.kr//music/esunny/lee20141121.mp4" type="audio/mp4">
    < /video>


    </body>

    </html>

     explorer11의  video와 audio 오류

    음원이 자동시작되는 페이지를 클릭하여 음악이 시작된 이후에

    잠시 다른페이지를 보기 위하여 이 페이지에서 빠져나간 이후

    다시 페이지로 들어오면 한참동안 먹통되는 현상이 발생됩니다.


    위 소스로 테스트할 경우,

    explorer11로 실행시킨 후 중간에 종료시키고 바로 다시 열어보시면

    먹통 증상을 확인하실 수있습니다.

    블로그나 카페 등 ( 예 : 다음(Daum) )  카페의 경우


    카페지기가 카페메인페이지에 배경음악을 흐르게 한 경우에도 배경음악의 영향으로

    전에 작동되던 영상이나 음원이 있었다면 


    explorer11의 audio나 video태그 오류가 발생됩니다.


    크롬에서 테스트하여 본 결과 크롬이나 안드로이드에서는 아주 정상적으로 작동됩니다.

    explorer11만 오류가 발생합니다.    

    ======================================================================  

                     

    Microsoft        

    안녕하세요.

    Internet Explorer 11에서 audio & video 태그 적용 시 중간에 종료 후 다시 돌아가면 멈추거나 오류가 발생되는 문제로 질문하셨습니다.

    이와 같은 문제는 Internet Explorer 버전과 태그와의 호환성 문제일 가능성이 있습니다.

    Internet Explorer 의 옵션 설정만으로 문제가 해결되기에 어려움이 있으며 Internet Explorer 웹 개발 및 소스와 관련하여 MSDN포럼을 통하여 도움을 받으실 수 있습니다.

    번거로우시더라도 아래 MSDN포럼으로 문의해 주시기 바랍니다.

    =======================================================================

    이런 현상을 구체적으로 관찰한 바에 의하면

    문제의 미디어화일 (mp3 또는 mp4)이 다른 써버에서 문제를 일으키지만 내 컴퓨터에서는 정상적으로 잘 나옵니다.

    먹통현상 발생(서버에서 불러올때)

    <video  width="130"  autoplay controls poster="cfile263.uf.daum.net/image/27647F37546FD992103295" heigth="50">
     <source src="yseongho.smilecast.co.kr//music/esunny/lee20141121.mp4" type="audio/mp4">
    < /video>

    (내컴퓨터에서 실행하면)정상적으로 작동됩니다

    <video  width="130"  autoplay controls poster="cfile263.uf.daum.net/image/27647F37546FD992103295" heigth="50">
     <source lee20141121.mp4" type="audio/mp4>
    < /video>

    그런데 이상하게도

    마이크로소프트 홈페이지에서 다운받은 (mp3 또는 mp4)는 서버에서 작동시켜도 잘됩니다.

    <문제의 현상을 관찰해본 요약>

    1. 문제의 미디어화일를 써버에 올린 후 <audio>혹은 <video>태그로 링크시킬때는 먹통현상이 발생하지만,

    2. 내 컴퓨터의 하드디스크에서 링크시키면   먹통현상이 없이 잘됩니다.

    3. 미디어화일를 써버 올린 후 <audio>혹은 <video>태그로 링크시켰다 하더라도 크롬이나 안드로이드에서는 먹통현상이 없이 잘됩니다.

    4. 마이크로소프트 홈페이지에서 다운받은 mp3나 mp4는 서버에 올린 후 <audio>혹은 <video>태그로 링크시켰다 하더라도 먹통현상없이 잘 나옵니다.

    5. 먹통 현상은 소리가 아예 안나오는 적은 한번도 없었습니다. 먹통으로 있다가 한참만에 나오는데 짧게는 수초에서 길개는 2분이상 먹통으로 있다가 소리가 나옵니다.

    6. 먹통현상이 있을때 새로고침 하면 정상적으로 나옵니다.

    7. 정상적으로 나올때 새로고침하면 먹통현상이 발생

    8. 정상적으로 소리가 나오는 동안 다른 탭들로 페이지를 계속 열을때는 모든 탭에서 먹통현상이 없이 잘나옵니다.

    9. 한 탭에서 반복적으로 새로고침할 경우 반드시 먹통현상이 발생한 다음번 새로고침은 정상적으로 소리가 나오고,

    정성적으로 소리가 나온 다음번  새로고침은 반드시 먹통현상이 발생합니다.

     

    추정되는 원인은

    explorer가 mp3 또는 mp4 중 일부 만들어진  화일형식이 다른 미디어에서 문제가 발생하는 것 같습니다.

    mp3 또는 mp4화일을 explorer에서 문제를 일으키지 않게 변환시키려면

    어떤 방법으로, 어떤 프로그램을 사용해야 하는지 알고 싶습니다.

    감사합니다.





    • 편집됨 yseongho 2014년 11월 24일 월요일 오전 8:39
    2014년 11월 24일 월요일 오전 3:08