Visual studio 2010 express fails to install


  • Hi, I tried to install visual studio express on my 64bit Windows 7 Home Premium but it fails to install, here is the log from the collect tool https://skydrive.live.com/redir.aspx?cid=839d28b95c9fa925&resid=839D28B95C9FA925!109&parid=root
    2012년 1월 30일 월요일 오전 10:28


모든 응답

  • Hi Oyeyipo,


    Welcome to the MSDN forum.

    I checked your logs and found a problem: “You haven’t installed .NET Framework 4 correctly”. Here are some error messages:

                1.    Exe (C:\69cd28c6d77487f4fed3\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null). PerformOperation on exe returned exit code 2359302 (translates to HRESULT = 0x240006)

                2.    The following applications should be closed before continuing the install:: , Web Farm Controller Service

    In order to solve the error 0x240006, please refer to this article:


    In addition, please follow these tips when installing .NET Framework 4:


    1. Ensure that all of the pre-release(Beta or CTP versions) components on your machine have been removed

    2. Disable your Anti-Virus or Anti-Spyware software

    3. Be sure that your OS has been "patched" up - Update your computer (Windows)

    4. Complete or dismiss Windows Update before installation. Please don’t forget to turn it on later.

    5. Make sure that the installation media is healthy. If the installation from disc drive is not working well, you can try copying the contents of the disc to the hard disk and installing from the hard disk.

    Finally, please check that your .NET Framework 4 has been installed correctly. You can use this tool http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx to verify your .NET Framework 4 and post the first 25 lines and last 25 lines of the output here for me. If so, then you can try to install VS express again.

    I hope it helps.


    Best regards,

    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    2012년 1월 31일 화요일 오전 9:20
  • Thanks, I tried everything you suggested it did not work. I have collected some fresh logs here is the link:


    Microsoft web matrix works very well on my system (Win 7 Home Premium 64 bits) I don't know if that is relevant or not.
    2012년 2월 2일 목요일 오전 8:43
  • Thanks so much for everything. I was able to install all the Visual Studio 2010 express products. Thanks.
    2012년 2월 3일 금요일 오전 8:29
  • Hi Oyeyipo,


    I’m glad to hear that you got it working.

    If you find out the root cause finally and share your solutions here, it will be very beneficial for other community members who have similar questions.​


    Best regards,

    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us
    2012년 2월 3일 금요일 오전 8:50