none
iis7.0설치가 안됩니다.. RRS feed

  • 질문

  • 웹플랫폼 4.0설치후

    윈도우xp이고 정품이 아닙니다.

     windows azure sdk for.net(vs2012)june 2012설치안됩니다.

    왜 안되지요?

    windows sp2설치후에도새로운 버전이 필요하다고 나옵니다..

    윈도우xp용인데 어떤 버전이 필요하다는건가요?

    2012년 6월 14일 목요일 오전 2:17

답변

  • 안녕하세요. Windows Azure MVP 남정현입니다.

    개발하려고 하는 기술이 무엇인지에 따라서는 Windows XP를 사용하실 수 없을 수 있는데, 지금 설치하시려는 SDK는 Web Role, VM Role, Worker Role과 같은 Cloud Service 개발을 위해서 필요한 SDK이고 Windows XP는 초기부터 지원되지 않았었습니다. Cloud Service 개발을 하시려면 Windows Vista SP2 이상, Windows 7 SP1 이상의 OS를 설치하여 사용하셔야 합니다. 그 이유는 해당 SDK가 Windows XP나 Windows Server 2003에 포함되어있지 않은 IIS 7.x 버전을 사용하기 때문입니다.

    그리고 Windows XP의 경우, 일반적으로 소프트웨어 개발을 위해서는 Home Edition이 아닌 Professional 버전이 필요하며, Professional 버전이어야 IIS 6.0 및 기타 개발 관련 구성 요소들의 설치에 문제가 없습니다. 또한, 가장 마지막으로 나온 서비스 팩 버전은 SP3입니다. x64 Edition을 사용 중이신 경우 Professional로 변경해서 재 설치하시는 것이 전반적인 호환성 문제 해결에 도움이 될 것입니다.

    감사합니다. :-)


    남정현 (rkttu@rkttu.com) - Windows Azure Cafe SYSOP - http://cafe.naver.com/wazure | DEVWITH - http://www.devwith.com/ | DEVPIA C# Forum SYSOP - http://www.devpia.com/CSharp.MAEUL

    2012년 6월 14일 목요일 오후 12:25
    중재자

모든 응답

  • 안녕하십니까? 하면된다 님,
    Microsoft MSDN 의 Forum 사이트를 방문해 주셔서 감사합니다.

    현재 문의 하신 ”iis7.0설치가 안됩니다.." 대해 답변드리겠습니다.

    Window azure 시스템 요구 사항 입니다. 참조 부탁드립니다.

    서비스 버스 클라이언트 또는 서비스 응용 프로그램을 실행하려면 다음이 필요합니다.

    •Windows XP 서비스 팩 3 이상, Windows Vista, Windows Server 2008, Windows Server 2008 R2 또는 Windows°7.
    •.NET Framework 3.5 서비스 팩 1.
    •Windows Azure SDK.
    •HTTP/HTTPS 인터넷 연결.
    •TCP 연결을 사용하려면 컴퓨터에서 포트 808 및 828을 사용하여 서비스 버스에 대한 아웃바운드 연결을 열 수 있어야 합니다.
    •클라이언트에 대한 직접 연결을 설정하려면(하이브리드 모드) 컴퓨터에서 포트 819를 사용하여 서비스 버스에 연결할 수 있어야 합니다.

    답변이 문제 해결에 도움이 되었다면 답변으로 채택을 부탁드립니다.
    하지만 문제 해결이 되지 않아서 정확한 답변을 원하는 경우에는 문제의 정보를 더 자세하게 답변으로 제공해주시기 바랍니다.

     

    2012년 6월 14일 목요일 오전 6:31
    중재자
  • 안녕하세요. Windows Azure MVP 남정현입니다.

    개발하려고 하는 기술이 무엇인지에 따라서는 Windows XP를 사용하실 수 없을 수 있는데, 지금 설치하시려는 SDK는 Web Role, VM Role, Worker Role과 같은 Cloud Service 개발을 위해서 필요한 SDK이고 Windows XP는 초기부터 지원되지 않았었습니다. Cloud Service 개발을 하시려면 Windows Vista SP2 이상, Windows 7 SP1 이상의 OS를 설치하여 사용하셔야 합니다. 그 이유는 해당 SDK가 Windows XP나 Windows Server 2003에 포함되어있지 않은 IIS 7.x 버전을 사용하기 때문입니다.

    그리고 Windows XP의 경우, 일반적으로 소프트웨어 개발을 위해서는 Home Edition이 아닌 Professional 버전이 필요하며, Professional 버전이어야 IIS 6.0 및 기타 개발 관련 구성 요소들의 설치에 문제가 없습니다. 또한, 가장 마지막으로 나온 서비스 팩 버전은 SP3입니다. x64 Edition을 사용 중이신 경우 Professional로 변경해서 재 설치하시는 것이 전반적인 호환성 문제 해결에 도움이 될 것입니다.

    감사합니다. :-)


    남정현 (rkttu@rkttu.com) - Windows Azure Cafe SYSOP - http://cafe.naver.com/wazure | DEVWITH - http://www.devwith.com/ | DEVPIA C# Forum SYSOP - http://www.devpia.com/CSharp.MAEUL

    2012년 6월 14일 목요일 오후 12:25
    중재자