none
helloが出力されません。 RRS feed

  • 質問

  • こんばんは、というより、おはようございます。
    なんとか、XP-SP3にインストールするところまで、漕ぎつきましたが、実際、動作させると
    ----- すべてのリビルド開始: プロジェクト: p, 構成: Debug Win32 ------
    プロジェクト 'p'、構成 'Debug|Win32' の中間出力ファイルを削除しています。
    コンパイルしています...
    プロジェクト : error PRJ0002 : エラーの結果 -1073741511 が 'C:\Program Files\Microsoft Visual Studio 8\VC\bin\cl.exe' より返されました。
    ビルドログは "file://c:\Documents and Settings\user1\My Documents\Visual Studio 2005\Projects\p\p\Debug\BuildLog.htm" に保存されました。
    p - エラー 1、警告 0
    ========== すべてリビルド: 0 正常終了、1 失敗、0 スキップ ==========
    となり、オブジェクトが作成されません。
    答えてネットで同様の質問をしたところ、コードは、あっているようです。

    インスートルなどにつきましては、こちらのサイトを参考にさせて頂きました。
    http://homepage3.nifty.com/mmgames/c_guide/p_vc2005.html

    http://mail2.nara-edu.ac.jp/~asait/2005_express/2005_express.htm

    何に原因があるのかが、解らず困っています。よろしくお願いいたします。
    2009年2月25日 20:56

すべての返信

  • USのフォーラムで似たようなものとして、下記のものがありました。

    http://social.msdn.microsoft.com/forums/en-US/vcgeneral/thread/8f6d94d5-a6c7-423f-aabe-5119a45939f2/

    http://social.msdn.microsoft.com/Forums/en-US/Vsexpressvc/thread/cd565492-cc1a-41e7-bdb7-b2bd665ad6b2/

    pdbファイルを消してみるとか、VC Expressを再インストールしてみるとか書かれています。
    コードが合ってる、合っていないの問題ではなさそうなので、簡単には解決しないかもしれません。


    解決した場合は、参考になった返信に「回答としてマーク」のボタンを利用して、回答に設定しましょう(複数に設定できます)。
    2009年2月26日 14:04
    モデレータ
  • 回答ありがとうございます。
    2005EXPを利用していますが、適用がXP-SP2となっており、SP3の環境では、利用できないものなのでしょうか?
    現在まで、2回程再インストールを実行し、そのたびに、ファイルの変更がみられ、(環境設定上の)幾つかの進展もありましたが、
    ビルドに関しては、相変わらず、同じ状況を脱する事ができません。
    確かに、SQLのインストールに失敗したので、再インストールしてくださいのメッセージが出力されましたが、開けてみると、SQLができていましたので、?うまくいったのではなかろうかと思っていました。

    リンクがうまくいっていないのでしょうか?
    SKDを先にインストールしてあったのが間違っていたのでしょうか?
    個々のファイルの設定が間違っていたのでしょうか?
    SQLのバージョンを上げる?
    CDによるインストールで、ゴミが付着していた?
    どれを試したらいいのか見当もつきません。

    皆さん、苦労しているみたいですね。困った、困った。
    2009年2月26日 19:59
  • 申し訳ありませんが、現状、解決のためのアドバイスをすることは困難です。
    試行錯誤を経て、解決できる状況もあれば、何をやっても解決しないことはあり得ます。


    なお、SQLのバージョンによって挙動が変わるとは考えにくいです。(考えにくいであって、ないとは明言できない)
    XP SP2だからとか、XP SP3だからで挙動が変わるとも思えません。

    ディスクが物理的に読めないとか、ディスクイメージが壊れているとか、環境にインストールを阻むものが入っている等、可能性は多岐に渡りますが、その全てを想像することはできません。
    解決した場合は、参考になった返信に「回答としてマーク」のボタンを利用して、回答に設定しましょう(複数に設定できます)。
    2009年2月28日 7:48
    モデレータ
  • こんにちは、
    幾多の障害を乗り越え、ふたたび、フォーラムに参加する事ができるようになりました。
    後は、2005が正常に動作してくれれば、申し分ありません。
    先ほどのインストールでは、正常に動作しておらず、状況の改善は、ありませんでした。
    ただ、フォーラム参加の経緯は、SP3のファイル障害と考え、SP3の再適用(上書き)を実行した事で、改選されました。
    ひょっとすると2005が動作しない理由は、SP3、SP2、SP1などの部分に問題をかかえている(私の環境において、ファイル破損がある)などがありそうです。
    2005がうまい具合に動作できるようであれば、また、投稿させて頂きます。ありがとうございました。
    2009年3月1日 3:48
  • 導入環境の違いをインストーラが区別してくれていないようです。しかし、この問題は、2008インストーラで改善されているようです。
    この事から、2005の導入をする為には、どうも、OSのインストールに戻って環境改変したあとに導入しなければならないように感じます。
    この環境改変とは、OSのインストール時点でのインストールネーム(英数)であったり、ログインユーザに付与されているログインパスワードの有無のように感じます。
    2009年3月3日 9:19