none
SSMSからIntegration Servicesへの接続が失敗 RRS feed

  • 質問

  • SQL Server 2017のSSMSからIntegration SerVicesに接続しようとすると以下のエラーが発生いたします

    タイトル: サーバーへの接続
    ------------------------------

    (SERVER名) に接続できません。

    ------------------------------
    ADDITIONAL INFORMATION:

    この要求のデータを取得できませんでした。 (Microsoft.SqlServer.Management.Sdk.Sfc)

    ヘルプを表示するには (LinkId = 20476) をクリック

    ------------------------------

    コンピューター (SERVER名) の Integration Services サービスに接続できませんでした。次のエラーが発生しました: "指定されたサービスはインストールされたサービスとして存在しません。"。

    このエラーは、最新バージョンの SQL Server ツールから SQL Server 2005 Integration Services サービスに接続しようとすると発生します。代わりに、サービス構成ファイルにフォルダーを追加して、ローカルの Integration Services サービスで SQL Server 2005 インスタンスのパッケージを管理してください。

    ヘルプを表示するには( LinkId=506689)をクリック

    ・サービスではSSISは起動しております

    ・もともと、SQL Server2005を2017へアップグレードした環境で、現在未使用と思われるDTSパッケージを移行しておりませんでした。

    アップグレードした際には、特に問題なく接続できていたのですが、最近改めて、パッセージの修正をしようと接続すると上記メッセージが表示されるようになりました。

    何か、よい対応方法がありましたら、ご教授お願いいたします。

    2019年8月4日 4:50

すべての返信

  • Developers_Aさん、こんにちは。フォーラムオペレーターのHarukaです。
    MSDNフォーラムにご投稿くださいましてありがとうございます。

    SQL Server Integration Servicesのバージョンを教えていただけますでしょうか。
    スタートページに「サービス」と入力して確認できます。

    SQL Server 2017のSSMSはSQL Server Integration Services 14.0を使用する必要があるようです。
    SQL Server Integration Servicesが14.0でない場合は更新してください。
    Integration Services のアップグレードをご参照いただければと思います。

    どうぞよろしくお願いします。


    MSDN/ TechNet Community Support Haruka

    ~参考になった投稿には「回答としてマーク」をご設定ください。なかった場合は「回答としてマークされていない」も設定できます。同じ問題で後から参照した方が、情報を見つけやすくなりますので、
    ご協力くださいますようお願いいたします。また、MSDNサポートに賛辞や苦情がある場合は、MSDNFSF@microsoft.comまでお気軽にお問い合わせください。~

    2019年8月9日 1:55
    モデレータ
  • バージョンは13.0でした。

    アップグレードは業務時間帯での作業が難しいので、後日、日程を調整してアップグレードを実施後、ご報告させていただきます

    2019年8月18日 4:12
  • Developers_Aさん、こんにちは。フォーラムオペレーターのHarukaです。
    MSDNフォーラムにご投稿くださいましてありがとうございます。

    ご質問いただいた件ですが、その後いかがでしょうか。
    追加でご確認いただいたことなどあれば、追記いただくことで回答がつきやすくなります。

    どうぞよろしくお願いします。


    MSDN/ TechNet Community Support Haruka

    ~参考になった投稿には「回答としてマーク」をご設定ください。なかった場合は「回答としてマークされていない」も設定できます。同じ問題で後から参照した方が、情報を見つけやすくなりますので、
    ご協力くださいますようお願いいたします。また、MSDNサポートに賛辞や苦情がある場合は、MSDNFSF@microsoft.comまでお気軽にお問い合わせください。~

    2019年8月29日 2:16
    モデレータ
  • 先日、SSISのアップグレードを実施にあたり、再度環境を確認したところ、ご報告していた環境と異なることが発覚いたしました

    SQL Server 2016

    Microsoft SQL Server 2016 (RTM) - 13.0.1601.5 (X64)   Apr 29 2016 23:23:58   Copyright (c) Microsoft Corporation  Standard Edition (64-bit) on Windows Server 2012 R2 Datacenter 6.3 <X64> (Build 9600: ) (Hypervisor)

    Management Studio 2017:13.0.16106.4

    SQL ServerとSSISのバージョンは同じで、Management Stdioのバージョンが異なっておりましたので、Management StudioのVer2016をインストールしてみました。

    Management Studio2016からデータベースの接続、参照などはできました。

    SSISへの接続はできたのですが、SSISのフォルダを開こうとしたところ、

    「SSISサービスの構成で指定されているSQL Serverインスタンスが使用できません。コンピュータ上にSQL Serverの規定のインスタンスが存在しない可能性がありうます。詳細については%SQL_PRODUCT_NAME%オンラインブックの「Integration Serviceサービスこの構成」を参照しください。

    ユーザー’(サーバ名)¥admin’はログインできませんでいた(MsDtsSrvr)

    と表示されました。

    詳しくは調べておりませんが、何か調査のヒントなりありましたら、ご教授よろしくお願いいたします。

     

    2019年9月15日 9:42