none
Azureの仮想networkについて RRS feed

  • 質問

  • 識者の皆様、いつも勉強をさせて頂いています
    今回、Azureで仮想Network(192.168.1.0/24)を作成して
    この仮想Networkに仮想インスタンスを2台、接続をしました

    それぞれのIPは
    ・192.168.1.4/24
    ・192.168.1.5/24
    です

    2台の仮想インスタンスは同一セグメントでありエンドポイントの設定も両方ともhttp、https、sshはopenしています
    この状態で192.168.1.4/24から192.168.1.5/24に対して
    ・telnet 192.168.1.5 80
    を実行すると
    Trying 192.168.1.4...
    telnet: connect to address 192.168.1.4: No route to host
    となってしまいます

    この2台の仮想インスタンスは両方ともCentOSでiptablesは両方ともstopをしています
    Azureでは仮想Networkに属する仮想インスタンス間の通信は制限されているのでしょうか?

    それとも設定上の問題なのでしょうか

    識者の皆様、ご教授よろしくお願い申し上げます。

    2014年2月25日 4:53

回答

  • こんばんは

    ご教授ありがとうございます
    結論から申し上げますと、仮想networkを再作成し、仮想インスタンスも再作成をしたところ

    仮想networkのセグメント(172.16.1.0/24)に属する仮想インスタンス同士でpingの疎通がとれました
    原因の特定までは出来ませんが、仮想networkを作成するときに何らかの不具合があったのかも知れません

    現状は正常に疎通できましたので、同様の現象が起こった場合は、仮想network、仮想インスタンスの再作成が良いと思います

    • 回答としてマーク tetuya1970 2014年2月25日 15:29
    2014年2月25日 15:29

すべての返信

  • こんにちは

    1つの仮想ネットワークに2つのサブネットがあって、それぞにインスタンスが所属しているという感じでしょうか?

    ※仮想ネットワークが異なるとそもそも通信できないので念のため

    もし、東アジアのデータセンターで同一仮想ネットワーク上でもpingが飛ばない(Destination host unreachableとかになる)のであれば、一度すべて削除してアフィニティグループ、ストレージ、仮想ネットワークなどすべて再作成してみてください。

    自分も同様の現象が発生しましたが切り分けていった結果、どうもストレージに起因しているような感じでした。(すべて再作成したところ疎通できるようになりました)


    2014年2月25日 6:10
    モデレータ
  • こんばんは

    ご教授ありがとうございます
    結論から申し上げますと、仮想networkを再作成し、仮想インスタンスも再作成をしたところ

    仮想networkのセグメント(172.16.1.0/24)に属する仮想インスタンス同士でpingの疎通がとれました
    原因の特定までは出来ませんが、仮想networkを作成するときに何らかの不具合があったのかも知れません

    現状は正常に疎通できましたので、同様の現象が起こった場合は、仮想network、仮想インスタンスの再作成が良いと思います

    • 回答としてマーク tetuya1970 2014年2月25日 15:29
    2014年2月25日 15:29
  • こんにちは。

    解決してよかったです。自分はストレージから全部作り直さないとダメだったので、、、何かしら調子が悪いようですね。

    2014年2月25日 16:13
    モデレータ