none
visual studio 2015のインストーラがスプラッシュ表示で止まる(エラーは出ない) RRS feed

  • 質問

  • (( 以下 visual studio 2015 communityのインストーラで試した結果を書いていますが enterpriseのインストーラでも同じでした。))

    (( visual studio 2015 communityのインストーラは 2016/09/16にフルパッケージとしてダウンロードしていたものを使用しています。))

    発生していること

    -----------------

    * インストーラ(vs_community.exe)を起動すると スプラッシュウィンドウが表示されるが、その次へ進まない。(2日ほどそのまま置いてみましたが先に進まず)

    * vs_community.exeに /S オプションを指定すると インストールは最後まで完了する。

    ログ

    ----

    $TEMPフォルダのログファイル(dd_vs_community_....log)の最後は 下記の様になっています。

    インストーラのメインウインドウのviewのロードが完了しない?

    ‘‘‘

    [3C5C:045C][2018-06-05T10:30:34]i000: MUX:  Detect Completed
    [3C5C:045C][2018-06-05T10:30:34]i000: MUX:  Wait for View to be loaded

    ‘‘‘

    その他補足情報

    ------

    * インストーラの実行環境は windows10 1803。

    * visual studio2015はこれまで同じPCで正常に利用していたのですが、以前作成したプロジェクトが正常に読み込めなくなり追加モジュールを要求されました。要求のままモジュールのインストールを実行したところ スプラッシュ表示から先に進まなくなり、現在に至ります。

    * (インストーラが起動してこないので) VisualStudioUninstaller で一度すべてアンインストールしましたが   

       症状に変化ありませんでした。(上に書いた /S オプションでインストールが最後まで行けるのはこの後確認しました)

    2018年6月5日 1:46

回答

  • 最後の報告をさせていただきます。

    試したことを後に書かせていただきますが、結果的に状況が改善できず
    windows10を初期化することで対応しました。
    色々アドバイスいただきありがとうございました。

    試したこと(試してみてうまくいかなかったこと)

    * PCに新規にアカウントを作成しそのアカウントでの インストーラ起動を試した
    * Process Monitorで読み込まれているモジュール、プロセスの動作ログを取得し うまく動いている環境(仮想環境内)と比較し違いを見ようとした
        ~ こちらはログが膨大で 探り切れませんでした。
    * インストールしたフォントが障害になることがあるとの過去のデータにあったので うまく動いている環境とフォントの状態を同じにしてみた。(韓国語、中国語のフォントなど追加で入れていました)
    * グラフィック関連として… cudaをインストールしていたのでこれをアンインストールしてみた
    * ついでに nVidia関係のドライバなどを削除してみた

    以上です。

    2018年6月21日 8:23

すべての返信

  • 德さんさん、こんにちは。フォーラム オペレーターの立花です。
    MSDN フォーラムへご投稿くださいましてありがとうございます。

    私も Windows 10 (1803) + Visual Studio 2015 Enterprise の環境で、
    コントロール パネル、インストール メディアからインストーラーの実行を試しましたが
    問題なく、変更の画面に推移しました。

    一度 VisualStudioUninstaller でアンインストールをお試しされているとのことですので、
    もしかすると Visual Studio だけの問題ではないのかもしれません。

    その他の端末や別の OS バージョンなどでお試しはされておりますでしょうか。
    そのあたりの情報がありましたら追記いただいた方が情報が集まるかもしれませんので、
    追加情報の記載などご検討くださいませ。
    例)
    Windows 10 (1703) では問題なく実行できた。
    新しく Visual Studio 2015 Community をダウンロードして試してみたが改善しなかった。
    インストーラーはネットワーク ドライブに保存している、など。

    フォーラム利用時の注意点のお知らせです。
    ※初めてご投稿された方を対象にお知らせしています。

    ご利用の際は、下記内容をお守りいただきますと
    情報が寄せられやすくなりますので、ぜひご一読ください。
    フォーラムでご質問頂くにあたっての注意点
    フォーラムのご利用方法(質問の投稿)について
    フォーラムへの回答に関するガイドラインおよびフォーラム運営について(再掲)
    ご意見、ご要望はこちらのフォーラムまで。
    各種設定方法はフォーラム内を [かんたん フォーラム ガイド] で検索してみてください。


    参考になった投稿には回答としてマークの設定にご協力ください
    MSDN/TechNet Community Support 立花楓

    2018年6月7日 2:50
    モデレータ
  • 立花さん

    回答ありがとうございます。

    前の投稿は 現象の説明に一生懸命で挨拶もできていないことに後で気が付き反省しておりました。
    よろしくお願いします。

    さて、追加の情報です。

    1. 他の環境でのインストーラーの挙動ですが

     投稿の後 もしかしたら 最新の windows10 1803 で発生するのかと思い、
     Hyper-V上に windows10 1803環境を構築し 使っている インストーラファイル(isoイメージ)をコピー。
     同じ手順でインストールしてみましたが
     こちらは問題なく起動し、最後までインストールが完了しました。(windows7でも同様に試し問題ありませんでした)

    2. インストーラのisoイメージはローカルのディスクに配置し、「プログラムで開く>>エクスプローラ」を選択し、CDドライブとしてマウント。中の vs_community.exe を 実行しています。

    3. その他試してみたこと/確認していたこと。
     フォーラムの他のスレッドなどで見かけた他の例で原因になっていたものを確認
     a. "SecondaryInstaller”が原因のことがある
       ⇒
    SecondaryInstaller.exe プロセスは存在しなかった
     b. ドライブレターが多いとインストーラが止まることがある
       ⇒ ローカル:5 、ネットワークドライブ:4 あったものを ローカル: 3 、ネットワークドライブ:0 に減らす
     c. 関係ないとは思うが Viewのロードに失敗しているので マルチディスプレーを止め ディスプレーを一つに。
       ちなみに OSの動作環境は
        PC: ノートPC (Dell) に外付けのモニタを HDMIで接続
          ハードディスクは C:ドライブ SSD  + 増設 HDD
     d. ウィルスソフトを一時的に停止してみる

    あと 記憶が曖昧で申し訳ないのですが、 最後に Visual Stuido 2015に変更を行なったのは 今年3月頃 pythonサポートのインストールを行なったことだと思います。

    曖昧な情報でも結構ですので試してみれることがあれば教えていただけると幸いです。





    2018年6月7日 6:30
  • 德さんさん、フォーラム オペレーターの立花です。
    ご返信、追加の情報をご記載くださいましてありがとうございます。

    ご利用のノート PC (Dell) で発生する問題のようですね。
    関連は低いと思うのですが、ハードウェアやグラフィック ドライバの変更、
    更新もございませんでしょうか。

    ソフトウェア的な問題でしたら Process Monitor を利用して、
    vs_community.exe のプロセスに読み込まれているモジュールを調べることで、
    何かわかるかもしれません。有用な情報をお伝えできずすいません。

    Process Monitor
    https://technet.microsoft.com/ja-jp/sysinternals/processmonitor.aspx

    調査方法や回避方法についてよりよいご提案があれば、参加者の皆様から情報を
    いただけると思いますのでお待ちくださいませ。

    ※ [回答としてマーク] のご設定ありがとうございます。
     こちらを設定されますと、問題が解決済みとなり、情報が寄せられにくくなってしまいます。
     大変恐縮ですが一旦解除させていただきますので
     参考となる投稿がありましたら、その投稿にご設定くださいますようお願いいたします。


    参考になった投稿には回答としてマークの設定にご協力ください
    MSDN/TechNet Community Support 立花楓

    2018年6月7日 7:44
    モデレータ
  • 最後の報告をさせていただきます。

    試したことを後に書かせていただきますが、結果的に状況が改善できず
    windows10を初期化することで対応しました。
    色々アドバイスいただきありがとうございました。

    試したこと(試してみてうまくいかなかったこと)

    * PCに新規にアカウントを作成しそのアカウントでの インストーラ起動を試した
    * Process Monitorで読み込まれているモジュール、プロセスの動作ログを取得し うまく動いている環境(仮想環境内)と比較し違いを見ようとした
        ~ こちらはログが膨大で 探り切れませんでした。
    * インストールしたフォントが障害になることがあるとの過去のデータにあったので うまく動いている環境とフォントの状態を同じにしてみた。(韓国語、中国語のフォントなど追加で入れていました)
    * グラフィック関連として… cudaをインストールしていたのでこれをアンインストールしてみた
    * ついでに nVidia関係のドライバなどを削除してみた

    以上です。

    2018年6月21日 8:23
  • 德さんさん、こんにちは。フォーラム オペレーターの立花です。
    解決方法、および検証結果をご共有くださいましてありがとうございます。

    Windows 10 の初期をすることで解決することができたとのことで、
    環境の再構築はお手間だと思いますが、一先ず安堵いたしております。

    また何かございましたらご投稿ください。
    今後とも MSDN/TechNet フォーラムをどうぞよろしくお願いいたします。


    参考になった投稿には回答としてマークの設定にご協力ください
    MSDN/TechNet Community Support 立花楓

    2018年6月22日 1:10
    モデレータ