none
Application GatewayとApp Serviceの組み合わせ RRS feed

  • 質問

  • Application GatewayとApp Serviceを組み合わせて使用しようと思っています。

    Application GatewayのバックエンドにApp Serviceを指定して構築したのですが、Application Gatewayに紐づけたpublic IPにブラウザからアクセスするとApp Serviceに301リダイレクトされてしまいます。(ブラウザのURLにApp ServiceのURLが表示されてしまう)

    Application GatewayはWAFやリバースプロキシなどに使う、という理解なのでバックエンドのサイトのURLが見えてしまうというのは動きとしておかしいと思っていますが、どこの設定を間違えているのでしょうか?

    ざっくりとした質問で申し訳ありません。

    必要であれば現在の設定についても回答します。よろしくお願いいたします。

    2018年12月27日 10:07

回答

  • どういう設定で作成したのか書かれていないから回答が難しいところですが
    基本的にバックエンドプール、正常性プローブ、HTTP 設定だけで設定完了するのでそのいずれかの問題かと思います。
    もしくはApp Service側でなんらかのリダイレクト設定があるかどうかでしょうか。

    Application Gateway の設定でそういう挙動になるとは思えませんが、あえて確認するのであれば
    正常性プローブでミスをするとは思えないので、消去法でバックエンドプールかHTTP設定かと思います。

    バックエンドプールでは該当のApp Serviceを正しく指定していますか?
    HTTP設定ではApp Service用に使用するのチェックを入れましたか?

    これらが問題ない場合はApp Service側を疑ったほうが良いかもしれません。

    • 回答としてマーク iijima_ken 2019年2月1日 9:36
    2019年1月6日 7:59

すべての返信

  • どういう設定で作成したのか書かれていないから回答が難しいところですが
    基本的にバックエンドプール、正常性プローブ、HTTP 設定だけで設定完了するのでそのいずれかの問題かと思います。
    もしくはApp Service側でなんらかのリダイレクト設定があるかどうかでしょうか。

    Application Gateway の設定でそういう挙動になるとは思えませんが、あえて確認するのであれば
    正常性プローブでミスをするとは思えないので、消去法でバックエンドプールかHTTP設定かと思います。

    バックエンドプールでは該当のApp Serviceを正しく指定していますか?
    HTTP設定ではApp Service用に使用するのチェックを入れましたか?

    これらが問題ない場合はApp Service側を疑ったほうが良いかもしれません。

    • 回答としてマーク iijima_ken 2019年2月1日 9:36
    2019年1月6日 7:59
  • 回答遅くなり大変申し訳ございません。

    設定には問題なさそうなので、App service側(というか中の実装)が怪しそうです。

    ご回答ありがとうございました。

    2019年2月1日 9:36