none
Visual Studio 2010 Professional をアンインストールしたい RRS feed

  • 質問

  • Windows 7 Pro SP1 64bit版に Visual Studio 2010 Professional SP1 を入れて使用していたのですが、Windows SDK 7.1 をインストールしようとして、うまくインストールできず。

    ネット上の情報を検索して、Windows SDK 7.1 はインストールできたのですが、気が付くと、Visual Studio 2010 の VC++ の環境がおかしくなっていてコンパイルできなくなってました。

    仕方ないので、再度全部アンインストールしてやり直そうと、VS2010_Uninstall-RTM.ENU.exe をつかってアンインストールしたら、Visual Studio 2010 SP1 が入っていたためか、アンインストールが中途半端になってしまったらしく、現在、Visual Studio 2010 SP1 のアンインストールも Visual Studio 2010 のアンインストールもできない状態になってしまいました。

    何とかして、一度Visual Studio 2010関連を全部アンインストールしたいのですが、どのようにしたら良いでしょうか?

    2012年11月21日 4:25

回答

  • 難しいと思います。

    こういう困ったときのツールを使って無理矢理消した結果、中途半端になった状態からの復帰は方法が用意されていないことが多いかと予想されます。
    ダメ元で技術サポートに相談してみてください。

    手っ取り早いのは開発環境を再構築する(OS からインストールしなおす)ことです。

    • 回答としてマーク 佐伯玲 2012年11月26日 0:31
    2012年11月21日 14:44
    モデレータ
  • OSから再インストールする前に
    「システムの復元」を試してみてはどうでしょう。
    つまり、SDK 7.1 をインストールする前の状態に戻すわけですね。
    2012年11月22日 0:43
  •  自分も間違ってVisual Studio 2010をアンインストールしてしまい、復旧するのに苦労しました。

     自分が行ったこととしては、
      ・VS2010より新しいバージョン(今だったらVS2012ですね)がインストールされていれば、一旦アンインストール。
      ・VS2010のコンポーネントを使用しているアプリケーション(例えばSQL Server 2012)があれば、一旦アンインストール。
      ※自分の場合、AVRの開発環境であるATMEL Studioでしたけど。

     あとはエラーログを見てみることもお勧めします。

    • 回答としてマーク 佐伯玲 2012年11月26日 0:31
    2012年11月22日 6:48

すべての返信

  • 難しいと思います。

    こういう困ったときのツールを使って無理矢理消した結果、中途半端になった状態からの復帰は方法が用意されていないことが多いかと予想されます。
    ダメ元で技術サポートに相談してみてください。

    手っ取り早いのは開発環境を再構築する(OS からインストールしなおす)ことです。

    • 回答としてマーク 佐伯玲 2012年11月26日 0:31
    2012年11月21日 14:44
    モデレータ
  • OSから再インストールする前に
    「システムの復元」を試してみてはどうでしょう。
    つまり、SDK 7.1 をインストールする前の状態に戻すわけですね。
    2012年11月22日 0:43
  •  自分も間違ってVisual Studio 2010をアンインストールしてしまい、復旧するのに苦労しました。

     自分が行ったこととしては、
      ・VS2010より新しいバージョン(今だったらVS2012ですね)がインストールされていれば、一旦アンインストール。
      ・VS2010のコンポーネントを使用しているアプリケーション(例えばSQL Server 2012)があれば、一旦アンインストール。
      ※自分の場合、AVRの開発環境であるATMEL Studioでしたけど。

     あとはエラーログを見てみることもお勧めします。

    • 回答としてマーク 佐伯玲 2012年11月26日 0:31
    2012年11月22日 6:48
  • アドバイス頂いたみなさま、ありがとうございました。

    連休を利用してOSから再インストールを行なって解決しました。

    2012年11月25日 6:43