none
ASP.NET開発サーバーでの動作確認ができません RRS feed

  • 質問

  • <現象>
    Visual Studio 2010 Professional Edition の評価版をダウンロードして、使っています。
    新しいプロジェクト(ASP.NET 空のWebアプリケーション Visual Basic)を作成し、
    Webフォームを作成し、この画面の動作を確認しようとしています。ビルドは正常に終了します。

    ところが、当該Webフォームを右クリックして「ブラウザで表示」させても、
    「スタートページに設定」して、「デバッグ開始」にしても、「デバッグなしで開始」しても、
    [ASP.NET開発サーバー]は起動されるのですが、ブラウザが起動しません。

    Visual Studio の画面は、マウスが砂時計のままか、矢印に戻って何も起こりません。
    [ASP.NET開発サーバー]の「中止」をクリックすると、Visual Studio の画面で
    「ASP.NET開発サーバーに接続できません」というエラーが表示されます。

    また、当該Webフォームを右クリックして「ブラウザの選択」をしても、固まります。

    [ASP.NET開発サーバー]の「中止」をクリックしなくても、15分ほど放置したら、
    「ASP.NET開発サーバーに接続できません」というエラーが表示されました。
    ([ASP.NET開発サーバー]は起動されたままです)

    何がいけないのでしょうか?ご教示いただければ幸いです。

    <動作環境>
    Windows 7 Professional Edtion
    Visual Studio 2010 Professional Edition の評価版

    よろしくお願いいたします。





    2011年4月6日 1:37

回答

  • 自己解決しました。
    単純に、PCを再起動させたところ、解決しました。

    その前に、AVG Free 9.0 のアップデートを実行しましたが、
    それは直接関係ないと思われます。

    取り急ぎ、これで解決ということにいたします。
    totojoさま、ありがとうございました。

    • 回答としてマーク study-park 2011年4月6日 3:12
    2011年4月6日 3:12

すべての返信

  • NOD32 アンチウィルスが動いている、ということはありませんか?
    NOD32 が動いている場合に同様の現象が発生する情報を目にします。「NOD32 "Visual Studio"」あたりで検索してみてください。

    <動作環境>
    Windows 7 Professional Edtion (XP モード)
    Visual Studio 2010 Professional Edition の評価版
    以前の質問でも感じたのですが、動作環境に「XP モード」というのを入れない方がいいと思います。
    XP モード上で動かしているのかと勘違いしてしまいます。
    2011年4月6日 2:23
  • totojoさま、早速のご教示ありがとうございます。
    (XPモード)は、削除しておきました。

    NOD32は入れていません。
    ウィルスバスターがバンドルされているのですが、よく問題を起こすので入れておらず、
    代わりに、AVG Anti-VirusのFree Versionは入れてあります。

    今回の事象が起きているのは、Dell Latitude E5510 ラップトップです。
    Dell Vostro 460 ミニタワーでは、問題なく動作しています。
    どちらも、ウィルスバスターはインストールせず、AVG Anti-VirusのFree Versionを入れてあります。

    取り急ぎ、お返事させていただきます。ありがとうございます。

    2011年4月6日 2:54
  • 自己解決しました。
    単純に、PCを再起動させたところ、解決しました。

    その前に、AVG Free 9.0 のアップデートを実行しましたが、
    それは直接関係ないと思われます。

    取り急ぎ、これで解決ということにいたします。
    totojoさま、ありがとうございました。

    • 回答としてマーク study-park 2011年4月6日 3:12
    2011年4月6日 3:12