none
IEを9から11へバージョンアップしたら不具合が発生した。 RRS feed

  • 質問

  • いつもお世話になっております。

    社内システムをIE11用に整備が完了したので、

    全社展開しようとIE9からIE11へのバージョンアップ検証を行ったところ、

    以下の不具合が見つかりました。

    ・IE9だと新しい画面でポップアップするリンクをクリックしても全く反応が無くなった

    ・インターネットオプションの一部(プロキシや例外設定など)を変更しても次回のIE起動時に元に戻ってしまう

     (レジストリで該当する部分を変更しても元に戻ってしまう)

    ・F12(開発者ツール)が画像のように真っ白になる

    特に上2つに関して解決できないまま展開してしまうと運用に支障が出てしまいます。

    何か解決策があれば教えてください。

    2016年7月14日 9:30

すべての返信

  • IE8/9/10/11と、セキュリティや新しい規格を重視した挙動に徐々に変わってきていて、IE11ではデフォルトの挙動がより厳しくなっているようです。

    具体的には、

    * 互換性表示設定を利用する

    * イントラネットゾーンの詳細設定にサイトを設定する

    * エンタープライズモードを使用する

    * 「設定を自動的に検出する」を無効にして、自動構成スクリプトを利用する

    などが考えられるのではないでしょうか?

    2016年7月14日 10:22
  • tmori3様

    返信ありがとうございます。

    それぞれ対応を行ってみましたが、改善はされませんでした。

    * 「設定を自動的に検出する」を無効にして、自動構成スクリプトを利用する

    の部分ですが、両方とも無効にしていたのを”自動構成スクリプト”を有効にして

    再度IEを開きなおしたところ両方とも無効になっていました。

    2016年7月14日 12:21
  • とりあえず複数の問題を一つのスレッドで取り扱うと話が見えにくくなって混乱するので、それぞれの問題について一つずつの質問を投稿してください。

    このスレッドでは最初の

    > ・IE9だと新しい画面でポップアップするリンクをクリックしても全く反応が無くなった

    について継続し、それ以外については別途質問を新規に投稿してください。

    また「・IE9だと新しい画面でポップアップするリンクをクリックしても全く反応が無くなった」問題については、現象の再現が確認できる最小限のサンプル コード (HTML や JS) を提供されると、問題の解決に繋がる情報が得やすいと思います。サンプルの提供が難しい場合は、公開されている Web サイトでその問題が確認できるページの URL を投稿してください。


    hebikuzure

    2016年7月14日 14:26
    モデレータ
  • 設定変更が出来ないなら、そもそもIE11ではポップアップブロックが標準動作だったと思いますので、投稿し直しは不要かと思います。

    こちらの記事の内容が関係していないでしょうか?

    http://www.atmarkit.co.jp/ait/articles/1501/05/news008.html

    カスタマイズされたOS/カスタマイズされたIE、設定が集中管理されて変更出来ない等考えられるので、レンタルPCや標準のOSイメージを適用したPCで動作するのであれば、設定変更出来ない理由をインフラ担当に確認すれば解決出来ないでしょうか?

    それに、社内システムのIE11対応が完了と書いてありますし、開発PCでは動作確認済みなんですよね?

    • 編集済み tmori3y2 2016年7月14日 18:27
    2016年7月14日 17:26
  • tmori3様

    返信ありがとうございます。

    URLの記事を確認しましたが、

    ・Internet Explorerのメンテナンス:IE11になっているため、表示なし

    グループポリシーの基本設定:IEに関する部分は”未構成”で設定なし

    ・レジストリ:該当する場所に記述無し。追加するも動作に変わりなし。

    でした。

    レジストリの”ProxyEnable”を1⇒0にしても、次回IE(もしくはインターネットオプション)を起動すると1に戻ってしまう状態です。

    >設定変更出来ない理由をインフラ担当に確認すれば解決出来ないでしょうか?

    OSやIEについては集中管理をしておらず、原因がわからないとのことです。

    >社内システムのIE11対応が完了と書いてありますし、開発PCでは動作確認済みなんですよね?

    開発PCでは問題ありませんでしたが、動作検証のため、3台程度から20台程度IE11へバージョンアップしたところ

    5台程度現象が発生しているのが現状です

    2016年7月19日 3:04
  • こんばんは、Nasuです。

    グレーになる件はWindows Updateを行い最新状態にすると解決した報告を見つけました。

    http://stackoverflow.com/questions/22403551/ie11-f12-developer-tools-greyed-out

    20台中5台に本現象が発生しているようですが、ADの有無、WSUSの有無、(PCによってまちまちなど)Windows Updateの当たり具合などが分かると回答が付きやすいのかなと思っています。


    ★良い回答、解決した場合には「回答済み」マークを付けてましょう!

    Satoru Nasu

    Microsoft MVP Cloud and Datacenter Management

    Blog:元「なんでもエンジニ屋」のダメ日記

    Facebook:元「なんでもエンジニ屋」のダメ日記

    2016年7月19日 8:51
  • > OSやIEについては集中管理をしておらず
    が正しく、

    > 開発PCでは問題ありませんでしたが、動作検証のため、3台程度から20台程度IE11へ
    > バージョンアップしたところ5台程度現象が発生しているのが現状です

    という事であればクライアントPC個別に原因があると考えられます。

    ポップアップ ブロックはブラウザーの機能としてだけでなく、セキュリティ対策ソフトウェアやそれに関連するブラウザー アドオンでも同様の機能が実装されている場合があります。また質問されている IE の設定が元に戻るという動作も、一部のセキュリティ対策ソフトウェアに設定変更をブロックする機能があります。

    当該の PC にインストールされているセキュリティ対策ソフトウェアの設定などを確認され、また可能であればそれらをアンインストールする、IE のリセットを行うなどの対処で改善しないか試されると良いかと思います。


    hebikuzure

    2016年7月19日 10:28
    モデレータ
  • Nasu様

    返信ありがとうございます。

    昨日から何度かWindowsUpdateを行っておりますが、問題は解決しておりません。

    ADの有無:ドメインに入っている/入っていない両方の状態でも駄目でした。

    WSUSの有無:なしです。

    Windows Updateの当たり具合:細かくは調査しておりませんが、利用し始めてから2年以上経過しており、こまめにWindowsUpdateを当ててはいない(PCリプレース以降全く当てていないものもあり)ようです。

    2016年7月21日 5:37
  • Hebikuzure様

    返信ありがとうございます。

    アドバイスいただいた内容で確認してみました。

    ・ブラウザのアドオン:有効の設定になっているアドオンなし

    ・セキュリティ対策ソフトウェア:ウイルスバスターを無効にしたあと変更⇒現象の発生

    ・IE のリセット⇒現象の発生

    と解決しませんでした。

    以下のマイクロソフト コミュニティへの投稿を見つけて「Process Monitor」を使ってチェックしてみました。

    ◎SavedLegacySettingsからプロキシ設定が復元される

    http://answers.microsoft.com/ja-jp/ie/forum/ie10-windows_7/savedlegacysettings%E3%81%8B%E3%82%89%E3%83%97/7e9b6f22-f609-4f59-adf5-bd6f358d34af

    「Process Monitor」のログを確かめてみると

    [プロキシサーバ]のチェックを外し、インターネットオプションの[OK]ボタンをクリックする(HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable:Type: REG_DWORD, Length: 4, Data: 0)

    ⇒別のレジストリに記入される(HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\SavedLegacySettings:Type: REG_BINARY, Length: 447, Data: 46 00 00 00 62 05 00 00 01…)

    ⇒デフォルトのレジストリに上書きされる(HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\DefaultConnectionSettings:Type: REG_BINARY, Length: 447, Data: 46 00 00 00 08 00 00 00 03…)

    ⇒[プロキシサーバ]のチェックがついた状態に戻る(HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable:Type: REG_DWORD, Length: 4, Data: 1)

    という動作が一瞬(同じ時分秒)で行われていたようです。

    できればインターネットオプション上で設定したいのですが、レジストリで値を操作するしか方法がないのでしょうか。

    2016年7月21日 6:04
  • Process Monitor でレジストリを元に戻しているプロセスが何か確認できないでしょうか。


    hebikuzure

    2016年7月21日 10:43
    モデレータ
  • hebikuzure様

    Process Monitorを以下の設定でログを見ました。

    (初めて利用するのでデフォルトです)

    先述したレジストリの部分のプロセスはすべて"iexplorer.exe"でした。

    該当する部分の間に”PccNTMon.exe”とウイルスバスターのプロセスがあり、

    ウイルスバスターを停止させて再度ログを取得したところ、

    該当する部分の間はすべて"iexplorer.exe"となりました。

    2016年7月21日 11:10
  • すいませんちょっと言葉足らずでした。

    プロキシの設定を外したのも戻したのもプロセス名はすべて"iexplorer.exe"でした。

    2016年7月21日 11:13
  • 間隔が開いてしまいましたが、まだ未解決であれば....

    Process Monitor でプロキシの設定を戻している所の "iexplorer.exe" のスタックを見て、何か変な (もしくは Windows 標準で無い) モジュールが出てこないか確認しても良いかもしれません。

    スタックの見方はこちらを参照してください。


    hebikuzure

    2016年7月26日 11:58
    モデレータ