none
SQL2005 リモート接続でサービスの操作が出来ない RRS feed

  • 質問

  • 初めまして。
    SQL2005にて、2台のSQLServerを「SQL Server Management Studio」でリモート接続して使用したいのですが、
    現在、リモートされる側のServerのSQLのサービスが操作出来ない状態です。
    DBには接続出来ています。(レプリケーションの設定も出来ます)
    状況は、登録済みサーバの所から、相手方のサーバを登録します。
    サーバ名の左側のアイコン(DBのマーク右下の所に○が表示される)が、○にグリーンで右矢印?が通常だと思われますが、
    白○のままで、上記の様なグリーン状態にはなりません。

    また、そのままでも、相手方のDBのテーブルは開けます。
    しかし、相手方のSQLインスタンスを右クリックして、SQLサービス自体を停止や開始等の操作がグレーアウトして操作できません。
    他のリモート操作が出来ない等のページに見る様にTCPの接続許可はしております。

    更に、全く同環境の設定で、自身のクライアントマシンで、バーチャルPCを使用して2台構築してみた所、
    そちらは問題なく接続出来ました。アイコンもグリーンでSQLサービスの停止・開始も問題なく出来ます。

    調べてみても、リモート接続が出来ない。の項目は沢山有るのですが、こんな中途半端な状態の項目が無いので、
    どなたか教えて頂ければ幸いです。

    宜しくお願い致します。

    2009年7月12日 14:50

回答

  • DBには接続できているとのことですから、SQL Serverへの認証はできていると思います。
    ただ、それはあくまでも稼働しているSQL Serverの中への認証であって、SQL Serverのサービス自体の開始・停止などについては、そのSQL Serverが稼働しているWindows上の権限が関係あるように思います。
    試しに、リモートクライアント側のWindowsに、SQL Serverが稼働するWindowsのAdministratorsアカウントと同じものでログインし、その状態でリモートのSQL Serverのサービスが開始・停止できるかどうかやってみてはどうでしょうか?

    上記でもダメなら、以下のページに記載されているsc.exeも参考になると思います。

    Sc.exe を使用して Windows サービスを作成する方法
    http://support.microsoft.com/kb/251192/ja
    2009年7月12日 15:29

すべての返信

  • DBには接続できているとのことですから、SQL Serverへの認証はできていると思います。
    ただ、それはあくまでも稼働しているSQL Serverの中への認証であって、SQL Serverのサービス自体の開始・停止などについては、そのSQL Serverが稼働しているWindows上の権限が関係あるように思います。
    試しに、リモートクライアント側のWindowsに、SQL Serverが稼働するWindowsのAdministratorsアカウントと同じものでログインし、その状態でリモートのSQL Serverのサービスが開始・停止できるかどうかやってみてはどうでしょうか?

    上記でもダメなら、以下のページに記載されているsc.exeも参考になると思います。

    Sc.exe を使用して Windows サービスを作成する方法
    http://support.microsoft.com/kb/251192/ja
    2009年7月12日 15:29
  • 有難う御座いました。
    確かに、WMIのエラー等も出たので、windows認証系のエラーだった様子です。
    イメージから戻したり、ドメインへ入れたり抜いたり等、何度もやっていたので、そこら辺が壊れたみたいです。

    もうOSからやり直したら、一発で解決しました。
    そちらに考えを向ける事が出来なかったので、発想の転換に至る事が出来て、感謝しています。
    2009年7月13日 14:36
  • こんにちは。フォーラムオペレーターの高橋春樹です。

    CrimsonPorkさん、初めまして。
    アドバイスありがとうございました。

    ヘルプ。。。さん、初めまして。
    MSDNフォーラムのご利用有難うございます。

    問題が解決したようなので、大丈夫と思いますが、
    CrimsonPorkさんの投稿に、回答マークを付けさせて頂きました。
    もしかすると、ヘルプ。。。さんが回答マークを付けた時、サーバの調子がおかしかったので、
    うまく回答マークを付けることが出来なかったのでしょうか・・・
    ご迷惑をお掛けしてすみません。

    もし、回答マークが不適切な場合は、削除することも可能なので、そのときはよろしくお願いします。


    マイクロソフト株式会社 フォーラム オペレータ 高橋春樹
    2009年7月21日 8:23