none
Visual Studio 2010 Professionalでウォッチウィンドウが表示できない RRS feed

  • 質問

  • ◇環境
    ------------------------------
    OS:Windows 7 Ultimate Service Pack 1 (64bit版)
    プロセッサ:Intel Core i5-2400S @2.50GHz
    実装メモリ:8.00 GB
    Visual Studio 2010 Professional Version 10.0.40219.1 SP1Rel

    ◇起こっている問題

    ------------------------------
    デバッグ用のウィンドウにウオッチウィンドウやその他いくつか本来表示されるべきウィンドウが表示されません。
    表示されるのは下記の画像の通り、イミディエイトウィンドウやローカル変数のみで、自動変数やウォッチと
    いった本来表示されるべきデバッグ用ウィンドウが表示できません。

    この問題に対して何か解決策はありますでしょうか?

    ヒント・アドバイス等どのような情報でも結構です。お寄せいただければ幸いです。
    どうかよろしくお願いいたします。

    2012年5月15日 22:14

回答

  • これが発生する原因はわかりませんが、
    とりあえず必要な機能を呼び出すには、
    「ツール」の「ユーザー設定」の「コマンド」タブを開き
    「デバッグ」項目を選択。
    必要な機能(ウォッチ等)を標準ツールバー等にドロップすれば、
    機能すると思います。
    2012年5月16日 0:48
  • メニューに表示されないのが問題なのでしょうか、それともウォッチウインドウを利用できないのが問題なのでしょうか。

    メニューに表示されないほうは、ちょっとわからないです。とりあえず、Visual Studioのツール→設定のインポートとエクスポートから全ての設定をリセットしたらどうなりますか?

    単に表示したいだけであれば、適当な変数をウォッチに追加すれば表示されます。

    また、コマンドウインドウもしくはイミディエイトウインドウで、>watchとか、>autosとかタイプして上げれば表示されます。

    2012年5月16日 1:00

すべての返信

  • Visual Studio の環境設定をデフォルトから作り直したら解消しないでしょうか。

    参考:
     Missing menu options in Visual Studio 2005? - Blog
     http://blogs.vertigo.com/personal/keithc/Blog/Lists/Posts/Post.aspx?List=be6e3098-107d-4252-b250-528b490370c0&ID=16
     ※Visual Studio 2005 向けの内容ですが、Visual Studio 2010 でも同じです。
    2012年5月16日 0:39
  • これが発生する原因はわかりませんが、
    とりあえず必要な機能を呼び出すには、
    「ツール」の「ユーザー設定」の「コマンド」タブを開き
    「デバッグ」項目を選択。
    必要な機能(ウォッチ等)を標準ツールバー等にドロップすれば、
    機能すると思います。
    2012年5月16日 0:48
  • メニューに表示されないのが問題なのでしょうか、それともウォッチウインドウを利用できないのが問題なのでしょうか。

    メニューに表示されないほうは、ちょっとわからないです。とりあえず、Visual Studioのツール→設定のインポートとエクスポートから全ての設定をリセットしたらどうなりますか?

    単に表示したいだけであれば、適当な変数をウォッチに追加すれば表示されます。

    また、コマンドウインドウもしくはイミディエイトウインドウで、>watchとか、>autosとかタイプして上げれば表示されます。

    2012年5月16日 1:00
  • 中澤さん、有難うございました。
    これでやってみて無事に出るようになりました。

    メニューは「ツール」→「カスタマイズ」でした。

    とても助かりました。心よりお礼申し上げます。

    2012年5月16日 2:26
  • かるあ様。
    アドバイス有難うございました。
    >autosで自動変数ウィンドウも表示されるようになりました。
    有益なアドバイス有難うございました。

    2012年5月16日 2:30
  • アドバイス有難うございました。

    恐らく(完全に確認したわけではないのですが)、これを発生させた原因はVisual Studio 2008の環境をインポートしたのがきっかけだったと思います。

    2012年5月16日 2:31