none
Visual Basic 2010でコードを実行すると「ビルドエラーが発生しました」と表示される RRS feed

  • 質問

  • エラー一覧から転記した内容です。

    説明: 文字列定数の終わりには、二重引用符を指定しなければなりません

    ファイル: AssemblyInfo.vb

    実際のコード: <Assembly: AssemblyCompany("b****g

    会社名のところで文字化けをおこしていました。解決方法がありましたら教えてください。


    ptinage
    2010年10月26日 1:50

回答

  • その文字化けをしている個所をエディタで修正することで回避できないのでしょうか?

    それと、関係ないかもしれませんが、過去に以下の話がありました。

    VS2010 Professional評価版、AssemblyInfo.vbで"文字列定数の終わりには、二重引用符を指定しなければなりません。"が出てしまう.
    http://social.msdn.microsoft.com/Forums/ja-JP/vsfeedbackja/thread/f6073eef-d81d-4d0e-be94-5a845d3ae6a8

    • 回答としてマーク ptinage 2010年10月27日 4:00
    2010年10月26日 2:10
  • プロジェクトのプロパティ⇒「アプリケーション」⇒<アセンブリ情報(Y)>ボタン⇒会社(C)

    このテキストボックスに、入力してみてください。
    ここに入力してエラーが出なければ、一般的にはコンパイルも通ると考えられます。
    まずは、プロジェクトの上記の項目を確認してください。

    • 回答としてマーク ptinage 2010年10月27日 4:11
    2010年10月26日 2:13

すべての返信

  • その文字化けをしている個所をエディタで修正することで回避できないのでしょうか?

    それと、関係ないかもしれませんが、過去に以下の話がありました。

    VS2010 Professional評価版、AssemblyInfo.vbで"文字列定数の終わりには、二重引用符を指定しなければなりません。"が出てしまう.
    http://social.msdn.microsoft.com/Forums/ja-JP/vsfeedbackja/thread/f6073eef-d81d-4d0e-be94-5a845d3ae6a8

    • 回答としてマーク ptinage 2010年10月27日 4:00
    2010年10月26日 2:10
  • プロジェクトのプロパティ⇒「アプリケーション」⇒<アセンブリ情報(Y)>ボタン⇒会社(C)

    このテキストボックスに、入力してみてください。
    ここに入力してエラーが出なければ、一般的にはコンパイルも通ると考えられます。
    まずは、プロジェクトの上記の項目を確認してください。

    • 回答としてマーク ptinage 2010年10月27日 4:11
    2010年10月26日 2:13
  • 回答ありがとうございます。

    エディタで修正はできるのですが他のプロジェクトを新規に作成すると同じ現象を起こします。

    Windowsの使用者と組織名ををレジストリで修正・再入力しましたら直りました。

    ありがとうございました。

     


    ptinage
    2010年10月27日 4:04
  • 会社情報の設定をどこでやるのか探し出せませんでした。

    プロジェクトのプロパティ⇒「アプリケーション」までいったのですが、その先の<アセンブリ情報(Y)>ボタン⇒会社(C)

    までいけませんでした。

    ありがとうございます。


    ptinage
    2010年10月27日 4:14
  • ptinage様

    C#の駆け出しです。AsemblyCampany("       ") とCopyright("      ")で文字化けのため

    エラーが発生する現象は、全く同じと思いますので、以下の処理方法を教えて頂けませんか。

      <<エディタで修正はできるのですが他のプロジェクトを新規に作成すると同じ現象を起こします。

      <<Windowsの使用者と組織名ををレジストリで修正・再入力しましたら直りました。

    つまりWindowsの使用者と組織名をレジストリで修正・再入力の方法をご教示下さい。

    レジストリに手を入れたことがありません。フォーラムの使い方もよくわかりません。

    よろしくお願いいたします。


    akimi
    2010年12月13日 4:25
  • akimi さんのスレッドの方に書かせてもらいました。

    初めてのプログラムでエラーです。
    http://social.msdn.microsoft.com/Forums/ja-JP/csharpexpressja/thread/cf675d97-a884-458b-a945-8529ef1f2b61/

    質問者さんがずっと自分のスレッドを見られているとは限らないので、古いスレッドには返信されない方がいいです。

    2010年12月13日 8:14
  • TH01様

    早速アドバイス有り難うございました。原因が同じ内容と判断しましたので、レジストリの書き換えについて安易に質問いたしました。古い本を読みレジストリの書き換えが出来ました。会社名に「***」と入れておりましたので、AssemblyInfo.vcで文字化けが発生しエラーとなった模様です。会社名を「akimisoft」こしたところ、順調にコンパイルされました。れで問題全て解決です。

    色々アドバイス有り難うございました。フォーラムについても全くの無知で御迷惑をお掛けいたします。これからもよろしくご指導をお願いいたします。


    akimi
    2010年12月13日 11:52