none
Edgeでのみ起こる不具合-動画が無効なソースと表示される RRS feed

  • 質問

  • ホームページで複数の動画を掲載しています。一つ目は問題なく再生されるのですが、二つ目以降は「無効なソース」と表示されてしまいます。どの動画を選んでも一つ目は再生されます。海外も含めて複数のPCで検証しましたが、どのPCでも同じ現象がおこります。海外では「Invalid source」と表示されるようです。

    HP制作会社に依頼して作成したHPですが、制作会社の方でも原因が解明できないとのこと。元々mp4ファイルでしたが、ogvファイルに変換しても改善されませんでした。

    尚、Chrome, IE, Mac等、他のブラウザでは問題なくすべての動画が再生できますし、Wixで作成した他のHPyoutubeではこのような現象はおこりません。

    一つ目は再生されるのに、2つ目以降がダメという現象はどんなにサーチしても見つかりません。原因や解決法をご存知の方がいらしたら教えていただけないでしょうか。

    アカウントが確認されるまで、本文に画像やリンクを含むことはできません。とのメッセージがでましてサイトURLが本文に入れられませんでした。


    2019年3月3日 9:49

すべての返信

  • URL にハイパーリンクを設定せずプレーンテキストとして投稿してください。

    またはこちらで解除を申請してください。

    参考:本文に画像やリンクを含むことが出来ませんというエラーについて


    Hebikuzure aka Murachi Akira


    2019年3月3日 9:55
    モデレータ
  • ありがとうございます。気が付きませんでした。こちらがリンクです。

    http://www.kens.co.jp/component/users/?view=login&Itemid=435

    お手数ですが下記IDとパスワードでログインしてください

     ログインID152740 パスワード:5812

    前述の現象が起きるのは一番上の、「キッズ学習用ビデオ」です。

    2019年3月3日 10:21
  • ログインすると

    http://www.kens.co.jp/component/users/profile?Itemid=435

    が表示されますが、「キッズ学習用ビデオ」が見当たらないですね。



    Hebikuzure aka Murachi Akira

    2019年3月4日 5:52
    モデレータ
  • 失礼しました。

    TOPメニューの「英語学習ページ」→「各種ボキャブラリー&お役立ちフレーズ」と進んでいただくと、ページの一番上に、「キッズ学習用ビデオ」が表示されないでしょうか。

    もしくは、ホームの、 http://www.kens.co.jp/ から、「英語学習ページ」→「各種ボキャブラリー&お役立ちフレーズ」でログイン画面が表示されます。

    お手数をお掛けして申し訳ありません。

    どうぞ宜しくお願い申し上げます。

    2019年3月4日 9:40
  • http://www.kens.co.jp/learning/vocabulary

    の動画ということですが、"(1) Play all" の連続再生は問題なく2番目3番目の動画が再生されますし、他の動画も問題なく再生できますね。

    Edge のというより何か他の環境に依存する問題があるのではないでしょうか?

    念のため手元のEdge のバージョンは以下の通り。


    Hebikuzure aka Murachi Akira


    2019年3月4日 11:57
    モデレータ
  • ご指導ありがとうございます。

    当方のバージョンはMicrosoft EdgeHTML 17.17134です。

    私のPCのみだけでなく、海外を含め6台のPCで同じ現象が起きています。

    皆エンジニアのようなプロではなく、一般のユーザーですので、PC購入後、初期設定のまま使用しているものと思われます。

    Updateなども、起動時の自動更新まかせで自分ではアクションをしたことはありません。そのあたりに起因しているのでしょうか。

    再度検証してみましたが、やはり、2つ目以降は「無効なソース」と表示されてしまいます。

    このサイトを利用するのは主に小学生ですが、問題解決まで他のブラウザで閲覧するようお願いしております。

    保護者の方にお願いして、Edgeでの再生に不具合がないかどうか聞いてみます。

    色々ありがとうございました。

    

    2019年3月4日 14:44
  • 度々申し訳ありません。一つ補足と確認をさせてください。

    「無効なソース」と表示されるのは、一つ目の動画を途中で静止して、次のビデオの再生ボタンを押した場合です。

    最後まで再生して次に移る場合は問題なく試聴できます。

    他のブラウザでは、どちらの場合も問題なく再生されます。

    Murachi様のPCでは、一時停止後も、次の動画は問題なく再生されるのでしょうか。

    説明不足で申し訳ありませんでした。

    2019年3月4日 14:57
  • ご覧のように1番目の動画を一時停止して、2番目の動画を再生、さらに2番目の動画を一時停止して3番目の動画を再生、の操作で期待通り動作しています。


    Hebikuzure aka Murachi Akira

    2019年3月5日 1:29
    モデレータ
  • 早速のご返信ありがとうございます。

    確かに再生されていますね。 ますますわからなくなってしまいました。

    NECに修理を依頼して初期設定したばかりの、比較的新しいPCが1台ありますので

    そちらでも改めて検証してみます。

    ありがとうございました。

    2019年3月5日 3:12
  • Edge のバージョンが私の手元より古い(Windows 10 1803 のバージョン)ようなので、可能であれば最新状態(Windows 10 1809 の環境)で試されると良いでしょう。


    Hebikuzure aka Murachi Akira

    2019年3月5日 4:08
    モデレータ
  • 動作報告だけですが、
    途中で止めて次の動画を見たとしても、エラー無く再生されることを確認しました。
    音が出ない?と思いましたが全画面化した際に、調整ボタンが出て音が出ることも確認できました。

    Microsoft Edge のバージョンは、Hebikuzure aka Murachi Akira 様と同じです。
    Windows 10 Pro 1809 です。


    2019年3月6日 6:27