none
アプリケーションのインストールが失敗します。[install.res.???.dll] RRS feed

  • 質問

  • 実行環境:
    [問題あり]No1. Windows server 2012 R2 Standard Build9600 (64bit) 英語
    [問題なし]No2. Windows 10 (64bit) language 、日本語

    アプリケーションをインストールする際に問題が起きている状態です。

    状況:
    No.2の環境ではインストール出来た事を確認しています。
    さらに、アプリケーションをインストールする際に言語を選択する事が出来るので、OS言語設定上の問題ではないと考えています。
    失敗する際に" install.res.???.dll "とエラーウィンドウが出力されます。

    インストール画面:

    以下のVisual C++ 2008をインストールし直しました。[EN/JA]
    ・Microsoft Visual C++ 2008 Redistributable Package (x64) 
    " https://www.microsoft.com/en-US/download/details.aspx?id=15336 "
    ・Microsoft Visual C++ 2008 SP1 Redistributable Package (x64)
    " https://www.microsoft.com/en-us/download/details.aspx?id=2092 " 

    それでも問題は解決しませんでした。
    ログを参考に調べてはいるのですが、他の解決方法が見当たらない状況になっています。
    [C:\Users\(user_name)\AppData\Local\Temp]
    [10/15/18,09:16:46] ========== Logging started ==========
    [10/15/18,09:16:46] =====================================
    [10/15/18,09:16:46] Failed to set lang to requested lang code 1033
    [10/15/18,09:16:46] Failed to set lang to OS language 1033
    [10/15/18,09:16:46] ***ERROR EVENT*** : Failed last resort to set lang to ENU - no resources
    [10/15/18,09:16:47] =========== Logging ended ===========
    [10/15/18,09:16:47] =====================================
    [10/15/18,09:16:47]  
    [10/15/18,09:16:47]  
    [10/15/18,09:16:47]  

    よろしくお願いいたします。

    https://social.msdn.microsoft.com/Forums/en-US/1660d65c-cdee-4700-b4b1-3365e9ba77e2/couldnt-i-install-the-app-made-in-japan?forum=visualstudiogeneral
    英語で同じ質問をしていますが、私自身の時差の関係で高レスポンスが難しいので、日本語でも投稿させて頂いてます。
    2018年10月15日 2:09

回答

  • Tanko55 さん、こんにちは。フォーラム オペレーターの立花です。
    MSDN フォーラムへご投稿くださいましてありがとうございます。

    複数のフォーラム (日本語と英語など) に投稿されますと、
    折角調査して回答いただいたのに、すでに他のフォーラムで
    解決済みだった、などの状況が生じてしまいます。

    ご事情があるとは思いますが、既に英語のフォーラムでやり取りがありますので、
    よろしければ、そのまま英語のフォーラムでご質問をご継続いただけますと幸いです。

    参考になった投稿には回答としてマークの設定にご協力ください
    MSDN/TechNet Community Support 立花楓

    • 回答としてマーク Tanko55 2018年10月15日 2:42
    2018年10月15日 2:27
    モデレータ

すべての返信

  • Tanko55 さん、こんにちは。フォーラム オペレーターの立花です。
    MSDN フォーラムへご投稿くださいましてありがとうございます。

    複数のフォーラム (日本語と英語など) に投稿されますと、
    折角調査して回答いただいたのに、すでに他のフォーラムで
    解決済みだった、などの状況が生じてしまいます。

    ご事情があるとは思いますが、既に英語のフォーラムでやり取りがありますので、
    よろしければ、そのまま英語のフォーラムでご質問をご継続いただけますと幸いです。

    参考になった投稿には回答としてマークの設定にご協力ください
    MSDN/TechNet Community Support 立花楓

    • 回答としてマーク Tanko55 2018年10月15日 2:42
    2018年10月15日 2:27
    モデレータ
  • こちらは、InstallShieldの問題ではありませんか?

    もしそうであれば、InstallShieldのユーザーコミュニティのほうが回答は得られるかもしれません。

    Flexera Community Forums - Forum: InstallShield が、ISのフォーラム(製品ごとに分かれてるようです)なので、一度そちらも確認してみてはいかがでしょうか?

    また、Networld でも FAQ などを出しています。そちらも確認してみるとよいと思います。

    Windows Installer 全般であれば、作成ツールによらず再現性なども確保できますが、特定の製品固有の状況はその製品に詳しいところをたどっていかないといつまでも確実な回答は得られないと思います。


    とっちゃん@わんくま同盟, Visual Studio and Development Technologies http://blogs.wankuma.com/tocchann/default.aspx

    2018年10月16日 5:10