none
IMEが英数固定になる RRS feed

  • 質問

  • VisualStudio2010、C#を使い、自作のアプリを開発中です。

    いつの間にか日本語入力が出来なくなり、困っております。

    textBoxやdataGridView、saveFileDialog等、すべてのコントロールで、英数固定になってしまいます。

    IMEの表示は、「入力方式」「入力モード」「変換モード」「IMEパッド」「ツール」のアイコンがロックされた

    状態(無効状態?)となり、「入力モード」は「 A」の表示になっています。

    以前は日本語が入力できていましたので、知らないうちにどこかを触ってしまったのかと思っています。

    これまで確認したことは、

    ・Formや各ControlのIME Modeプロパティがどのようになっているか? →すべてNoControl

    で、問題ないかと思っています。

    開発用PCはWindowsXP+MS-IME2002+VisualStudio2010

    動作確認用にWindows7+MS-IME2007

    を使用しており、いずれも同じ症状です。

    思い当たる点があれば、指摘いただければ幸いです。

    2011年9月13日 5:41

すべての返信

  • 日本語入力が目的ならばIME ModeをHiraganaなどにすればいいとは思いますが
    2015年1月6日 12:40
  • 試しにTextBoxのみIME Modeを指定するとどうなりますか。

    IME Modeは親コンテナの値をデフォルトで引き継ぎますが、
    デザイナで確認できる箇所以外でIME Modeを変更している箇所はありませんか。

    まず、上記をご確認ください。

    2015年1月7日 15:08
    モデレータ
  • デザイナのどこを触ってしまったかわかり辛い場合、デザイナが生成したコード(FormX.Designer.cs)を直接見てみることをお勧めします。

    そこで「ImeMode.Disable」などの語句で検索してみてはどうでしょうか?

    2015年2月12日 5:31