none
vs2008 インストーラー 作成 RRS feed

  • 質問

  • お世話になります。
    「windows 7(32bit)」にてVS2008で
    「セットアップ プロジェクトの作成」
    「セットアップ処理の実装」を行い
    セットアッププログラムを作成して
    他の「windows 7(32bit)」パソコンにインストルを行った結果
    「WindowsApplicationは動作を停止しました。
    問題が発生したため、プログラムが正しく動作しなくなりました。このプログラムを閉じてください。」というメッセージが表示されてインストルしたプログラムが動作しません
    その他にメッセージ等が表示されていないのでどのように調べたらいいのかがわかりません。

    VS2008の「セットアッププロジェクト」の「見つかった依存関係」には「Micrsoft.Net Framework」しか表示されていません
    作成したプログラムの画面には「TextBox」「Buttom」位しか使用していません
    「SerialPort」はカードリーダの読込に使っています

    何が原因なのかの調べる方法等を教えて頂ければ幸いです。

    2015年6月11日 5:40

回答

  • お世話になります。

    ご回答ありがとうございます。

    DBへのコネクトがうまくできないので
    プログラムが動かなかったようです

    セットアップが原因ではありませんでした。

    宜しくお願いします。

    • 回答としてマーク 星 睦美 2015年6月17日 1:27
    2015年6月13日 10:33

すべての返信

  • こんにちは。 作成したインストーラは、そもそもその作成したWin7端末では、セットアップに成功しますか?
    2015年6月11日 10:03
    モデレータ
  • イベントログを見て、プログラムが不正終了された時刻近辺に情報が残っていないか見てください。

    この手の問題が起きるのは、必要なランタイム、ライブラリなどが足りていないとき、設定ファイルなどの必要な要素がインストールされていないとき、開発環境とファイルの位置関係が違うことで例外が起きるときなどです。

    2015年6月11日 13:41
    モデレータ
  • 単にアレじゃないですか、setupをしたらProgram Files以下にexeが配置されたりして
    起動時の「カレントフォルダへの書き込み」がエラーになったりしただけでは、、、

    リモートデバッガを当ててみて確かめる手がありますが。
    https://msdn.microsoft.com/ja-jp/library/vstudio/bt727f1t(v=vs.90).aspx

    jzkey

    2015年6月11日 14:17
  • インストーラの実行結果がエラーだというものだと勘違いしておりました。
    インストール成功後の実行結果なのですね。失礼いたしました。

    Azuleanさんが仰られているように、まずはログの確認からでしょうか。

    2015年6月11日 14:37
    モデレータ
  • お世話になります。
    ご回答ありがとうございます。

    開発したパソコンでは
    セットアップに成功します

    宜しくお願いします。

    2015年6月12日 6:26
  • お世話になります。
    ご回答ありがとうございます。

    イベントログを見ても情報は残っていませんでした。

    ご指摘いただいたように
    設定がインストールされていないことだとは
    思います。

    宜しくお願いします。

    2015年6月12日 6:29
  • お世話になります。
    ご回答ありがとうございます。

    リモートデバッガを
    試そうとしていますが
    上手く動かないので
    悪戦苦闘しています。

    宜しくお願いします。

    2015年6月12日 6:33
  • 単純にプロジェクトのフォルダーを丸ごとコピーし、binフォルダ以下にあるexeを実行したらどうなりますでしょうか?
    ここで動作するかしないかでセットアップの問題なのかどうかが切り分けられるかもしれません。
    ご質問文から「SerialPort」が怪しいような気がしないでもありません・・・

    ★良い回答には回答済みマークを付けよう! MVP - .NET  http://d.hatena.ne.jp/trapemiya/

    2015年6月12日 7:29
    モデレータ
  • お世話になります。

    ご回答ありがとうございます。

    DBへのコネクトがうまくできないので
    プログラムが動かなかったようです

    セットアップが原因ではありませんでした。

    宜しくお願いします。

    • 回答としてマーク 星 睦美 2015年6月17日 1:27
    2015年6月13日 10:33