none
サーバー構築の際にデータ層エラー RRS feed

  • 質問

  • お世話になります。

    こちらで合っているか定かではないのですが投稿させていただきます。

    現在[Team Foundation Server 2015]にてVBAのバージョン管理を

    することはできないか検証しようとしています。

    そのためにサーバー構築からしようとするものの、適合性チェックの

    データ層でエラーとなり構築ができない状態となっています。

    エラーとしては下記となります。

    [TF401159: 指定された SQL Server インスタンス ([PC名]\SqlExpress) はバージョン 9.0.3042.0 であり、使用またはアップグレードできません。サポートされている SQL Server のバージョンの詳細については、http://msdn.microsoft.com/library/dd578592(v=vs.120).aspx を参照してください。 ]

    [SQL Server インスタンス]のアップグレードが必要とのことなのですが、

    どこかでアップグレードできないか探してみても不明で、調べてみても

    わからずで困っています。

    アップグレードする方法を教えていただけると幸いです。

    よろしくお願い致します。

    2016年7月26日 10:23

回答

  • 9.0ということは、SQL Server 2005を使われているようですね。TFS2015がサポートするのはSQL Server 2012 SP1以降なので、アップグレードする必要があります。

    あとSQL Server 2005はサポートが終了しているので、セキュリティパッチも提供されません。 リテール版(MSDNではない)TFSを買っている場合はSQL Serverのライセンスが付属しているはずです。

    しかし、残念ながらVBAのバージョン管理をTFsで行うことはできません。Excelファイルの履歴を保存するということならできますが、C#やVB.NETのようなコードの差分を比較するということはサポートされていません。


    Thanks, K.Kamegawa (http://kkamegawa.hatenablog.jp/)


    2016年7月27日 3:38