locked
Silverlight Tools RC0 RRS feed

  • 質問

  • フォーラムで質問する内容ではないかもしれませんが、回答いただけるのは結局マイクロソフトの社員の方みたいなので
    こちらで質問させていただきます。

    Silverlight Tools RC0をインストールしようとしたのですが、注意事項としてBlendのプレビュー版をアンインストール
    しないとならないようです。
    現状、Blend 2.5はプレビュー版しか出ていないようなので、RC0をインストールすると正式版のリリースまで Blend が
    使えなくなってしまうということでしょうか?
    (Blend 2はまだ Silverlight 1しかサポートしていないので実質 Blendは使えないということですよね?)
    2008年11月6日 11:05

回答

  • どうもありがとうございました。

    Blend 2 SP1 / Tools RC0でビルドし直したところ、表示できるようになりました。
    2008年11月9日 9:32

すべての返信

  • Silverlight 2 RTW用にアプリケーションを開発するにあたり、現時点では、日本語のVisual Studio 2008用にはSilverlight Tools RC0が必要で、Blendについては、Blend 2 SP1日本語版をご利用ください。これによりSilverlight 1サイト、Silverlight 2アプリケーション、それぞれの開発ができます。

    http://www.microsoft.com/downloads/details.aspx?FamilyID=eb9b5c48-ba2b-4c39-a1c3-135c60bbbe66&DisplayLang=ja

     

    Blend 2 SP1の日本語版が先月末に出たばかりということもあり、これからフォーラムの書き込みが活発になればと期待しています。


     この投稿は現状のまま何の保証もなく掲載しているものであり、何らかの権利を許諾するものでもありません。コミュニティにおけるマイクロソフト社員による発言やコメントは、マイクロソフトの正式な見解またはコメントではありません。詳しくは http://www.microsoft.com/japan/communities/msp.mspx をご覧ください。

    2008年11月6日 14:55
  • ご回答、どうもありがとうございます。

    Blend 2 SP1ですが、試用版のBlend 2 にSP1のパッチをあてたものでも、Silverlight Tools RC0に対応していますでしょうか?(プレビュー版はNGだけれども、試用版ならOK?)
    また11月にBlend 2.5の製品版が発売になるようなことを聞いたのですが、Blend 2 SP1より機能が増えているのでしょうか?

    それと、今回ご回答いただいた内容が、別のスレッドで質問した件に関連していそうなので改めて質問させていただきます。

    Silverlight 2 RTW用には
    RC0での開発が必要とのことですが、旧バージョンのSilverlight Tools環境で作ったコンテンツをRTW(2.0.31005.0)のクライアント上で動作させようとするとダウンロードバナーが表示されてしまい、古いバージョン(2.0.30523)のプラグインを要求されてしまうのですが、もしかしてこれが原因でしょうか?
    2008年11月7日 9:27
  • Blend 2.5 Previewと呼んでいたものは、今はBlend 2 SP1と呼ばれています。Silverlight Tools RC0に対応しています。

    Blend 2.5というものは登場しません。公開されているBlend 2 SP1が最新のExpression Blendです。試用版でも動作します。

     

    Beta 2用のSilverlight Toolsが生成する<object>タグの記述と、RC0/RTW用のSilverlight Toolsが生成するものが変わっています。次の例を参考にして違いを見つけてください。

     

        <div id="silverlightControlHost">
      <object data="data:application/x-silverlight-2," type="application/x-silverlight-2" width="100%" height="100%" id="SilverlightControl">
       <param name="source" value="ClientBin/HtmlBridge02.xap"/>
       <param name="onerror" value="onSilverlightError" />
       <param name="background" value="white" />
       <param name="minRuntimeVersion" value="2.0.31005.0" />
       <param name="autoUpgrade" value="true" />
       <a href="http://go.microsoft.com/fwlink/?LinkID=124807" style="text-decoration: none;">
            <img src="http://go.microsoft.com/fwlink/?LinkId=108181" alt="Get Microsoft Silverlight" style="border-style: none"/>
       </a>
      </object>
      <iframe style='visibility:hidden;height:0;width:0;border:0px'></iframe>
        </div>

     


     この投稿は現状のまま何の保証もなく掲載しているものであり、何らかの権利を許諾するものでもありません。コミュニティにおけるマイクロソフト社員による発言やコメントは、マイクロソフトの正式な見解またはコメントではありません。詳しくは http://www.microsoft.com/japan/communities/msp.mspx をご覧ください。

    2008年11月7日 12:04
  • どうもありがとうございました。

    Blend 2 SP1 / Tools RC0でビルドし直したところ、表示できるようになりました。
    2008年11月9日 9:32