none
team foundation server への接続方法 RRS feed

  • 質問

  • 環境

    クライアント:windows7 visual studio 2010 sp1

    サーバ:windows server 2008 r2

    クライアント、サーバー共にインストール済の状態でvisual studio 2010上で

    Team Foundation Server への接続>>接続ダイアログ>>追加>>サーバー名を入力としましたが

    接続が出来ません。

    ポートが解放されていないのかと思いtelnetで8080ポートに接続しましたが何も画面が表示されない(接続出来ませんでしたのメッセージ無し)状態なので解放は出来ていると認識しています。

    ちなみに、 Team Foundation Server の管理ツールで

    urlの変更>>何も変更を加えずにテストをクリックした所

    HTTPステータスコード500でエラーになりました。

    原因がわかる方がいらっしゃいましたら教えて下さい。

    2012年6月15日 7:19

回答

すべての返信

  • >ポートが解放されていないのかと思いtelnetで8080ポートに接続しましたが何も画面が表示されない(接続出来ませんでしたのメッセージ無し)状態なので解放は出来ていると認識しています。

    ブラウザで Team System Web Access は閲覧できているんでしょうか?

    • 回答の候補に設定 山本春海 2012年6月28日 9:09
    • 回答としてマーク 山本春海 2012年7月2日 8:31
    2012年6月20日 1:23
  • ブラウザでの閲覧は出来ませんでした。

    管理画面でのURLテストはNGでした。

    IISでのブラウザでの確認(閲覧)もNGでした。

    IISをアンインストールして、ポートのファイヤーウォール設定も一旦手動で削除して

    インストールしなおしても駄目でした。

    ちなみに他のWin7機にインストールしたら出来ました。

    windows server 2008 r2では正常に出来ないのでしょうか・・

    2012年6月22日 0:31
  • サーバーのイベント ログ等に何か情報は落ちていないのでしょうか?

    以下は、"Windows Server 2008 R2" "tfs" "500 Internal Server Error" で拾った情報です。

    ・64 bit OS 上ではワーカー プロセスも 64 bit でないとダメという話:
      Getting HTTP 500 Internal Server Error after successfull installation
      http://social.msdn.microsoft.com/Forums/en-US/tfssetup/thread/fdf9cf0c-7102-4d73-bb77-aafa7d3b4a0b

      Getting HTTP 500 Internal Server Error with TFS 2010
      http://social.msdn.microsoft.com/Forums/en-US/tfssetup/thread/35510911-55fb-40f4-9cc8-bbddc0263bd9

    ・レスポンス ヘッダーが重複していたという話:
      TFS returns Internal Server Error 500
      http://social.msdn.microsoft.com/Forums/en-US/tfssetup/thread/9b3613ed-09f9-43ca-b145-eee088cff785

    • 回答の候補に設定 山本春海 2012年6月28日 9:09
    • 回答としてマーク 山本春海 2012年7月2日 8:31
    2012年6月22日 1:10
  • >windows server 2008 r2では正常に出来ないのでしょうか・・

    そんなはずはないですね。

    ウチでも会社でも 2008 R2 で動かしてます>TFS2010

    2012年6月22日 14:23
  • こんにちは、ビックル さん。

    MSDN フォーラムのご利用ありがとうございます。オペレーターの山本です。
    その後いかがでしょうか。みなさんからの情報は確認されましたか?

    継続したご質問がないようなので、勝手ながら私の方で参考になったと思われる投稿に一旦回答としてマークさせていただきました。
    渋木宏明 さん、totojo さん、アドバイスありがとうございます。

    ビックル さん、もしまだ解決していない場合には、現在の状況や確認したことなど情報更新してご質問を続けてくださいね。
    今後とも MSDN フォーラムをよろしくお願いいたします。それでは。
    _____________________
    日本マイクロソフト株式会社 フォーラム オペレーター 山本 春海

    2012年7月2日 8:31