none
ヘルプコンテンツのインストールエラー RRS feed

  • 質問

  • ヘルプをオフラインで使用する場合についてご質問させてください。ヘルプライブラリーマネージャーを開いて「オンラインからコンテンツをインストール」をクリックします。すると「オンラインからコンテンツをインストール」という画面が開き、その画面でコンテンツ(例えば「Visual C++」)を追加します。その後、「更新」ボタンをクリックすると「ローカルライブラリを更新しています」という画面が表示されるのですが「パッケージ(6/8)をダウンロードしています」と表示された後で「例外が発生しました。詳細については、イベントログを参照してください。」とのダイアログが表示されてしまいインストールに失敗します。このような状況の解決方法があるようでしたらお教え下さい。また、イベントログとはどこにあるのでしょうか。使用しているのは、Visual C++ 2010 Expressで、OSはWindows7 Professional(64bit)です。よろしくお願いいたします。

    2012年1月24日 4:49

回答

  • 展開を忘れておりました。

    MSDN側で問い合わせ結果が戻ってきてました。

    サーバ側で問題があった部分を修正して、ダウンロードが行えるようになったとの事でした。

    2012年1月30日 9:03

すべての返信

  • http://windows.microsoft.com/ja-JP/windows7/Open-Event-Viewer
    → Windows ログ → アプリケーション という順でしょうか。

    そこにエラーか警告で登録されていると思いますので、その内容を確認してください。

     

    よく聞くのは、認証が必要なプロキシサーバーを使う環境のケースでしょうか。
    これであれば、検索すると回避策がいろいろと出ていますね。


    質問スレッドで解決した場合は、解決の参考になった投稿に対して「回答としてマーク」のボタンを押すことで、同じ問題に遭遇した別のユーザが役立つ投稿を見つけやすくなります。
    2012年1月24日 15:50
    モデレータ
  • ご回答ありがとうございます。お教えいただきました場所にログがありました。内容は、「ローカルコンテンツを更新しているときにエラーが発生しました」ということで、「http://packages.mtps.miscosoft.com/visual_studio_20055766_vs_100_en-us_2(dab2f919-c118-6ad0-63fb-d3e6c7488399).cab」をc:\のディレクトリに転送しているときにエラーが出ているようです。「エラーコンテキストは'RemoteFile'、エラーコードは'0x80190194'です。」と記述されています。ちなみに、インストールの作業を何度か繰り返してそのたびにエラーが出ているのですが、ファイル名が若干異なるもののエラーコード等は毎回同じでした。もし、何かご存じでしたら教えてください。よろしくお願いいたします。

    2012年1月24日 23:49
  • 外していたら申し訳ありませんが、ウィルス チェッカーの類は動いていないですか?

    参考:
    Visual Studio 2010 をインストールする方法
    http://support.microsoft.com/kb/2445557/ja

    Visual Studio 2010 インストールにまつわる FAQ - Visual Studio サポート チーム blog - Site Home - MSDN Blogs
    http://blogs.msdn.com/b/jpvsblog/archive/2012/01/20/visual-studio-2010-faq.aspx
    2012年1月25日 4:21
  • 同じ現象で現在なまやされております。

    とりあえず、複数マシンと複数回線で試してみたのですが、対象のファイルは毎回違いますが、BITSでエラーが発生したといい、「エラー コンテキストは 'RemoteFile'、エラー コードは '0x80190194' です。」とエラーログが毎回記録されております。

    昔にインストールができていたマシンでインストールではなく、更新も試してみましたが、同様のエラーが発生しております。

    あと、今の時間に書き込んでいるのは、RemoteFileエラーがエラーコンテキストで出てきていたので、時間帯によって、ファイルのアクセスサーバ側で追いついていないのかと思い、ずらしてインストールを確認していたのですが、それでも全てのダウンロードが完了するよりも先にエラーが発生します。

    昼間よりは夜の方がエラーが起こるタイミングが遅くはなっているので、サーバ側の問題なのかなぁ~と思っていますが、どうなんですかね?

     

    2012年1月26日 19:28
  • さらに追加。

    MSにインシデントを切って問い合わせを行ったところ、技術担当者の方から、同様の現象があり、サーバサイドで404が出ているとのことで、

    今現在担当部署にてサーバ側の調査を行うとの返答がありました。

    どうにもサーバ側くさい?

    2012年1月27日 9:28
  • sinakuさん、ありがとうございます。エラーログに出力されているサーバー側のファイルのurlをクリックすると404エラーが出たのですが、それが原因だったのですね。しばらく待ってみます。

    2012年1月28日 5:09
  • 再度試してみたところ、問題なくインストール出来るようになっていました。ありがとうございました。

    2012年1月30日 5:03
  • 展開を忘れておりました。

    MSDN側で問い合わせ結果が戻ってきてました。

    サーバ側で問題があった部分を修正して、ダウンロードが行えるようになったとの事でした。

    2012年1月30日 9:03