none
VisualStudio2010 セットアッププロジェクトの必須コンポーネントについて RRS feed

  • 質問

  • VisualStudio2010でセットアッププロジェクトを作成しています。

    .NET Framework 4.0を必須コンポーネントに指定し、インストール場所を「アプリケーションと同じ場所から必須コンポーネントをダウンロードする」を選択しています。

    ビルドも成功し、インストーラーと同じ場所に、DotNetFX40というフォルダが作成され、.NET Framework 4.0と言語パッケージのフルパッケージのインストーラーが作成されました。

    しかし、実際にインストール(OSはWindows7)してみたところ、

    「このセットアップは、.NET Framework バージョン 4.0を必要とします。.NET Frameworkをインストールして、このセットアップをやり直してください。.NET Framework は Webから取得できます。今すぐ取得しますか?」

    というダイアログが出てきてしまい、.NET Framework 4.0のインストールが起動しませんでした。

    どなたか原因および解決法をご存じの方がおりましたら、ご教授いただけると助かります。

    2012年4月26日 5:44

回答