none
SQL Server 2008 EnterpriseEdition SP1 の レポーティングサービスのエラーについて RRS feed

  • 質問

  • Windows Server 2008 R2 Standardedition環境下において、SQL Server 2008 EnterpriseEdition SP1をインストールし、
    レポーティングサービスを使用しております。

    その環境下において、以下のエラーが出力されて困っております。

    ----------------
    ソース:Report Server Windows Service
    イベントID:140
    ユーザー:N/A
    カテゴリ:スタートアップ/シャットダウン
    >>詳細<<
    アプリケーション ドメイン WindowsService_X の初期化に失敗しました
    エラー:Microsoft ReportingServices.Diagonostics.Utilities.ServerConfigurationErrorException: レポート サーバーで構成エラーが発生しました。
    ----------------
    ※ WindowsService_X の部分は0からインクリメントされていきます。

    エラーが出力されるタイミングは以下の通りです。
    ・Reporting Services 構成マネージャ で操作時Reporting Services 構成マネージャで、各設定を変更する

    動作としては問題ないように見受けられます。(http://<servername>/reportserver で確認しています。)


    本エラーは対処する必要はあるでしょうか?

    2010年4月21日 5:21

回答

  • こんにちは、nagino です。

    ちょっと難しい状況のようですね。
    Reporting Services のログや、セキュリティログにはエラーなどの記録がありませんでしょうか。
    また、コンピューター名や Reporting Services のサービスアカウントを変更したことはありませんでしょうか。
    あとは、同じサーバーに何らかのサービス(SharePoint や AD 等)をインストールしていませんでしょうか。

    仮に構成情報に問題があるのではと考えると、Reporting Services 構成マネージャでレポートサーバーの接続やサービスアカウントを構成しなおしてみるというのはいかがでしょうか。

     


    MCITP(Database Developer/Database Administrator)
    • 回答としてマーク 山本春海 2010年5月6日 9:23
    2010年4月23日 13:55

すべての返信

  • こんにちは、nagino です。

    ちょっと私は見たことの無いエラーなので、原因や、対処する必要があるかどうか、といったことは分かりませんが、以下のケースと類似しているように見受けられます。
    http://social.msdn.microsoft.com/Forums/en/sqlreportingservices/thread/61d77397-8bf4-4d33-bf2b-092c22e0c8ed

    確認するとなると、本ケースでは Windows Server 2008 と SQL Server 2008 の組み合わせなので、Reporting Services のサービスアカウントが SQLServerReportServerUser$<コンピューター名> というローカルグループに属しているかどうか、でしょうか。

     


    MCITP(Database Developer/Database Administrator)
    2010年4月22日 14:52
  • nagino様

    ご意見ありがとうございます。
    Reporting Serviceのサービスアカウント( test-admin:ドメインユーザ(administratorsに所属))は
    ご提示いただいたSQLServerReportServerUser$グループにすでに所属しておりました。


    情報が五月雨になってしまい申し訳ございませんが、追加で以下のようなログも発生しておりました。

    ----------------------------------------------------
    ソース:           SQL Server Reporting Services (MSSQLSERVER)
    イベント ID:       0
    ユーザー:          N/A
    カテゴリ:      なし
    >>詳細<<
    アプリケーション ドメイン DefaultDomain を読み込めませんでした。次の例外が発生しました:
    appdomain をアンロード中にエラーが発生しました。 (HRESULT からの例外: 0x80131015)。
    ----------------------------------------------------

    本ログが出力されるのは以下のタイミングです。

    (1)SP1を当てた時
    (2)Reporting Services 構成マネージャ で操作時Reporting Services 構成マネージャで、各設定を変更したとき
       ※ただし、出ない場合もある。


    よって、イベントID0と140の2つが出力されている状況です。

    引き続きご意見お待ちしております。もちろんこちらでも引き続き調査いたします。

     

    2010年4月23日 6:15
  • こんにちは、nagino です。

    ちょっと難しい状況のようですね。
    Reporting Services のログや、セキュリティログにはエラーなどの記録がありませんでしょうか。
    また、コンピューター名や Reporting Services のサービスアカウントを変更したことはありませんでしょうか。
    あとは、同じサーバーに何らかのサービス(SharePoint や AD 等)をインストールしていませんでしょうか。

    仮に構成情報に問題があるのではと考えると、Reporting Services 構成マネージャでレポートサーバーの接続やサービスアカウントを構成しなおしてみるというのはいかがでしょうか。

     


    MCITP(Database Developer/Database Administrator)
    • 回答としてマーク 山本春海 2010年5月6日 9:23
    2010年4月23日 13:55