none
silverlightアプリケーションのazureへのデプロイ方法 RRS feed

  • 質問

  • お世話になっております。かもがわと申します。

    タイトルそのままになりますが、silverlightのアプリケーションをazureにデプロイする方法がわかりません。

    開発環境は、

    OS:Windows 7

    言語:visual stuio 2010

        silverlight4 toolsおよびVSCloudService、VsCloudService.VS100.ja-jp.msi

           をインストール済です。

     

    現在まで、以下を行いました。

    ①silverlightを使用しているページを用意する。

      (最初なので特に凝ったことはしておらず、HELLO WORLDと同レベルのページです。)

    ②cloudプロジェクトを新規作成する。

    ③②のプロジェクトのロールにWeb Roleプロジェクトを追加する。

       (②のプロジェクトのロールの項目に③のプロジェクトが記述されている事を確認した)

    ④①のファイルを、③のプロジェクトのフォルダに配置する。(フォルダごとコピーしている。)

    ⑤③のプロジェクト下に、①のページが存在する事をソリューションエクスプローラで確認できる状態で

       ③のWebRoleで初期表示ページを①のページに設定する。

       (プロジェクトのプロパティのWEBタブの「開始動作-ページを指定する」の箇所に①のsilverlightのページを指定する)

    ⑥③のプロジェクトをスタートアッププロジェクトに設定した。

       「デバッグ開始」にてテスト実行すると、silverlightを使用したページが表示されることを確認した。

    ⑦プロジェクトをビルドし、その後発行し「サービスパッケージだけを作成」を実行します。

    ⑧以上を行いWindows Azure Platformから   パッケージファイルとコンフィグファイルをデプロイした。

     

    この手順を行いましたが、azureのデプロイしたページを開くと

    silverlightでないページ(③で作成されたWeb Roleプロジェクトのdefault.asp)が表示される状態です。

    どのようにすればazureでsilverlightのページを開くことができるでしょうか?

     追記1:プロジェクトを作成するときは、visual basicで作成しています。

     追記2:azureのページを開くと、WebRoleを新規作成したときに作られた

             Default.aspxが表示されますb。




    2011年4月18日 4:57

すべての返信

  • こんにちは。

     

    おそらく既定のドキュメントに設定されていないだけと思います。(ファイル名まで指定すれば表示される前提ですが)
    プロジェクトのプロパティの開始動作はVisual Studio上での実行時の動作ですので、サーバー側の処理とは関連がありません。

    ファイル名を指定しない場合の既定のURL ( http://*.cloudapp.net/ へのアクセス等)で表示されるページを変える場合はWeb.configで設定することでできると思います。

    http://technet.microsoft.com/ja-jp/library/ee431582.aspx

    以下引用です

    <configuration>
      <system.webServer>
       <defaultDocument enabled="true">
    
         <files>
          <add value="home.html" />
         </files>
       </defaultDocument>
      </system.webServer>
    </configuration>

     

    2011年4月18日 5:05
    モデレータ
  • こんにちは、

    Webロールのプロジェクトを含んだソリューションを作成してから、そのソリューション内にSilverlightプロジェクトを新規で追加してはいかがでしょうか?

    Silverlightプロジェクトを作成する際にホストするWebプロジェクトを選択する必要があるので、そこでWebロールのプロジェクトを選択します。

    そうすれば、自動的にホストされてSilverlightが見えるようになるかと思います。

    2011年4月18日 6:29
  •  

    返信ありがとうございます。かもがわです。

    Web.Configを修正してみましたが、結果は同じでした。

    ---------------------------------------------------------------------

      <system.webServer>
         <modules runAllManagedModulesForAllRequests="true"/>

       
        <defaultDocument enabled ="true" >         ←ここから
          <files>
            <add value="Test.html"/>
          </files>
        </defaultDocument>                                ←ここまでを追記
      
      
      
      </system.webServer>

    ---------------------------------------------------------------------

      silverlightのページを直接add values=の中に設定しても

    add values="Test.html"として、silverlightのページのファイル名をTest.htmlに修正しても同じでした。

    これはこれで必要な修正だと思いますが、何か別に足りないものがあるようです。

     

     

    2011年4月18日 10:52
  • 返信ありがとうございます。

    silverlightのページを後から追加する方法ですね。

    挑戦してみます。

     

    2011年4月18日 10:58
  • おせわになっております。かもがわです。しばらく挑戦できず申し訳ありません。

    silverlightアプリケーションを追加しましたら、動くようになりました。

    やはりhello worldレベルのことですazure上でsilverlightが動きました。

     

    ありがとうございました。

    2011年4月28日 7:02