none
認証プロキシ経由のVisualStudioOnlineへの接続 RRS feed

  • 質問

  • Visual Studio Online上に作成したプロジェクトを利用したいのですが、
    私のネットワーク環境では認証を必要とするプロキシが設置されており、
    開発ツール(VisualStudio)やExcelから接続することができません。

    このような認証を必要とするプロキシがある状態で、下記のツールで接続する方法をご存知の方がいましたら教えてください。
    ・Visual Studio 2013 (Team Explore)
    ・Excel
    ・Microsoft Project

    よろしくお願いします。

    2014年6月4日 9:07

回答

  • あら、違いましたか。検索したら拡張機能の更新とプログラムから認証情報をVisual Studioにおぼえさせると解決したという記事が有りますね。こちらを試したらどうなりますか?

    http://stackoverflow.com/questions/13717815/visual-studio-error-407-proxy-authentication-required

    • 回答としてマーク wadatka 2014年8月28日 9:41
    2014年6月5日 1:10

すべての返信

  • 外しているかもしれないけれど、、、ProxyサーバーはExpect: 100-continueに対応していますか?

    devenv.configで100-continueを利用しないように設定したらどうなりますか?

    http://karuakun.wordpress.com/2011/01/25/%E6%8B%A1%E5%BC%B5%E6%A9%9F%E8%83%BD%E3%83%9E%E3%83%8D%E3%83%BC%E3%82%B8%E3%83%A3%E3%83%BC%E3%81%A8devenv-exe-config/


    • 編集済み かるあ 2014年6月4日 11:21
    2014年6月4日 11:20
  • 返信ありがとうございます。

    Expect: 100-continueについて、あまり理解が深くないのですが、紹介して頂いた設定を行って試してみましたが、アクセスできませんでした。

    Visual Studioでチームコレクションの接続からサーバの追加を行うと、「リモートサーバーがエラーを返しました:(407)プロキシ認証が必要です」と表示されました。

    なので、切断されるとかではなく認証ができない状態です。
    VisualStudioに認証設定する箇所は存在しているのか、見つけられない状態です。

    2014年6月4日 11:39
  • あら、違いましたか。検索したら拡張機能の更新とプログラムから認証情報をVisual Studioにおぼえさせると解決したという記事が有りますね。こちらを試したらどうなりますか?

    http://stackoverflow.com/questions/13717815/visual-studio-error-407-proxy-authentication-required

    • 回答としてマーク wadatka 2014年8月28日 9:41
    2014年6月5日 1:10
  • VisualStudioからは、アクセスすることができるようになりました。ありがとうございます。

    VisualStudioの設定なので、当たり前ですが、VisualStudioをインストールしたら利用できるExcelのアドオンとかMicrosoftProjectのアドオンからでは接続は無理そうでした。

    同じような設定ができればよかったのですが。


    • 編集済み wadatka 2014年6月5日 6:24
    2014年6月5日 6:23
  • 上の方法でうまくいくならこっちでもどうにかなるかも?

    http://social.msdn.microsoft.com/Forums/sqlserver/en-US/cd5c7877-b7e4-4041-a1d6-feaa33e5e74e/powerpivot-datamarket-place-and-proxy-authentication?forum=sqlkjpowerpivotforexcel

    2014年6月9日 2:20
  • 情報ありがとうございます。

    上の記事の設定を試みたのですが、接続できませんでした。
    ただ、エラーの内容が「407」から変化したので、もう少し設定を変えたり調べてみます。

    エラーメッセージ:
    TF400324: サーバー・・・からはTeam Foundation サービスを使用できません。
    技術情報(管理者):
    リモートサーバーに接続できません。再試行

    ちなみに、上のURLの設定のうち下記のものを「EXCEL.EXE.config」に記載しています。
    「EXCEL.EXE.config」がなかったので、新規ファイルで作成しています。

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
      <system.net>
       <defaultProxy enabled="true" useDefaultCredentials="true" >
         <proxy autoDetect="true" usesystemdefault="true"/>
       </defaultProxy>
      </system.net>
    </configuration>

    2014年6月20日 8:18
  • TF400324 Excelなんかで検索するといくつか引っかかりますね。

    一度検索してみてください。下記のURLではTFSのキャッシュをクリアしたら問題が解消した事例があります。

    http://www.ganshani.com/blog/2014/03/solved-tf400324-team-foundation-services-are-not-available-from-server/

    2014年6月23日 0:53
  • 時間がなかなか確認ができなかったのですが、キャッシュのクリアなども試してみましたが、通信することはできませんでした。

    とりあえずの対処としては、マシンにローカルプロキシのソフトを起動して、それ経由で通信する方式で行うことにしました。
    ローカルのプロキシにユーザー・パスワードを設定しておいて、認証付きプロキシの認証を通る形です。

    将来的にExcelやMSPのアドオンでプロキシ経由する際にユーザー・パスワードを設定できるようになるのを期待します。

    2014年8月28日 9:40