none
Visual Studio Professional 2017がインストールできない RRS feed

  • 質問

  •  経緯:
    元々2018/1くらいに試供版をインストールして使用せずにそのままにしており、
    最近ライセンスを購入して使おうとしました。
    ライセンスの認証もでき、
    使おうと思ったところリソースエディタがなくMFCでのGUI編集ができませんでした。
    リソースエディタをどうすれば入れれるのかが分からなく、
    インストールし直そうと思いアンインストールしようとVisual Studio Installerを起動したところ、
    「準備しています」ずっと出ており数分後に、

     次のパラメーターと一致する製品が見つかりません:
     channelId:  VisualStudio.15.Release
     productId:  Microsoft.VisualStudio.Product.Professional

    と表示され、
    OKボタンを押すと画面上に

     ネットワークに接続されていない可能性があります

    と表示されました。
    ワークロードも表示されません。

    InstallCleanup.exeを使用して削除して見ましたが、
    「すべてのプログラム」にあるショートカットやコントロールパネルにある「プログラムのアンインストールまたは機能」には残ったままになっていました。
    (アイコンはVisual Studioのものでは無くなっていましたし起動もできませんでした)

    「C:\Program Files (x86)\Microsoft Visual Studio\Installer」を削除して再起動してからvs_professional__805842111.1517309706.exeを実行させても
    同じエラーメッセージが出てしまいます

    「C:\Program Files (x86)\Microsoft Visual Studio\2017」フォルダの削除も行いましたが同じでした。

    ネットワークは有線で接続されており、
    インターネットやメール、他社のソフトのアップデートは行えます。

    気になる点としてVisual Studio Installerを起動すると非常に重たくなり、
    タスクマネージャを起動してみるとcom.exe、conhost.exe、vs_instalhersholl.exe、WMIC.exeが大量に起動していました。
    とくにcom.exe、conhost.exeが多かったです。
    これはVisual Studio Installerを落としても増え続けているようで、
    強制再起動をいつもしております。

    もう数日悩んでおりどうしたらいいのかまったくわかりません。
    どなたかお力をお貸しください。
    2018年9月7日 5:07

すべての返信

  • 過去の類似例だと、C:\ProgramData 以下にパッケージに関する情報を保存しているフォルダーがあるということなので、そちらの方かもしれませんね。
    消しすぎに注意

    https://social.msdn.microsoft.com/Forums/ja-JP/44382c35-3dab-4b66-acac-c826fc1d05ef/visual-studio?forum=vsgeneralja

    2018年9月7日 16:27
    モデレータ
  • Azulean 様のご返答で解決できることを願いながら返答します。
    私のは無理やり削除するやり方なので。

    いったん Visual Studio 関連を削除して、まっさらにしたいということですよね。
    以下の記事を読まれた後で、自己責任で、GitHub からダウンロードして実行かと思います。

    Visual Studio 2017 ははっきりとは明記されていませんが、以前私が使った時は消してくれたような記憶があります。
    復元ポイントを作成後にされると安心かもしれません。


    VisualStudioを完全にアンインストールする
    http://blog.livedoor.jp/iincho223/archives/6639660.html

    Visual Studio Uninstaller でvisual studio 2015 を完全アンインストール
    https://qiita.com/yizumi1012xxx/items/b13314c12d5dec627ad7

    2018年9月7日 16:59
  • Azuleanさん

    回答ありがとうございます。返信が遅れてすみません。

    C:\ProgramData\Microsoft\VisualStudioの12.0フォルダ以外を削除してやってみましたが、

    残念ながら変わりませんでした。

    2018年9月11日 5:27
  • sutefu7さん

    回答ありがとうございます。返信が遅れてすみません。

    最初にのアンインストールに10時間近く掛りまして…。

    TotalUninstallerでの実行結果が同じものが出るようになったので完全に全てアンインストールされたと思います。

    この状態でやってみましたが、残念ながら変わりませんでした。

    ウィルスソフトのSymantecを無効にしてみたりしましたが、

    エラーメッセージは同じでした。

    2018年9月11日 5:33
  • 10時間ですか!?お疲れ様です。

    Windows 自体は大丈夫でしょうか?
    大丈夫だとは思いますが、怖いので念のため、そのパソコンに入っているメールなり、アカウント情報なり、社内データをバックアップしておいた方がいいかもです。
    (そこまで考えなくていいかな?)


    確認ですが、ご質問当初の作業は、以下の手順を調べられて、作業されたのでしょうか?
    【-full】オプション付きで実行されたのでしょうか?

    ---------------------------------------------------------------------
    クリーンアップ手順に沿ってVSインストールを再試行してください
    "%programfiles(x86)%\ Microsoft Visual Studio \ Installer \ resources \ app \ layout \ InstallCleanup.exe"というファイルがマシンにあるかどうかを確認してください。
    もしそうなら、adminコマンドプロンプトから-full paramを使って起動してください:
    InstallCleanup.exe -full

    そうでない場合は、手動で "%programfiles(x86)%\ Microsoft Visual Studio \ Installer"フォルダを削除してください
    新しくダウンロードしたvs_enterprise.exe(またはvs_professional.exeまたはvs_community.exe ...)を再起動します。
    最初のステップでインストーラをインストールできるようにする
    インストーラが起動し、ワークロードの選択肢(.netデスクトップなど)を確認したら、閉じる
    同じInstallCleanup.exeを起動してVSの古いビルドをクリーンアップする
    その後、vs_enterprise.exeを再起動し、VSをインストールします。
    ---------------------------------------------------------------------


    それぞれ、最後らへんに出てくる投稿の和訳
    Visual Studio 2017をインストールする際にエラーが表示される
    https://answers.microsoft.com/ja-jp/windows/forum/windows_7-winapps/visual-studio/e1096405-3d1a-46b0-9280-5e18463a6c95
    Visual Studio 2017がエラーが出てしまってインストールできない。
    https://social.msdn.microsoft.com/Forums/ja-JP/44382c35-3dab-4b66-acac-c826fc1d05ef/visual-studio?forum=vsgeneralja


    類似ですがこちらも。
    Visual Studio Express 2017 for Windows Desktop がインストールできない
    https://social.msdn.microsoft.com/Forums/ja-JP/ed2bc379-b942-45fd-b4cd-31e82aee046c/visual-studio-express-2017-for-windows-desktop?forum=vsgeneralja
    社内ネットワークのセキュリティが影響する場合もあるみたいなので、一応載せておきます。
    2018年9月11日 15:19
  • sutefu7さん

    色々と情報をありがとうございます。

    InstallCleanup.exeでのクリーンアップですが、
    【-full】オプション付きで行っています。
    (ちゃんとその事を書いておけばよかったです。すみませんでした)

    一応もう一度やってみましたが、
    何もせずにすぐに終了してしまいました。

    教えて頂いた他の投稿の内容もすでに行っておりました。
    いかんせんエラー後にワークロードが表示されないのでなにもできません。

    ネットワーク環境のせいなのかよく判断できません。
    普通にネットにつながっていますし…。
    ファイヤーウォールの許可プログラムにvs_instalhersholl.exeを追加してみたりしましたが駄目でした。

    ただ、インストールのログをみると
    2018-09-12T19:55:32 : Verbose : Starting the installer service.
    2018-09-12T19:55:40 : Error : Retrying attempted connection to service 'RemoteSettingsClient' - attempt '0'
    2018-09-12T19:55:40 : Error : Retrying attempted connection to service 'SetupUpdater' - attempt '0'
    2018-09-12T19:55:40 : Error : Retrying attempted connection to service 'ProductsProvider' - attempt '0'
    2018-09-12T19:55:40 : Error : Retrying attempted connection to service 'Installer' - attempt '0'
    2018-09-12T19:55:42 : Verbose : FeedbackIpcRpcService listening to ipc channel: FeedbackProxy2018-09-12T19:55:45 : Error : Retrying attempted connection to service 'SetupUpdater' - attempt '1'
    2018-09-12T19:55:45 : Error : Retrying attempted connection to service 'ProductsProvider' - attempt '1'

    と出ており接続がうまくいかなくて何度もリトライを行っているようではありますが。
    49回ほどこのエラーが出ています。

    その後のエラーは下記のようになっています。

    2018-09-12T20:00:04 : Error : Attempted connection to service 'ProductsProvider': location is null
    2018-09-12T20:00:04 : Error : Failed to start the products provider service. error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0 at Error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0
        at SetupEngineAdapter.handleServiceHubError (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\main\StubMain.js:4:369716)
        at <anonymous>
        at process._tickCallback (internal/process/next_tick.js:188:7)
    2018-09-12T20:00:04 : Error : Failed to start the installed products provider service. error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0 at Error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0
        at SetupEngineAdapter.handleServiceHubError (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\main\StubMain.js:4:369716)
        at <anonymous>
        at process._tickCallback (internal/process/next_tick.js:188:7)
    2018-09-12T20:00:04 : Error : Failed to get product summaries. [installerId: SetupEngine, error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0 at Error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0
        at SetupEngineAdapter.handleServiceHubError (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\main\StubMain.js:4:369716)
        at <anonymous>
        at process._tickCallback (internal/process/next_tick.js:188:7)]
    2018-09-12T20:00:04 : Error : Failed to get installed product summaries. [installerId: SetupEngine, error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0 at Error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0
        at SetupEngineAdapter.handleServiceHubError (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\main\StubMain.js:4:369716)
        at <anonymous>
        at process._tickCallback (internal/process/next_tick.js:188:7)]
    2018-09-12T20:00:06 : Error : Attempted connection to service 'Installer': location is null
    2018-09-12T20:00:06 : Error : Failed to start the installer service. error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0 at Error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0
        at SetupEngineAdapter.handleServiceHubError (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\main\StubMain.js:4:369716)
        at <anonymous>
        at process._tickCallback (internal/process/next_tick.js:188:7)
    2018-09-12T20:00:06 : Error : Attempted connection to service 'RemoteSettingsClient': location is null
    2018-09-12T20:00:06 : Error : Remote Settings Ipc Service creation failed.
    error: [HubClientError] connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0 at Error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0
        at Object._errnoException (util.js:1024:11)
        at _exceptionWithHostPort (util.js:1046:20)
        at PipeConnectWrap.afterConnect [as oncomplete] (net.js:1182:14)
    From previous event:
        at Function.defer (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:582:19)
        at netConnect (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\microsoft-servicehub\connect.js:31:22)
        at netConnectWithTimeout (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\microsoft-servicehub\connect.js:42:12)
        at C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\microsoft-servicehub\connect.js:51:44
        at _fulfilled (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:834:54)
        at self.promiseDispatch.done (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:863:30)
        at Promise.promise.promiseDispatch (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:796:13)
        at C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:604:44
        at runSingle (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:137:13)
        at flush (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:125:13)
        at _combinedTickCallback (internal/process/next_tick.js:131:7)
        at process._tickCallback (internal/process/next_tick.js:180:9)
    2018-09-12T20:00:06 : Error : Failed to create VS Telemetry Survey [error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0 at Error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0
        at Object._errnoException (util.js:1024:11)
        at _exceptionWithHostPort (util.js:1046:20)
        at PipeConnectWrap.afterConnect [as oncomplete] (net.js:1182:14)
    From previous event:
        at Function.defer (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:582:19)
        at netConnect (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\microsoft-servicehub\connect.js:31:22)
        at netConnectWithTimeout (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\microsoft-servicehub\connect.js:42:12)
        at C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\microsoft-servicehub\connect.js:51:44
        at _fulfilled (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:834:54)
        at self.promiseDispatch.done (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:863:30)
        at Promise.promise.promiseDispatch (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:796:13)
        at C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:604:44
        at runSingle (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:137:13)
        at flush (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\node_modules\q\q.js:125:13)
        at _combinedTickCallback (internal/process/next_tick.js:131:7)
        at process._tickCallback (internal/process/next_tick.js:180:9)]
    2018-09-12T20:00:06 : Error : Attempted connection to service 'SetupUpdater': location is null
    2018-09-12T20:00:06 : Error : Failed to start the setup updater service. error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0 at Error: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0
        at SetupEngineAdapter.handleServiceHubError (C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\main\StubMain.js:4:369716)
        at <anonymous>
        at process._tickCallback (internal/process/next_tick.js:188:7)
    2018-09-12T20:00:06 : Error : Create shortcut failed: connect ENOENT \\?\pipe\f9eb39ad66a7885bbf7c5b52639720b0587717083a13ee0026c55139a90ca5e0


    このエラー内容で何か分かりますでしょうか。

    申し訳ありませんが
    よろしくお願い致します。


    2018年9月12日 11:34
  • 正直お手上げ状態ですorz
    こじつけ、またはあら探ししか思いつきませんでした。申し訳ないです。


    ■インターネットに接続できることの他に、インストーラーが任意のURLにアクセスできるかどうかという問題があるかなと。
    (以下の記事に記載された大量のドメインに関して、アクセスできるかどうか。ただ以前(2018/1)インストールできたので関係ない気がする)

    Visual Studio をインストールまたは使用するときのネットワーク関連のエラーのトラブルシューティング
    https://docs.microsoft.com/ja-jp/visualstudio/install/troubleshooting-network-related-errors-in-visual-studio?view=vs-2017

    ファイアウォールまたはプロキシ サーバーの内側に Visual Studio および Azure Services をインストールして使用する
    https://docs.microsoft.com/ja-jp/visualstudio/install/install-and-use-visual-studio-behind-a-firewall-or-proxy-server?view=vs-2017

    ■インストーラーが壊れている、または今現在の(新しくなっているかもしれない)インストーラーで試す
    ・ダウンロードし直す

    ■管理者権限(UAC)を無効にしている
    ・有効にして、「管理者として実行」経由でインストーラーを実行する

    ■後は・・・
    ・他の方の回答を待つ
    ・工場出荷時に戻す
    ・MS有償サポートを受ける(そもそもできるのかは分からないですが)


    > Retrying attempted connection to service 'RemoteSettingsClient' - attempt '0'
    → サービス 'RemoteSettingsClient'への接続を再試行しました - 試した回数? '0'
    なので、インストーラー内で別途実行したexeファイルなのか、インターネット先のプログラムなのか、
    それが起動していないからなのか、アクセス権限が無くてはじかれたからなのか、分からないですが、ここなんですよね。
    2018年9月12日 14:31
  • > Retrying attempted connection to service 'RemoteSettingsClient' - attempt '0'
    → サービス 'RemoteSettingsClient'への接続を再試行しました - 試した回数? '0'
    なので、インストーラー内で別途実行したexeファイルなのか、インターネット先のプログラムなのか、
    それが起動していないからなのか、アクセス権限が無くてはじかれたからなのか、分からないですが、ここなんですよね。

    Visual Studio Installer は Electron を使った HTML ベースのアプリケーションなので、いくつかの処理は別プロセスのサービスと通信することで実現していると思われます。
    正常な環境では vs_installerservice.exe がバックグラウンドで稼働していることを、タスクマネージャーで観測できます。

    今回のログをさらっと見る限り、なぜ失敗するか?についてはちょっとわからないですね…。
    (ネットワークにつながらないと言うよりは、pipe につながらないなので、プロセス間通信の失敗が理由であろうことはわかるものの、その現象が起きた理由が相手プロセスが立ち上がらないのか、IPC の待ち受け開始に失敗しているのか、Electron 側の接続要求が何らかの理由で阻止されているのか、不明)

    -----
    ウィルス対策系のソフトで阻害されている可能性はあるかもしれませんが、可能性レベルかな…。

    2018年9月12日 22:09
    モデレータ
  • FYI
    -----------------------------------------
    Windows でクリーン ブートを実行する方法
    https://support.microsoft.com/ja-jp/help/929135/how-to-perform-a-clean-boot-in-windows
    -----------------------------------------

    2018年9月13日 2:44
  • sutefu7さん
    Azuleanさん
    お馬鹿さん

    情報ありがとうございます。

    残念ながらいまだ進展がありません…。

    >・ダウンロードし直す
     同じファイ名(バージョン)しかダウンロードできません。

    >・有効にして、「管理者として実行」経由でインストーラーを実行する
     管理者権限のユーザーにて実行しております。

    >・他の方の回答を待つ
     どなたかお願いします。

    >・工場出荷時に戻す
     これは…ちょっと無理かもです。

    >・MS有償サポートを受ける(そもそもできるのかは分からないですが)
     これも…高いです…。

    >ウィルス対策系のソフトで阻害されている可能性はあるかもしれませんが、可能性レベルかな…。
     Symantec Endpoint Protectionを無効にしてやってみましたがだめでした。

    お馬鹿さんに教えて頂いた「Windows でクリーン ブートを実行」も試してみましたが、
    現象は変わらずでした。

    始めも書きましたが、
    タスクマネージャを起動してみてみると
    com.exe、conhost.exe、vs_instalhersholl.exe、WMIC.exeが大量に起動しています。
    とくにcom.exe、conhost.exe。

    この大量に起動するのがなにか動作を阻害しているのではと思うのですが、
    ただ、このような現象を調べても出てこないんですよね…。

    2018年9月14日 8:57
  • とりあえず、現在の状態を知っておいても損はないと思います。
    インストーラーで消したもの以外で残っているものを調べるのも、無駄ではないと思います。

    (追記)
    > 始めも書きましたが、
    > タスクマネージャを起動してみてみると
    > com.exe、conhost.exe、vs_instalhersholl.exe、WMIC.exeが大量に起動しています。
    こちらは、Windows 起動時からですか?インストーラー起動時からですか?


    1.コントロール パネル / システムとセキュリティ / 管理ツール / サービス の一覧に、Visual Studio 関連のサービスが起動していますでしょうか?
    もしある場合は、停止しておいてください。
    ※「Visual Studio」と名前がついているサービス名だけでOKだと思いますし、そもそも 1 件も無いかも。

    2.コントロール パネル / プログラム / プログラムと機能 の一覧に、Visual Studio 関連のプログラムが残っていますでしょうか?
    あれば、消せるものは消してください。

    3.C ドライブ直下を対象に、「Visual Studio」という文字列で検索をかけて、1件以上あれば、残っていたら控えておいてください。
    隠しファイルは表示するようにしています?表示していない場合もこのタイミングだけは表示するようにしてください。
    ※時間がかかると思います。

    4.レジストリ/「コンピュータ」ノードを対象に、「Visual Studio」という文字列で検索をかけて、1件以上あれば、残っていたら控えておいてください。
    「regedit」でレジストリエディタを起動、コンピュータノードを右クリック→エクスポートで、任意のフォルダに保存。
    ※時間がかかると思います。
    ※私の場合(Windows 10)、550 MB くらいになりました。
    危ないので「xxx.reg」を「xxx.reg.txt」と名称変更して、メモ帳なりで開いて検索。ただし、メモ帳だと開くまでに時間がかかったので、他のエディタを持っていればそちらで。
    検索機能が充実している、大容量ファイル対応しているものがベターです。

    3、4で、「Visual Studio」、「VisualStudio」、「VS」という具合に、揺れがあるので、正規表現をご存知であれば探すのが楽かもしれません。
    3、4で、手動で消せば何とかなるかもしれない、しかし、もしかしたら、Windows にまで影響が出るかもしれない。最悪 Windows が立ち上がらなくなるかもしれない。ということがあるので、調べるところまでかなと思います。


    5.今更ですが Windows のバージョンを教えてください。(Windows 7 Pro (x64)  とか、Windows 10 Pro (x64) 1803 とか)
    6.インストール済みの .NET Framework も教えてください。
    7.エラー発生時あたりの時刻で、イベントログには何か残っていますでしょうか?


    参考
    Visual Studio Community 2017 がインストールできない
    https://social.msdn.microsoft.com/Forums/vstudio/ja-JP/da61ad38-7452-426f-9663-5e63d2cc7ee6/visual-studio-community-2017-?forum=vsgeneralja

    • 編集済み sutefu7 2018年9月14日 11:35 現象を詳細に知りたかったため追記
    2018年9月14日 11:18
  • sutefu7さん
    回答致します。

    > こちらは、Windows 起動時からですか?インストーラー起動時からですか?
     インストーラを起動して、『作業を開始する前に、インストールを構成するためにいくつかの点を設定する必要があります。』
     という画面が出て、そこにある続行ボタンを押すと起動されていきます。
     続行ボタンを押さずに画面を閉じると起動しません。

    > 1.コントロール パネル / システムとセキュリティ / 管理ツール / サービス の一覧に、Visual Studio 関連のサービスが起動していますでしょうか?
     起動しているものはありませんでした。
     1個だけ「Visual Studio Data Collection Service 150」とうものがありますが、起動していません。
     スタートアップの種類は手動、ログオンはLocal Systemとなっています。

    >2.コントロール パネル / プログラム / プログラムと機能 の一覧に、Visual Studio 関連のプログラムが残っていますでしょうか?
     残っているのはRedistributableとOffice Runtimeとかです。バージョンは色々入っています。
     あとはVisual Studio Installer、Visual Studio Professional 2017の残がい(アイコンがVisual Studioではない)が残ってはいます。

    >3.C ドライブ直下を対象に、「Visual Studio」という文字列で検索をかけて、1件以上あれば、残っていたら控えておいてください。
     下記のフォルダが残っていました。
     C:\Program Files (x86)\Microsoft Visual Studio\Common
     C:\Program Files (x86)\Microsoft Visual Studio\Installer
     C:\Program Files (x86)\Microsoft Visual Studio\Shared
     C:\Program Files (x86)\Microsoft Visual Studio\VB98
     C:\Program Files (x86)\Microsoft Visual Studio 14.0\Microsoft Visual Studio Agents 2015 - JPN
     C:\Program Files\Common Files\Microsoft Shared\VSTO\10.0\Microsoft Visual Studio 2010 Tools for Office Runtime (x64) Language Pack - JPN
     C:\Program Files\Common Files\Microsoft Shared\VSTO\10.0\Microsoft Visual Studio 2010 Tools for Office Runtime (x64)
     C:\Users\ユーザー名\AppData\Roaming\Visual Studio Setup
     C:\Users\ユーザー名\.gradle\wrapper\dists\gradle-2.2.1-all\c64ydeuardnfqctvr1gm30w53\gradle-2.2.1\samples\native-binaries\visual-studio
     C:\Users\ユーザー名\.gradle\wrapper\dists\gradle-3.3-all\55gk2rcmfc6p2dg9u9ohc3hw9\gradle-3.3\samples\native-binaries\visual-studio
     マイドキュメントにVisual Studio 2008、2013、2017のフォルダが残っています。

    >4.レジストリ/「コンピュータ」ノードを対象に、「Visual Studio」という文字列で検索をかけて、1件以上あれば、残っていたら控えておいてください。
     これはかなりの数が引っ掛かりました。
     「Visual Studio」で約6000個、「VisualStudio」で約19000個
     秀丸のgrepで検索した結果ですが。

    >5.今更ですが Windows のバージョンを教えてください。(Windows 7 Pro (x64)  とか、Windows 10 Pro (x64) 1803 とか)
     すみません書いていませんでした。
     Windows 7 Pro (x64) SP1です。

    >6.インストール済みの .NET Framework も教えてください。
     コントロールパネルのプログラムと機能に表示されているのは
     .NET Framework 4.6.1 Targeting Pack(ENU)
     .NET Framework 4.6.1 Targeting Pack(日本語)
     .NET Framework 4.7.2
     .NET Framework 4.7.2 (日本語)
     この四つです。

    >7.エラー発生時あたりの時刻で、イベントログには何か残っていますでしょうか?
     アプリケーションとセキュリティは特に何も残ってないですね。
     システムでエラーが出ていますが、「デバイス \Device\Harddisk0\DR0 に不良ブロックがあります。」
     というエラーでした。

    お手数掛け致します。
    よろしくお願い致します。

    2018年9月14日 12:52
  • >「デバイス \Device\Harddisk0\DR0 に不良ブロックがあります。」を検索すると、ハードディスク交換した方がいい等が多く出ます。
    ソフトウェア的な破損ならまだしも、ハードウェア寄りの破損になるとどうしようもないですので、起動できるうちに何らかの対処をした方がいい気がします。
    (こちらの方を優先された方がいいのでは?とは思います・・・)


    (追記)冒頭に記載されていましたね。見落としていました。
    以下の記事を見つけましたが、以下ではうまくいかず結局再セットアップされたみたいです。

    Trying to update VS 2017 - Generic error "Sorry there is a problem with the Visual Studio Installer"
    https://developercommunity.visualstudio.com/content/problem/226740/trying-to-update-vs-2017-generic-error-sorry-there.html

    引用(和訳)ここから ----------------------------
    > ありがとうございます、 'C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\ServiceHub\Hosts\Microsoft.ServiceHub.Host.CLR\vs_installerservice.exe.Config'が有効なxmlファイルであることを確認できますか? インストールされていない場合は、インストーラを再インストールする必要があります。 最初に「C:\Program Files (x86)\Microsoft Visual Studio\Installer\」を削除し、Webサイトから再インストールしてください。

    >既に\Installerフォルダを削除しようとしました。 その後、インストールファイルを別のコンピュータの外部メディアに抽出し、そのメディアからインストールを実行しても、再インストールは失敗しました。 \ Installerフォルダがなければ、プログラムをアンインストールまたは修復することができなかったので、私はその時点で完全に覆われていました。私はラップトップの "焦げた地球"の再構築を終わらせ、物事は今正しく動作しています。
    引用(和訳)ここまで ----------------------------


    MS社員の方のコメントということで、お?って思いましたが、結果が失敗でしたので情報共有しない方がいいかなと思っていましたが、以下に載っていましたのでやっぱり書きました。

    Visual Studio 2017 のインストールとアップグレードの問題のトラブルシューティング
    https://docs.microsoft.com/ja-jp/visualstudio/install/troubleshooting-installation-issues?view=vs-2017
    ここの「手順 3 - Visual Studio インストーラーのディレクトリを削除してアップグレードの問題を修正する」

    Installer フォルダ以下全部を削除するように記載されていますが、デスクトップに移動させたり、削除じゃなくてリネームするなど、万が一何かあっても戻せるように、かつインストーラーからは認識できないようにする方が、多少の保険を掛けられるかなと思いました。意味無い気もしますけど。
    ※見落としここまで



    また今更ですが、復元ポイントは有効になっていますか?2018/1 時点に戻せるならそれに越したことは無いかなと思いました。

    • 編集済み sutefu7 2018年9月15日 7:04 ご質問の見落としによる修正。文章が見づらくなったが後学向けに残すように修正
    2018年9月15日 6:47
  • 2点思いつきましたので記載します。


    1.IPC$ の確認
    JavaScript を追ってみましたが、分かりませんでした。

    IPC$ ってありますか?
    コマンドプロンプトか PowerShell 開いて、net share
    または、コンピュータの管理 / 共有フォルダー / 共有で、一覧に IPC$ という共有名があるかどうかの有無


    / -----------------------------
    C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\main\StubMain.js

    ウェブサービス: JavaScriptのコード整形ツール
    https://lab.syncer.jp/Tool/JavaScript-PrettyPrint/
    より、コードを展開。以下は展開後の行番号

    C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\main\StubMain.js:4:369716
    の位置が、だいたい「InvalidPathMessage」に当たる

    12615 / return new o.InvalidPathMessage(e.installationPath, e.cachePath, e.sharedInstallPath)
    12614 / invalidPathMessageFromIpc(e)
    12869 / return new o.InstallParametersEvaluation(driveSpaceEvaluationsFromIpc(e.driveEvaluations), invalidPathMessageFromIpc(e.invalidPathMessage))
    12741 / e.CANCEL_PRODUCT_REQUEST =
    から始まってる?理解できず。

    C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\lib\ResourceStrings.nls.ja.json
    日本語版メッセージ
    ----------------------------- /


    2.Web インストーラーだとうまくいかないので、オフラインインストーラーでどうか
    インストールフォルダ先にあるインストーラーや、ダウンロードしてきた Web インストーラーがうまくいかないので、オフラインインストーラーを作ってどうかかなと思いました。

    ハードディスクに十分空き容量があることを確認して、オフラインインストーラーをダウンロード
    exe経由で証明書をインストールしてから、オフラインインストールしてみる。


    【Tips】Visual Studio 2017のオフラインインストーラーを作成する方法
    https://www.softantenna.com/wp/tips/visual-studio-2017-offline-installer/
    この方の場合、計 25 GB くらいになっています。

    Visual Studio 2017 インストールエラーの対応
    http://stone-book.hatenablog.com/entry/2017/08/24/224006

    ※証明書のインストールの理由は、セキュリティ確保のためらしいです。
    Visual Studio オフライン インストールに必要な証明書をインストールする
    https://docs.microsoft.com/ja-jp/visualstudio/install/install-certificates-for-visual-studio-offline?view=vs-2017


    2018年9月15日 15:03
  • sutefu7さん
    回答致します。

    >>「デバイス \Device\Harddisk0\DR0 に不良ブロックがあります。」を検索すると、ハードディスク交換した方がいい等が多く出ます。
    >ソフトウェア的な破損ならまだしも、ハードウェア寄りの破損になるとどうしようもないですので、起動できるうちに何らかの対処をした方がいい気がします。
    >(こちらの方を優先された方がいいのでは?とは思います・・・)
    調べてみたら結構やばいですね…。
    ちょっと冷や汗でました。


    > また今更ですが、復元ポイントは有効になっていますか?2018/1 時点に戻せるならそれに越したことは無いかなと思いました。
    残念ながら2018/1までは戻せませんでした。
    復元ポイントは有効になっていましたが、
    最近の日付までしか戻せませんでした。


    > 1.IPC$ の確認
    コマンドプロンプトで見てみました。
    一応ありました。


    > 2.Web インストーラーだとうまくいかないので、オフラインインストーラーでどうか
    教えて頂いたサイトを参考にオフラインインストーラを作成して、
    証明書のインストールを行い、
    ダウンロードフォルダ内の「vs_professional__805842111.1517309706.exe」を「vs_professional.exe」にリネームして実行してみましたが、
    まったく同じ現象でした。(オフラインとは…?)
    一緒にあった「vs_setup.exe」を実行しても同じでした。

    オフラインインストーラを作成中に、
    「Failed to load from stream: 要求されたオブジェクトが見つかりません。」
    「Failed to get signer for 'C:Users\ユーザー名\AppData\Local\Temp\xxxxxx.ps1'
    というメッセージがいくつも表示されていました。
    これが何か関係があるのでしょうか?


    お手数掛け致します。
    よろしくお願い致します。
    2018年9月18日 12:22
  • > 「Failed to get signer for 'C:Users\ユーザー名\AppData\Local\Temp\xxxxxx.ps1'
    > というメッセージがいくつも表示されていました。
    うーん、分からないです。


    以下だとどうでしょうか?


    1.サービス一覧の中で、「RPC(Remote Procedure Call)」が起動していますか?起動していなかったら起動してください。

    2.以下の2つのフォルダをリネームしてください。_Installer とか。
    ・「C:\Program Files (x86)\Microsoft Visual Studio\Installer」
    ・「C:\Program Files (x86)\Microsoft Visual Studio\2017」←すでに消されて無い状態?

    3.プログラム一覧に出ている「Visual Studio Installer」、「Visual Studio Professional 2017」について、
    アイコンはおかしいかもしれませんが、それぞれ選択した時に、「アンインストール」「変更」と出ると思います。
    この時、「アンインストール」を選択して消せますか?消せる場合は2つとも消します。
    (※インストール一覧から消すという意味で)

    4.ウェブインストーラーの実行。うまく動作するかどうか
    5.うまく起動した場合、インストーラーのインストールが始まる(ダウンロード&インストール)
    6.5.がうまくいった場合、vs2017 のインストールに失敗したと出るはず。この時「再試行」ではなく「アンインストール?削除?」を押す。

    • 編集済み sutefu7 2018年9月19日 12:06 指示間違い。2.3.の順序入れ替えと補足を追加
    2018年9月19日 10:26
  • sutefu7さん
    回答致します。

    > 1.サービス一覧の中で、「RPC(Remote Procedure Call)」が起動していますか?起動していなかったら起動してください。
    サービス一覧には「RpcSs」というのは実行中になっています。 説明にRemote Procedure Call(RPC)と書いてます。

    > 2.以下の2つのフォルダをリネームしてください。_Installer とか。
    > ・「C:\Program Files (x86)\Microsoft Visual Studio\Installer」
    > ・「C:\Program Files (x86)\Microsoft Visual Studio\2017」←すでに消されて無い状態?
    Installerは_Installerとリネームしました。2017は削除したので無い状態です。

    > 3.プログラム一覧に出ている「Visual Studio Installer」、「Visual Studio Professional 2017」について、
    > アイコンはおかしいかもしれませんが、それぞれ選択した時に、「アンインストール」「変更」と出ると思います。
    > この時、「アンインストール」を選択して消せますか?消せる場合は2つとも消します。
    > (※インストール一覧から消すという意味で)
    インストール一覧から消すことができました。
    アンインストールを行うと、「既にアンインストールされている可能性があります。」と表示され、そのまま一覧から削除しますか?と出ました。

    > 4.ウェブインストーラーの実行。うまく動作するかどうか
    vs_professional__805842111.1517309706.exeを実行し動作はしました。

    > 5.うまく起動した場合、インストーラーのインストールが始まる(ダウンロード&インストール)
    ダウンロードとインストールは行われました。

    > 6.5.がうまくいった場合、vs2017 のインストールに失敗したと出るはず。この時「再試行」ではなく「アンインストール?削除?」を押す。
    ここでインストールの失敗は出ませんでした。
    現象はいつもと同じでVisual Studio Installerが起動して、

     次のパラメーターと一致する製品が見つかりません:
     channelId:  VisualStudio.15.Release
     productId:  Microsoft.VisualStudio.Product.Professional

    これが出て画面にはいつもと同じ「ネットワークに接続されていない可能性があります」とでます。

    状態も同じでcom.exe、conhost.exeが大量に実行されている状態になっていました。

    お手数掛け致します。
    よろしくお願い致します。
    2018年9月20日 4:21
  • 時間と手間ばかりかけて、進展無くてすみません。
    以下も関係無いかもしれません。


    以下の記事を見かけて、「C:\Program Files (x86)\Microsoft Visual Studio」の他に「C:\ProgramData\Microsoft\VisualStudio」も事前に削除が必要なのではと思いました。
    こちらのフォルダも含めて、再度2~6を試していただけないでしょうか?
    ※どちらも Visual Studio フォルダ名からリネームする


    引用(和訳後)ここから ----------
    それは私のために役立ちます: "C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\layout\InstallCleanup.exe" -full
    非常に重要:あなたはそれを何度も実行しなければなりません - あなたがインストールを実行して、何度かエラーメッセージを受け取った場合。
    次に、このフォルダを削除します。
    C:\ProgramData\Microsoft\VisualStudio
    C:\Program Files (x86)\Microsoft Visual Studio
    私にとってはうまくいく。
    引用ここまで ----------

    参考
    Visual Studio 2017をインストールする際にエラーが表示される
    https://answers.microsoft.com/ja-jp/windows/forum/windows_7-winapps/visual-studio/e1096405-3d1a-46b0-9280-5e18463a6c95
    一番下の方の助言より

    channelId: VisualStudio.15.Release
    https://developercommunity.visualstudio.com/content/problem/139157/channelid-visualstudio15release.html
    ここの記事より

    Visual Studio 2017 RC installation failure “product … cannot be found”
    https://stackoverflow.com/questions/41565324/visual-studio-2017-rc-installation-failure-product-cannot-be-found



    妥協案
    別のPCに開発環境を移されるのはどうでしょうか?
    ・空いている既存PCを使う
    ・新規PCを購入して使う
    ・(Windows ライセンスを購入して)仮想化ソフトを使って、仮想マシンを構築して、その中で開発環境を整える

    2018年9月20日 7:55
  • > タスクマネージャを起動してみるとcom.exe、conhost.exe、
    > vs_instalhersholl.exe、WMIC.exeが大量に起動していました。

    とりあえず、"Process Explorer" や "Process Monitor" を使って、そのプロセスを誰が起動しているのか確認してみては?
    あと、それらプロセス空間に、怪しそうな 3rd ベンダー製モジュールがロードされていないか確認するとか。

    2018年9月20日 8:34
  • sutefu7さん
    お馬鹿さん

    回答致します。


    sutefu7さん

    > 以下の記事を見かけて、「C:\Program Files (x86)\Microsoft Visual Studio」の他に
    > 「C:\ProgramData\Microsoft\VisualStudio」も事前に削除が必要なのではと思いました。
    「C:\ProgramData\Microsoft\VisualStudio」フォルダの削除してのインストールは実はもう行っていました。

    全てのVC削除後に上記フォルダも削除してやってみましたが
    現象は変わらずでした。


    > 妥協案
    > 別のPCに開発環境を移されるのはどうでしょうか?
    もうこれしか無いかなと思っています。
    同僚に頼みこんで使っていないPCにインストールさせてもらった結果、
    憎たらしいほどアッサリインストールされました…。

    ここまでくるとこのPCのネットワーク系に問題があるのではないかと考えてしまいます。
    (じゃあその問題は何だと言われると答えられませんが…)


    お馬鹿さん

    > とりあえず、"Process Explorer" や "Process Monitor" を使って、そのプロセスを誰が起動しているのか確認してみては?
    "Process Explorer"を起動してインストールをしてみました。
    結果"Process Explorer"でのツリーを見る限りでは、
    「conhost.exe」は「csrss.exe」から発行されているようです。
    「com.exe」は「vs_instalher.exe」から発行され、
    その「com.exe」が「vs_instalhersholl.exe」を「vs_instalhersholl.exe」が「WMIC.exe」を発行していました。

    「conhost.exe」は「csrss.exe」からひたすら発行され、
    「com.exe」一つにつき「vs_instalhersholl.exe」が一つ発行されていました。

    他に怪しそうなモジュールはいなさそうでした。
    (私が分かっていないだけかもしれませんが)


    インストール出来たPCを何とか借りれるか
    新しいPCを購入できるか
    その辺りで考えないと駄目かもしれませんね…。

    お手数お掛け致します。
    以上よろしくお願い致します。

    2018年9月21日 8:01
  • 悔しいけど私の力では解決できません。ギブアップです。

    WMI サービスが無効?とか考えましたが、exe が動いている時点で有効なはずですし、
    exe の多重起動問題も、単純に Visual Studio インストーラーが必要な処理のために要求していて、妥当なのでは?以外の可能性は思いつきませんでした(仕様は分からないので体感的な判断)。

    お力になれず申し訳ないです。

    • 編集済み sutefu7 2018年9月24日 4:26
    2018年9月24日 4:22
  • >「conhost.exe」は「csrss.exe」からひたすら発行され、
    >「com.exe」一つにつき「vs_instalhersholl.exe」が一つ発行されていました。

    以前から気になっていたのですが。。。。(私が細かすぎるのかもしれませんが。)
    「com.exe」ではなく、「cmd.exe」なのでは?
    「vs_instalhersholl.exe」ではなく、「vs_installershell.exe」では?

    私のテスト環境で VS インストーラを起動したところ、"csrss.exe" プロセス経由で起動される "conhost.exe" プロセスは存在しませんでしたし、"vs_installershell.exe" プロセスは "vs_installerservice.exe" プロセスを起動させていました。
    もし "vs_installerservice.exe" が起動されていないのであれば、まずは "Process Monitor" でこのプロセスの起動リクエストが発行されているかを確認してみては?



    • 編集済み お馬鹿 2018年9月25日 4:05 誤記訂正
    2018年9月25日 1:06
  • sutefu7さん

    いえこちらこそ丁寧に対応して頂きありがとうございます。
    お手数お掛け致しました。
    本当にありがとうございました。


    お馬鹿さん

    > 「com.exe」ではなく、「cmd.exe」なのでは?
    > 「vs_instalhersholl.exe」ではなく、「vs_installershell.exe」では?

    おっしゃる通りです。
    綴りを間違えていました…。

    vs_installerservice.exeは発行されていませんでした。

    Process Explorerの画面をキャプチャーしたものを貼り付けようとしたんですが、
    貼り付けできませんでした。

    キャプチャーした時のツリーはこんな感じです。
    csrss.exe
     ├conhost.exe
     ├conhost.exe
     ~~~~~~
     ├conhost.exe
     └conhost.exe

    vs_installer.exe
     └vs_installershell.exe
      ├vs_installershell.exe
      ├vs_installershell.exe
      └cmd.exe
      │└vs_installershell.exe
      │ └WMIC.exe
      └cmd.exe
      │└vs_installershell.exe
      │ └WMIC.exe
      └cmd.exe
      │└vs_installershell.exe
      └cmd.exe
      │└vs_installershell.exe
      └cmd.exe
      │└vs_installershell.exe
      └cmd.exe
      ├cmd.exe
      ├cmd.exe
      ├cmd.exe
      ├cmd.exe
      ├cmd.exe
      ~~~~~~
      ├cmd.exe
      └cmd.exe

    お手数お掛け致します。
    以上よろしくお願い致します。

    2018年9月25日 9:38
  • 提示されているツリーは、どのタイミングの状態のことを示しているのでしょうか?
    VS インストーラ起動直後?

    先の返信にも書きましたが、VS インストーラ起動時の状態を "Process Monitor" でキャプチャし、"vs_installerservice.exe" のプロセス起動リクエストが発行されていないのか、それとも起動したけど落ちたのか、落ちたならなんの処理で失敗しているのか、きちんと調べることをお勧めします。

    2018年9月26日 0:52
  • お馬鹿さん
    回答致します。


    > 提示されているツリーは、どのタイミングの状態のことを示しているのでしょうか?
    > VS インストーラ起動直後?

    VSインストーラを起動して大体2分くらい経ってからのものです。
    というのも「WMIC.exe」がそのくらいになって初めて発行されていたので。

    「conhost.exe」や「cmd.exe」はVSインストーラを起動して、
    『作業を開始する前に、インストールを構成するためにいくつかの点を設定する必要があります。』
    という画面が出て、そこにある続行ボタンを押すと起動されていきます。
    続行ボタンを押さずに画面を閉じると起動しません。

    「Process Monitor」のフィルタに「vs_installerservice.exe」を設定してキャプチャしてみましたが、
    画面上に一度も表示されませんでした。
    「vs_installerservice.exe」だけフィルターに設定して行いました。

    試しに「vs_installer.exe」をフィルターに追加して行っても見ましたが、
    「vs_installer.exe」は取得して画面上に表示されました。
    「vs_installerservice.exe」はやはりいませんでしたが。

    お手数お掛け致します。
    以上よろしくお願い致します。


    2018年9月26日 4:39
  • > 「Process Monitor」のフィルタに「vs_installerservice.exe」を設定してキャプチャしてみましたが、
    > 画面上に一度も表示されませんでした。
    > 「vs_installerservice.exe」だけフィルターに設定して行いました。

    どのような条件でフィルタをかけたのでしょうか?
    それを明記していただかない限り、コメントのしようがありません。

    2018年9月26日 6:21
  • お馬鹿さん
    失礼致しました。

    下記のようにフィルターを掛けました。

    プロセス名 is vs_installerservice.exe なら Include
    プロセス名 is vs_installer.exe なら Include

    フィルターに設定したのはこの2つです。
    最初はvs_installerservice.exeだけ設定して確認しました。


    お手数お掛け致します。
    以上よろしくお願い致します。
    2018年9月27日 10:54
  • そのフィルタ設定では、"vs_installerservice.exe" プロセスの起動リクエストが発行されているか確認することはできません。
    先の返信でも指摘しましたが、まずは "vs_installerservice.exe" プロセスの起動リクエストが発行されているかを確認することが、一番重要だと思います。
    下記フィルタ設定で、再度確認してみてください。

    "Operation"   "is"             "Process Create"              then    "Include"
    "Path"          "contains"    "vs_installerservice.exe"   then    "Include"

    上記フィルタ設定で "vs_installerservice.exe" を起動させているプロセスが特定出来たら、その "PID" と "Time of Day" を確認後このフィルタ設定を一旦解除し、新たに下記設定でそのプロセスのエラーを確認してください。

    "PID"  "is"  "xxxx"  then  "Include"

    2018年9月28日 0:28
  • お馬鹿さん
    ご指摘ありがとうございます。

    教えて頂いたとおりにフィルタ設定を行い、
    VSインストーラを起動させましたが、
    「vs_installerservice.exe」はProcess Monitor上に表示されませんでした。


    それから大変申し上げにくいのですが、
    上のほうでも報告してありますが、
    イベントログで
    「デバイス \Device\Harddisk0\DR0 に不良ブロックがあります。」
    というエラーが出ているのを見つけまして、
    これがいずれHDDが起動しなくなる可能性があるとの指摘を受けて
    先日HDDの換装を行いました。(ついでにHDDからSSDに変更)
    丸ごとコピー(クローン)を行いました。

    それでSSDに変えてからVisual Studio Professional 2017のインストールを試してみたところ、
    あっさりとインストールすることが出来ました…。

    完全にHDDの不良が原因でした。


    3週間近くも長い間相談に乗って頂き大変申し訳ありませんでした。
    最終的にはHDDの不良が原因であったというのは何とも申し訳ない気持ちです。

    以上よろしくお願い致します。
    • 回答の候補に設定 kenjinoteMVP 2018年11月6日 13:52
    2018年9月29日 3:44