none
Visual Studio 2015をインストールすると Visual Studio 2010のチームエクスプローラーの挙動が変わってしまった RRS feed

  • 質問

  • いつもお世話になっております。

    バージョンが異なるVisual Studio (VS)を同一端末上に同居させると、最初に入っていたVSの挙動が変わってしまいました。

    現象は下記に記載しております通りなのですが、元に戻す方法はございますでしょうか。

    恐れ入りますがよろしくお願い致します。

     【元の環境】

      Visual Studio 2010 Professional から、Team Foundation Serverでソースコード管理をしており、

      プロジェクトに対する開発メンバの追加等はチームエクスプローラーの「グループメンバーシップ」より行っていた。

     【新しい環境で発生したこと】

      「元の環境」に対して、Visual Studio 2015 Professional をインストールしたところ

      Visual Studio 2015 からはこれまで通り、チームエクスプローラーの「グループメンバーシップ」から、

      プロジェクトのプロパティを開くことができるが、

      Visual Studio 2010で同様の操作を行うと、WEBブラウザが立ち上がり、

      プロジェクトに対するグループメンバの編集ができなくなってしまった。

    ----イメージ図----

    VS2015

    VS2010の挙動

    VS2010では、挙動が変わってしまい、グループメンバーシップをクリックするとWEBブラウザが立ち上がり、アクセスできないページ(真っ白なページ)に飛ばされる。

    VS2010

    上記事象の通り、VS2010のコンテキストメニューのリンクが書き換えられてしまったような動きをしています。

    大変手数をおかけしますが、事象についての解決策をご教示いただきたく

    お願い致します。

    不足している情報がございましたらご指摘いただければ幸いです。



    • 編集済み Unripe01 2015年11月20日 1:43
    2015年11月20日 1:42

すべての返信

  • サポートマトリクスによると、問題はないそうですが、使用するにはSP1とパッチが必要になります。接続されているとのことなので、パッチは適用されているかもしれませんが、いかがでしょうか?

    https://msdn.microsoft.com/en-us/Library/vs/alm/TFS/administer/requirements

    https://www.microsoft.com/ja-JP/download/details.aspx?id=29082


    Thanks, K.Kamegawa (http://d.hatena.ne.jp/kkamegawa/)

    2015年11月22日 4:24
  • kkamegawa さん

    アドバイスありがとうございます。
    Visual StudioはSP1で修正パッチも適応している状態です。

    TFSと対応しているOS、そしてクライアント側のVisual Studio のバージョンも調べた上で並行稼動にトライしたので、
    まさかまさかでした。

    現状のご報告を申し上げますと
    下記の事を一度でもトライすると事象が発生することが分かりました。

    ■1台のマシン上にVS2010とVS2015を同居させて、TFS2015へ、
    WEBブラウザで一度アクセスすると、VS2010が影響を受ける。

    ■シナリオ

    【事象発生前】

    クライアントA→ VS2010 →  TFS2010 (Windows Server 2008 (無印))

    【事象発生させるシナリオ】

    1.クライアントA→ VS2010 →  TFS2010 (Windows Server 2008 (無印 x32))

      この時はWEBブラウザではなく、VSのクライアントウィンドウが開く

    2.クライアントA→ VS2015 →  TFS2015 (Windows Server 2012 R2 )

      TFSをブラウザ経由で操作できる。VS2015はWEBでプロジェクトをイジる事もできるし、
        クライアント機能でイジることもできる。

    2で、WEB経由でTFSを操作すると、VS2010も影響を受けてしまい
    掲題記載の通り、VS2010のクライアントウィンドウが開かなくなり、VS2015と同じようなブラウザアクセスになってしまう。
    しかしブラウザで開くURLが適切でないアドレスを指し示し、空白のページのままとなる。

    とりあえず特に切羽詰っている訳ではない(VS2015を使えばTFSを操作できるので。必ずしもVs2010でやる必要が無い)
    のですが、意図していない挙動となったため原因や対応方法が分かればまた報告に参りたいと思います。

    2015年11月24日 5:07