none
Windows7の64ビットパソコンでは、Alt+Sのアクセスキーは使えないのでしょうか RRS feed

  • 質問

  • 私が開発中のソフトのテスト中に、メニューのAlt+Sのアクセスキーを使おうとしたところ、有効な操作ができませんでした(パソコンはWindows7の64ビットです)。
    そこでテスト的に「メモ帳」ソフトで、メモ作成後に [Alt+F → Alt+S] キーで上書き保存しようとしたところ、私が日常使用しているWindows7の64ビットパソコンでは、初回保存時に出るはずの「名前を付けて保存」のダイアログボックスが出ませんでした。
    手持ちの他のWindows7の64ビットパソコン2台で操作をしても同じ状態でした。
    以上の不具合は、Alt+Sのアクセスキーに特有のもので、Alt+F、Alt+A等の他のアクセスキーは問題なく使えました。

    そこで、確認のために、Windows7の32ビットパソコン、Windows10の64ビットパソコンのメモ帳で同じ操作をしたところ、初回保存時に「名前を付けて保存」のダイアログボックスが表示され、Alt+Sのアクセスキーが有効であることが確認できました。

    これから見ると、私が所持しているWindows7の64ビットパソコン(3台)では、Alt+Sのアクセスキーに問題がありそうですが、このアクセスキーを使用できるようにする方策はあるでしょうか。

    なお、どこのフォーラムでお聞きしたら良いかわからなかったので、ここでお尋ねしました。
    他に適切な場所があったら教えてください。

    2017年12月3日 6:11

回答

  • 私の手持ちの Windows 7 64 ビットのパソコン 2 台で試してみたところ、両方のパソコンで「Alt+S」は有効でした。(メモ帳で確認)

    何かキーボードをフックするような常駐ソフトが入っているのではないでしょうか?
    もし常駐しているソフトがあるようでしたら。一度すべての常駐ソフトを終了して試してみていかがでしょうか?

    もし、常駐ソフトが原因ではない場合、その 3 台のパソコンに OS 以外で何か共通するものはありますでしょうか?(例えば、同じ機種とか・・・)

    2017年12月3日 6:25
  • ウィルス対策ソフトとは限りません。
    タスクトレイにいるソフトを終了していく過程で、Alt+S の組み合わせが効くようにならないかが手っ取り早く試せる方法でしょうか。
    • 回答としてマーク はむさん 2017年12月3日 11:11
    2017年12月3日 9:28
    モデレータ

すべての返信

  • 私の手持ちの Windows 7 64 ビットのパソコン 2 台で試してみたところ、両方のパソコンで「Alt+S」は有効でした。(メモ帳で確認)

    何かキーボードをフックするような常駐ソフトが入っているのではないでしょうか?
    もし常駐しているソフトがあるようでしたら。一度すべての常駐ソフトを終了して試してみていかがでしょうか?

    もし、常駐ソフトが原因ではない場合、その 3 台のパソコンに OS 以外で何か共通するものはありますでしょうか?(例えば、同じ機種とか・・・)

    2017年12月3日 6:25
  • kenjinote様

    ご返信、有難うございました。

    常駐ソフトとは、ウィルス対策ソフトのようなものでしょうか。
    3台のうち、1つはマカフィーのウィルス対策ソフトが入っていますが、
    他の2台はオフライン使用なので、ウィルス対策ソフトはありません。
    他に調べるべき常駐ソフトがありましたら、ご教示ください。

    3台のパソコンで共通的なソフトはOfficeとVisual Studio 2010、CrystalDiskInfo、
    VirtualPCぐらいでしょうか。

    • 回答としてマーク はむさん 2017年12月3日 11:11
    • 回答としてマークされていない はむさん 2017年12月3日 11:14
    2017年12月3日 7:18
  • ウィルス対策ソフトとは限りません。
    タスクトレイにいるソフトを終了していく過程で、Alt+S の組み合わせが効くようにならないかが手っ取り早く試せる方法でしょうか。
    • 回答としてマーク はむさん 2017年12月3日 11:11
    2017年12月3日 9:28
    モデレータ
  • Azulean様

    ご連絡有難うございました。

    ご教示いただいたとおり、タスクトレイにあるものを順に終了させて、
    Easy KM Link が原因であることを特定しました。

    これは、ELECOM社のPC間データ移動ツールを導入した時に組み込まれた
    もので、これをはずせば [Alt+S]のアクセスキーが有効になることを
    確認しました。

    このツールを使用したパソコンがたまたまWindows7の64ビットパソコン3台
    であったというのが原因でした。

    お騒がせして申し訳ありませんでした。

    貴重なご教示をいただき、感謝しております。

    またご所持のパソコンで検証し、貴重な情報を提供していただきました
    kenjinote様にも、厚くお礼申し上げます。

    2017年12月3日 11:13