none
メンテナンスプランが保存できません。 RRS feed

  • 質問

  • SQLSERVER2005のマネジメントスタジオでメンテナンスプランウィザードでバックアップのプランを作成したいのですが、

    最後の進行状況の画面の最後でエラーが出てしまいます。

    エラー内容は、

    「メンテナンスプランを保存できませんでした」

    追加情報

    「SaveToSQLServerメソッドでOLE DBエラーコード0x80004005(通信リンクが失敗しました。)が検出されました。発行されたSQLステートメントは失敗しました。」

    と出ています。

     

    IISIサービス・SQLServerAgentサービスは起動しています。

    対象のDBは移行ではなくSQLSERVER2005インストール後に新規に作成したDBです。

    プランを作成するのに足りない物があるのでしょうか?

    それともどこかの設定が影響して失敗しているのでしょうか?

    よろしくお願いします。
    2008年12月19日 5:42

回答

  • こんにちは、naginoです。

    0x80004005 はネットワークや OLE DB のレベルのエラーだったはずです。
    原因はもちろん SQL Server Management Studio の設定のこともありますが、エラーメッセージのみでは切り分けが困難です。

    外部のサイトですが、主な原因と対処法を列挙したサイトがあります。

    ただ、これも全部では無いようです。
    確か、ネットワーク環境によりますが、パケットサイズを 4096 より大きく設定しすぎた場合も発生した気がします。

    様々なログの収集や、状況と設定の確認が必要かもしれません。
    アタリがつきにくい現象ですのでフォーラムでの解決は運任せになりやすいため、場合によっては有償サポートへの問い合わせをご検討ください。

    ご参考になれば幸いです。

    2008年12月20日 16:49

すべての返信

  • 以下が参考になりませんでしょうか?

     

    SQL Server 2005でバックアップスケジュールの設定ができません
    http://forums.microsoft.com/msdn-ja/ShowPost.aspx?PostID=3110148&SiteID=7

     

    メンテナンスプランが作成できない。
    http://forums.microsoft.com/msdn-ja/ShowPost.aspx?PostID=460187&SiteID=7

    2008年12月19日 8:09
  • ご回答ありがとうございます。

     

    認証に関してはWindows認証でも試してみましたが、同じエラーが出てしまいました。

    WindowsUpdateも実行してみましたが、SQLSERVERに関するUpdateは有りませんでした。

    ネットで調べた中に再インストールすると上手くいったと報告が有りましたので、

    SQLSERVERとマネジメントスタジオの再インストールもしたのですが、やはり同じエラーが出てしまいました。

     

    OLE DBがエラーを返しているということは、SQLSERVER本体ではなくMDACを疑ったほうがよいのでしょうか?

    2008年12月19日 9:11
  • こんにちは、naginoです。

    0x80004005 はネットワークや OLE DB のレベルのエラーだったはずです。
    原因はもちろん SQL Server Management Studio の設定のこともありますが、エラーメッセージのみでは切り分けが困難です。

    外部のサイトですが、主な原因と対処法を列挙したサイトがあります。

    ただ、これも全部では無いようです。
    確か、ネットワーク環境によりますが、パケットサイズを 4096 より大きく設定しすぎた場合も発生した気がします。

    様々なログの収集や、状況と設定の確認が必要かもしれません。
    アタリがつきにくい現象ですのでフォーラムでの解決は運任せになりやすいため、場合によっては有償サポートへの問い合わせをご検討ください。

    ご参考になれば幸いです。

    2008年12月20日 16:49
  • ご回答ありがとうございます。

     

    ご指摘のパケットサイズについて、アプリが発行するSQL文が4kbを超える可能性があるため、

    SQLServerインストール直後に変更していましたので、4096に戻したところ問題は解決できました。

    御礼が遅くなりましたが、本当にありがとうございます。

    2008年12月22日 1:58