none
VS2005でデバックで開始すると、デフォルトブラウザでWEBページが開かない RRS feed

  • 質問

  • こんにちは、OpSです。

    開発機WindowsXP Pro SP2で、デフォルトブラウザをInternet Explorerにしています。
    VS2005でWEBアプリのデバックで開始(デバックなしで開始も同じ)すると。
    デフォルトブラウザであるInternet Explorerが開かず、FireFox(1.5.0.3)が開いてしまいます。

    VS2003では、デフォルトブラウザであるInternet Explorerが開きます。
    VS2005インストール時点では、デフォルトブラウザはFireFoxにしておりました。

    VS2005で、、デフォルトブラウザであるInternet Explorerを開かせるには、
    どこを直せばいいのかを教えてください。

    よろしくお願いします。

    なお、ASP.NET 開発サーバーを右クリックして、「WEBブラウザで開く」
    では、デフォルトブラウザであるInternet Explorerが開きますが、デバックなしモードとなります。




    2006年5月6日 9:41

回答

  •  OpS さんからの引用
    VS2005 Professional ですが、言われた「ファイル」メニューに、見当たらないのですが。

    私は Professional Edition で "確認" しています。
    Web アプリケーションのプロジェクトを選択していないと表示されないようです。

     OpS さんからの引用
    FireFoxを削除すれば、IEがVS2005上でのデフォルトブラウザになると、思いますけど、できれば、削除しないでできないかと思っています。

    ですので、こちらの返信は割愛しますね。(できない前提で話されているようですので)

    2006年5月7日 3:07

すべての返信

  • 「ファイル」メニューから、「ブラウザの選択」がその機能になります。
    2006年5月7日 1:41
    モデレータ
  • > 「ファイル」メニューから、「ブラウザの選択」がその機能になります。

    trapemiyaさん、返信ありがとうございます。

    VS2005 Professional ですが、言われた「ファイル」メニューに、見当たらないのですが。

    FireFoxを削除すれば、IEがVS2005上でのデフォルトブラウザになると、思いますけど、できれば、削除しないでできないかと思っています。


    2006年5月7日 2:52
  •  OpS さんからの引用
    VS2005 Professional ですが、言われた「ファイル」メニューに、見当たらないのですが。

    私は Professional Edition で "確認" しています。
    Web アプリケーションのプロジェクトを選択していないと表示されないようです。

     OpS さんからの引用
    FireFoxを削除すれば、IEがVS2005上でのデフォルトブラウザになると、思いますけど、できれば、削除しないでできないかと思っています。

    ですので、こちらの返信は割愛しますね。(できない前提で話されているようですので)

    2006年5月7日 3:07
  • じゃんぬねっとさん、返信ありがとうございます。

     別WEBアプリケーションで、確認したところ、「ブラウザの選択」がありました。
    そこで、Internet Explorerを既定値にした、結果、当該WEBアプリケーションでも、
    IEでデバックができるようになりました。
    でも、依然として、当該アプリケーションでは、「ブラウザの選択」がない状態のままです。
    不思議です。まったく、新しいWEBアプリケーションで試したところ、こっちでは、
    「ブラウザの選択」がありました。

     何度も、確認しないと、いけないことを痛感しました。

    trapemiyaさん、きっかけを作っていただき、ありがとうございました。
    2006年5月7日 3:47
  • >でも、依然として、当該アプリケーションでは、「ブラウザの選択」がない状態のままです。

    こちらで試したところ、Webプロジェクトでも以下の条件下でないと、「ブラウザの選択」が表示されませんでした。

    1.ソリューションエクスプローラで、プロジェクトを選択する。
    または、
    2.何かWebフォームを開く。(コードを開いてもダメ)

    以上を、確認してみて下さい。

    2006年5月7日 15:03
    モデレータ
  • trapemiyaさん、ありがとうございます。

    >以下の条件下でないと、「ブラウザの選択」が表示されませんでした。


    確認できました。その通りでした。
    2006年5月9日 12:53