none
ダイヤルアップのプロキシ設定のレジストリ保存の不具合 RRS feed

  • 質問

  • 最近、IE10のインターネットオプションでダイヤルアップ接続のプロキシ設定をして保存しても正しく保存されず、

    再度設定を開くと元の設定に戻っている現象が複数台で発生しております。

    また、ダイヤルアップ接続中、設定したプロキシサーバにアクセスしていないようです。

    レジストリを調べたところ、\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\

    の下にダイヤルアップ時のプロキシ設定を保存したものが2個存在していました。

    キー名は一方が 社内接続WM320 となっており、もう一方は �Г�ڑ�WM320 となっておりました。

    設定したプロキシの内容は 社内接続WM320 に書き込まれており、

    IEのインターネットオプションのダイヤルアップ接続のプロキシ設定時は文字化けしたキー名の情報を読み込んでいるようです。

    これは、IEの不具合でしょうか。もしくは、なにか別の問題でしょうか。

    環境:Windows7Proffesional SP1、IE10(更新バージョン10.0.12)

    (2014/1/21追記)

    グループポリシーやIEAKは使用しておらず、コントロールパネルのインターネットオプションから手作業で設定しております。

    具体的には、

    (1)コントロールパネル → インターネットオプション を開く。

    (2)インターネットオプションの[接続]タブを開く。

    (3)接続タブの中の「ダイヤルアップと仮想プライベートネットワーク」の設定より、

       該当するダイヤルアップ名をクリックして選択し、「設定」ボタンをクリックする。

    (4)開いたウィンドウに、プロキシサーバーのアドレス等を入力し「OK」をクリックする。

    通常は、上記手順で設定が保存されます。

    しかし、(3)のダイヤルアップ名に日本語("社内接続"など)が含まれる場合、

    (4)で設定後、再度、(3)で開きなおすと、設定したアドレス等が消えています。

    ※現象が発生しているPCで、ダイヤルアップ名を半角英字のみにした場合は、

     正しく設定が保存されました。

     ただし、ドコモコネクションマネージャを使用している場合、

     ダイヤルアップ名に日本語が自動で付けられる時があり、問題となっております。


    • 編集済み Masa331 2014年1月21日 2:55
    2014年1月16日 2:06

すべての返信

  • フォーラム オペレーターの星 睦美です。
    Masa331 さん、投稿ありがとうございます。

    Active Directory ドメイン環境のネットワーク内ではグループ ポリシーやInternet Explorer 管理者キット 10 (IEAK 10) で設定を展開している場合が多いと思いますが、Masa331 さんの環境ではいかがでしょうか?

    以下の情報がIE10 の設定の参考になりそうだと思いますのでご紹介します。

    ・IE10 以降では「Internet Explorer のメンテナンス」が廃止されている:
    http://hebikuzure.wordpress.com/2013/12/20/ie10-%E4%BB%A5%E9%99%8D%E3%81%A7%E3%81%AF%E3%80%8Cinternet-explorer-%E3%81%AE%E3%83%A1%E3%83%B3%E3%83%86%E3%83%8A%E3%83%B3%E3%82%B9%E3%80%8D%E3%81%8C%E5%BB%83%E6%AD%A2%E3%81%95%E3%82%8C%E3%81%A6/

    もし設定に関する疑問が解決されない場合には、設定方法を質問に追記していただくとフォーラムの回答者からのアドバイスが集まりやすくなると思います。

    フォーラム オペレーター 星 睦美 - MSDN Community Support


    • 編集済み 星 睦美 2014年1月17日 5:13 編集
    2014年1月17日 5:11
  • 星さんも書かれているように、クライアントへのプロキシサーバーの設定方法が色々ありますから、具体的にどのような方法でどのように設定しているのか、、その場合の期待すると実際の動作が明瞭でないと直接的な回答やアドバイスはつけにくいと思います。


    hebikuzure

    2014年1月18日 6:43
    モデレータ
  • 遅くなりましたが、ご返信ありがとうございました。情報が足らず申し訳ありませんでした。

    先ほど、質問に設定方法を追記しました。

    2014年1月21日 1:53
  • 日本語名の使用で気になったのですが、レジストリの内容は文字コードがUnicode(UTF-16)である必要があります。
    違う文字コードで保存されている、あるいはダイアルアップ名にそもそも日本語が使えないと想定することもできます。(私のほうで調べてみた限りでは日本語は使えない、という情報は見つかっていませんが。)いずれにしても文字コードが関係しているため、ダイヤルアップ名を英数字で設定した場合には問題なく設定を保存できるかも知れません。

    ダイヤルアップ名の日本語が文字化けしている場合と、文字化けしない場合の設定方法が違うのかどうか、質問から詳しくは分からないのですが、ドコモコネクションマネージャでレジストリのキーを設定している場合は、ツールのサポート窓口にお問い合わせいただければと思います。ご自身で変更を行っている場合はトラブルシューティングの手がかりとして、文字コードを確認してみてはいかがでしょうか。

    レジストリを編集する際に参考になりそうなページをご紹介します。編集の際にはレジストリのバックアップを取得して、慎重に行うようにお願いいたします。

    (参考情報)
    .regファイルを「手書き」してレジストリに読み込ませる方法:
    http://www.atmarkit.co.jp/fwin2k/win2ktips/1119wrtregfil/wrtregfil.html


    フォーラム オペレーター 星 睦美 - MSDN Community Support

    2014年1月22日 6:24
  • 星様、ご返信ありがとうございました。

     

    さて、ダイヤルアップ名を英字のみにした場合は設定を正しく保存できております。

     

    また、ドコモコネクションマネージャがレジストリを設定するかどうかですが、

    ドコモコネクションマネージャはダイヤルアップ接続の作成はしますが、プロキシの設定は行わないため、別途手作業でIE10のインターネットオプションに設定しております。

    このため、インターネットオプションに関連するレジストリは、ドコモコネクションマネージャではなく、IE10が書き込んでいると思われます。

    ダイヤルアップ接続の名前はIE10上やネットワーク接続の中でも日本語を含めて正常に表示されているため、ドコモコネクションマネージャの問題ではないと思われます。 

    また、ドコモコネクションマネージャ以外の接続ソフト(WM320 Data Connection Manager)でも接続名に日本語を含めた場合は同様の現象が発生します。

    ※レジストリについては問題の切り分けのため調査しただけで、特に設定時にレジストリを直接変更するということはしておりません。

     

    次に、文字化けしない場合と文字化けしている場合の設定方法の違いですが、特に違いはありません。

    なお、文字化けする場合は、正常なキー名と文字化けしたキー名の2つのエントリを同時にレジストリに書き出すようです。

    ところで、以前は問題なかったが、最近このようになったというように、一部の者からは言われております。

    このため、設定方法の違いというよりは、おそらく最近の更新プログラムなどの影響を受けているように思われるのですが、絞りきれておりません。

     

    以上、取り急ぎ返信いたします。



    • 編集済み Masa331 2014年1月23日 6:52
    2014年1月23日 5:04
  • おなじ現象が起きました。
    手動で選びなおすと設定が有効になるのが良くわかりません。
    初めはバケた方が有効になっていて、手動で選びなおすと化けていない方が選ばれるようです。
    (実は私も困っていたり^^;)

    ・発生を確認した環境
    Windows 7 amd64 & IE10
    Windows 8.1 amd 64 & IE11

    ・再現手段
    ダイアルアップと仮想プライベートネットワークの設定からVPNの追加を日本語名で行いProxyの設定を行った。




    • 編集済み ChukiMVP 2014年3月4日 11:34
    2014年3月4日 11:18