none
VWD2008EXPRESS SP1からSQLserverへ接続できません RRS feed

  • 質問

  • VWD2008ExpressをSP1にアップグレードしました。同時にSQL Server Express 2008、.NET Framework3.5 SP1もインストールいたしました。

    VWD2008Express SP1からSQLServer ファイルの新規作成をしようとしても、既存のファイルへ接続の変更をしようとしても

    「ユーザーインスタンスのプロセスを起動中のエラーにより、SQL Serverのユーザーインスタンスは生成できませんでした。接続は閉じられます」

    のメッセージでSQL Serverに接続できなくなってしまいました。

    環境:

    OS:Vista(Ultimate)でもXP+SP2でも同様です。

     

    解決方法ご存知でしたらよろしくお願いいたします。

    2008年9月8日 9:27

回答

  • はっきりわからないのですが、一度、以下のフォルダのバックアップを取ってから、そのフォルダを削除してみて下さい。

     

    c:\Documents and Settings\<user>\Local Settings\Application Data\Microsoft\Microsoft SQL Server Data\SQLEXPRESS

     

    2008年9月9日 0:53
    モデレータ
  • Stuck between "Failed to generate user instance" and "An attempt to attach...failed"
    http://forums.microsoft.com/msdn/showpost.aspx?postid=98346&siteid=1

     

    ここの回答済みになっているLanceDelanoさんの発言によれば、SQL Serever Express Editionが最初に起動する時に、適切に動作するために当該フォルダに必要なコピーを行うそうです。たぶん、この当該フォルダが何らかの影響で整合性が崩れてしまったのでしょう。
    そこで当該フォルダを一度削除し、新たに当該フォルダを自動で作成させたところ、うまく動いたのだと思います。

    2008年9月9日 8:13
    モデレータ

すべての返信

  • はっきりわからないのですが、一度、以下のフォルダのバックアップを取ってから、そのフォルダを削除してみて下さい。

     

    c:\Documents and Settings\<user>\Local Settings\Application Data\Microsoft\Microsoft SQL Server Data\SQLEXPRESS

     

    2008年9月9日 0:53
    モデレータ
  • Vista環境でフォルダを削除したら接続ができました。

    XP環境はまだ確認していませんが。

    ありがとうございます。解決です。なぜだかわかったら投稿お願いします。

     

    2008年9月9日 4:49
  • Stuck between "Failed to generate user instance" and "An attempt to attach...failed"
    http://forums.microsoft.com/msdn/showpost.aspx?postid=98346&siteid=1

     

    ここの回答済みになっているLanceDelanoさんの発言によれば、SQL Serever Express Editionが最初に起動する時に、適切に動作するために当該フォルダに必要なコピーを行うそうです。たぶん、この当該フォルダが何らかの影響で整合性が崩れてしまったのでしょう。
    そこで当該フォルダを一度削除し、新たに当該フォルダを自動で作成させたところ、うまく動いたのだと思います。

    2008年9月9日 8:13
    モデレータ
  • こんにちは。中川俊輔 です。

     

    trapemiyaさん、回答ありがとうございます。

     

    miyakuniさん、フォーラムのご利用ありがとうございます。

    有用な情報と思われたため、trapemiyaさんの回答へ回答済みチェックをつけさせていただきました。

     

    回答済みチェックが付くことにより、有用な情報を探している方が情報を見つけやすくなります。
    有用な情報と思われる回答があった場合は、なるべく回答済みボタンを押してチェックを付けてください。

    miyakuniさんはチェックを解除することもできますので、ご確認ください。

     

    それでは!

    2008年9月22日 6:05