none
Redash で SQLserver のデータを扱いたい/ tds versionを下げたい RRS feed

  • 質問

  • SQLserver 2018 の中のテーブルを Redash に連携させる方法はありますか?

    → Redash にある連携の口は、pymssql というライブラリに依存しているらしく、tds version 7.3 までしか対応していません


    -SQLserver 2018 はおそらく tds version 7.4 という認識ですが、合ってますでしょうか?
    -おそらく TDS のバージョンが対応していない影響で、エラーが出ます。
     SQLserver のバージョンを変えず、TDS のバージョンだけ下げるような方法‥があったりしますでしょうか?



    • 編集済み kumiko_m 2020年5月28日 2:41
    2020年5月28日 2:39

回答

  • SQL Server 2008 では、TDS 7.3 となるようです。残念ながら、SQL ServerのTDSバージョンを変更することはできないかと思います。

    6 Appendix A: Product Behavior
    https://docs.microsoft.com/en-us/openspecs/windows_protocols/ms-tds/135d0ebe-5c4c-4a94-99bf-1811eccb9f4a?redirectedfrom=MSDN
    7.3.A : SQL Server 2008
    7.3.B : SQL Server 2008 R2

    • 回答としてマーク kumiko_m 2020年5月28日 9:51
    2020年5月28日 4:26

すべての返信

  • SQL Server 2008 では、TDS 7.3 となるようです。残念ながら、SQL ServerのTDSバージョンを変更することはできないかと思います。

    6 Appendix A: Product Behavior
    https://docs.microsoft.com/en-us/openspecs/windows_protocols/ms-tds/135d0ebe-5c4c-4a94-99bf-1811eccb9f4a?redirectedfrom=MSDN
    7.3.A : SQL Server 2008
    7.3.B : SQL Server 2008 R2

    • 回答としてマーク kumiko_m 2020年5月28日 9:51
    2020年5月28日 4:26
  • ご返信いただきましてありがとうございます。

    別の方法を模索したいと思います。。

    2020年5月28日 9:53