none
新規プロジェクトが作成できない RRS feed

  • 質問

  • visual stadio 2008 standard editionを使っています。
    ファイル→新規作成→プロジェクトで新しいプロジェクトを作りますが、Visual C++のプロジェクトを作成しようとプロジェクト名を例えばtestと入力してOKボタンを押すと

    ファイルのダウンロード
    このファイルを保存しますか?
    名前:default.htm
    種類:HTML ドキュメント,12.6KB
    発信元:C:|Program Files (x86)\Microsoft Visual Stu...

    というウインドウが表示され保存またはキャンセルどちらのボタンを押すと、

    Webページへのナビゲーションは取り消されました
    対処方法:
    ・アドレスを再入力する

    というウインドウが表示され結局プロジェクトが作成されませんでした。

    新規のプロジェクトを作成できるようにするにはどのようにしたらよいのでしょうか?
    教えて頂きたいと思い質問させていただきました。
    なにとぞご協力をお願いいたします。

    環境
    OS:windows7 enterprise
    セキュリティソフト:AVG Anti-Virus Free Edition 2012( ver.2012.0.1913 )
    Microsoft Visual Studio 2008 Version 9.0.30729.1 SP

    2012年2月9日 7:39

回答

  • 解決に至ってないかもしれませんが、英語で同じような現象の質問がありました。
    http://www.codeguru.com/forum/showthread.php?threadid=516479

    IE絡みっぽい気がします。
    Win7だとIE8の再インストールはできないと思いますが、デフォルトの
    ブラウザをIE8にしたり、.htmの関連付けを一度削除するなど 試してみてはどうでしょうか。


    追記:
    これも参考になるのでは。
    http://social.msdn.microsoft.com/Forums/ja-JP/vcgeneralja/thread/96dcf71f-eae8-481f-8920-fd3ecc936994/
    2012年2月10日 4:08
  • >ぼーず様
    返事が遅くなり申し訳ございません。
    上記のアドバイスをさっそく試してみようと思います。
    進展があり次第ご報告をさせて頂きたいと思います。
    貴重なアドバイス、ありがとうございます。

    >ぼーず様
    参考として挙げて頂いた以下のサイト
    http://social.msdn.microsoft.com/Forums/ja-JP/vcgeneralja/thread/96dcf71f-eae8-481f-8920-fd3ecc936994/
    から

    ウィザードのHTMLが普通に開いちゃってるのですね、本来ならそのHTMLに基づいてウィザードフォームが表示されるはずなのですが。
    システムの構成がおかしくなっていると思われるので、修復セットアップで直りそうなものですが。
    だめだったのならアンインストール後の再インストールが一般的と思います。
    他の方策としては「ツール」-「オプション」の「環境」-「全般」で「ファイルの関連付けを復元」
    もしくは、「ツール」-「設定のインポートとエクスポート」で「全ての設定をリセット」
    あたりが関係しそうなところでしょうか?
    あまり役にたってなくて申し訳ありませんが・・・。

    という書き込みを見つけ、「ツール」-「設定のインポートとエクスポート」で「全ての設定をリセット」をしたところ、
    新規のプロジェクトが作成できるようになりました。

    これで問題なくプロジェクトが作成できるようになりました。
    本当に貴重なアドバイスをしていただきましてありがとうございました!!

    2012年2月13日 6:52

すべての返信

  • あんまり聞いたことのない内容なうえにC++も使わないので的外れかもしれないですが
    > 発信元:C:|Program Files (x86)\Microsoft Visual Stu.
    を全部さらしてみませんか。何のファイルをダウンロードしようとしてるかで
    原因に近づくかもしれません。
    2012年2月10日 0:22
  • >mars12様
    発信元:C:|Program Files (x86)\Microsoft Visual Stu...
    上記のパスですがウインドウに表示されているパスが途中で切れているため
    このような表示となっていました。
    ウインドウのサイズを変更しようとしましたが拡大ボタンがついておらず、クローズボタンしかついていないウインドウでした。
    ダウンロードしようとしているファイルは「default.htm」ですので
    おそらくこの「default.htm」があるパスだと思います。

    2012年2月10日 1:15
  • 当方はVS2005なので厳密には同じではないのですが、新しいプロジェクトを
    作る際のウィザードは、VSのフォルダ内のHTMLを読み込んで表示しています。

    例えば、以下の場所。
    C:\Program Files\Microsoft Visual Studio 8\VC\VCWizards\AppWiz\MFC\Application\html\1041

    このHTMLをウィザードが読み込む時に、なぜかわかりませんがブラウザか
    エクスプローラーが横取りしているのではないかと思います。

    何か設定とかファイルの関連付けとかで直る可能性もありますが
    VS2008を再インストールするのが手っ取り早いように思います。
    • 編集済み ぼーず 2012年2月10日 2:45
    2012年2月10日 2:44
  • >ぼーず様
    こちらの環境にも
    C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\VCWizards\AppWiz\MFC\Application\html\1041
    にdefault.htmがありました。

    >このHTMLをウィザードが読み込む時に、なぜかわかりませんがブラウザか
    >エクスプローラーが横取りしているのではないかと思います。
    確かにその可能性はあると思います。
    使用しているブラウザはIE8、FireFox6.02、safari5.04、Google Chrome17.0963.46mです。
    エクスプローラーが横取りせずにウィザードが読み込めるようにする方法があるのでしょうか?

    >何か設定とかファイルの関連付けとかで直る可能性もありますが
    >VS2008を再インストールするのが手っ取り早いように思います。
    VS2008の再インストールは2回ほど試してみましたが状況は変わりませんでした。

    2012年2月10日 3:19
  • 解決に至ってないかもしれませんが、英語で同じような現象の質問がありました。
    http://www.codeguru.com/forum/showthread.php?threadid=516479

    IE絡みっぽい気がします。
    Win7だとIE8の再インストールはできないと思いますが、デフォルトの
    ブラウザをIE8にしたり、.htmの関連付けを一度削除するなど 試してみてはどうでしょうか。


    追記:
    これも参考になるのでは。
    http://social.msdn.microsoft.com/Forums/ja-JP/vcgeneralja/thread/96dcf71f-eae8-481f-8920-fd3ecc936994/
    2012年2月10日 4:08
  • >ぼーず様
    返事が遅くなり申し訳ございません。
    上記のアドバイスをさっそく試してみようと思います。
    進展があり次第ご報告をさせて頂きたいと思います。
    貴重なアドバイス、ありがとうございます。
    2012年2月10日 9:33
  • >ぼーず様
    返事が遅くなり申し訳ございません。
    上記のアドバイスをさっそく試してみようと思います。
    進展があり次第ご報告をさせて頂きたいと思います。
    貴重なアドバイス、ありがとうございます。

    >ぼーず様
    参考として挙げて頂いた以下のサイト
    http://social.msdn.microsoft.com/Forums/ja-JP/vcgeneralja/thread/96dcf71f-eae8-481f-8920-fd3ecc936994/
    から

    ウィザードのHTMLが普通に開いちゃってるのですね、本来ならそのHTMLに基づいてウィザードフォームが表示されるはずなのですが。
    システムの構成がおかしくなっていると思われるので、修復セットアップで直りそうなものですが。
    だめだったのならアンインストール後の再インストールが一般的と思います。
    他の方策としては「ツール」-「オプション」の「環境」-「全般」で「ファイルの関連付けを復元」
    もしくは、「ツール」-「設定のインポートとエクスポート」で「全ての設定をリセット」
    あたりが関係しそうなところでしょうか?
    あまり役にたってなくて申し訳ありませんが・・・。

    という書き込みを見つけ、「ツール」-「設定のインポートとエクスポート」で「全ての設定をリセット」をしたところ、
    新規のプロジェクトが作成できるようになりました。

    これで問題なくプロジェクトが作成できるようになりました。
    本当に貴重なアドバイスをしていただきましてありがとうございました!!

    2012年2月13日 6:52
  • もう解決になってしまっていますけれど、

    貼り付けられた内容が原文のままだとすると、パスの所がおかしくなっているように見えます。

    >発信元:C:|Program Files (x86)\Microsoft Visual Stu...

    C:に続いている文字が"|"になっているのが原因ではないでしょうか。
    普通に考えたら"\"になっているべきだと思います。
    「全ての設定をリセット」で元に戻ったのだろうと思いますけれど、
    何か設定を弄っている時に誤ってここを書き換えたりしたのではないかと思います。
    (もしくはツール系のインストーラーに不具合があったとか)


    解決した時は、参考になったレスポンスの所にある[回答としてマーク]ボタンをクリックしてスレッドを締めましょう。

    2012年2月13日 7:00