none
SSIS SQL Server オブジェクトの転送タスクエラー RRS feed

  • 質問

  • いつもお世話になっております。

    SQLServer2005 IntegrationServiceを使用しております。

    SQL Server オブジェクトの転送タスクを使用して、DBからDBへオブジェクト(テーブル・ユーザなど)の一括コピーを行おうとしています。

    プロパティは、基本的にすべてTrueにして実行しています。
    パッケージは、このフロー1つのみで実行しています。

    実行時に以下のエラーを出力して終了してしまいます。

    ──────────────────────────────────

    [SQL Server オブジェクトの転送タスク] エラー : 次のエラーにより実行が失敗しました: "値 null をプロパティ Login に適用できません: 値を NULL にすることはできません。。"。
    ──────────────────────────────────

     

    エラーメッセージを見て、該当箇所を探してみたのですが、見つからず、どこを修正すれば良いのか分かりませんでした。


    どなたか、同じような状態をご存知の方はご教授頂けますでしょうか。
    よろしくお願いいたします。

     

    2008年6月3日 5:10

回答

  • こんにちは。中川俊輔 です。

     

    エラーについて調べてみたところ、フィードバックサイトに同じエラーがでる現象がバグとして

    登録されているのをみつけました。

    SSIS Transfer SQL Server Objects Task Execution Error

    http://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=127100

    コメントを見るとSP2で修正されているようですので、まだインストールしていないようでしたら

    解決するかもしれません。

     

    また、転送タスクにかかわるSP2以降の修正点として下記の情報がありました。

    FIX: The logins are incorrectly deleted when you run a SQL Server 2005 Integration Services package

    that contains a Transfer SQL Server Objects task

    http://support.microsoft.com/kb/945323/en-us

     

     

    参考になると幸いです。

    それでは!

     

    この投稿は現状のまま何の保証もなく掲載しているものであり、何らかの権利を許諾するものでもありません。

    コミュニティにおけるマイクロソフト社員による発言やコメントは、マイクロソフトの正式な見解またはコメントではありません。詳しくは http://www.microsoft.com/japan/communities/msp.mspx をご覧ください。

     

    2008年6月4日 10:04

すべての返信

  • こんにちは。中川俊輔 です。

     

    エラーについて調べてみたところ、フィードバックサイトに同じエラーがでる現象がバグとして

    登録されているのをみつけました。

    SSIS Transfer SQL Server Objects Task Execution Error

    http://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=127100

    コメントを見るとSP2で修正されているようですので、まだインストールしていないようでしたら

    解決するかもしれません。

     

    また、転送タスクにかかわるSP2以降の修正点として下記の情報がありました。

    FIX: The logins are incorrectly deleted when you run a SQL Server 2005 Integration Services package

    that contains a Transfer SQL Server Objects task

    http://support.microsoft.com/kb/945323/en-us

     

     

    参考になると幸いです。

    それでは!

     

    この投稿は現状のまま何の保証もなく掲載しているものであり、何らかの権利を許諾するものでもありません。

    コミュニティにおけるマイクロソフト社員による発言やコメントは、マイクロソフトの正式な見解またはコメントではありません。詳しくは http://www.microsoft.com/japan/communities/msp.mspx をご覧ください。

     

    2008年6月4日 10:04
  • 中川さま

     

    お返事が遅くなってしまい、すみません。

    ご紹介いただいたサイトを参考に、SP2をインストールしたところ、

    無事事象解決しました。

     

    ありがとうございます。

     

    2008年6月12日 3:06
  • みのさん、

     

    こんにちは!

    フォーラム オペレーターの服部 清次です。

    みのさんがこの質問を投稿されてからしばらく経過しましたが、その後の状況はいかがでしょうか?

     

    今回、弊社の中川俊輔の投稿が参考になったのではないかと思いましたので、勝手ながら回答チェックを付けさせていただきました。

    もしまだ問題が解決していない場合は、回答チェックを外していただくことも可能です。

    また、中川俊輔が紹介しました英語情報の中で、どこか分からない点などがあれば、ぜひまた返信してください。

     

    今後とも、TechNet Forum をよろしくお願いします!

    それでは、また!

     

    _____________________________________________

    マイクロソフト株式会社 フォーラム オペレータ 服部 清次

     

    2008年9月30日 9:27