none
bootstrap4へのバージョンアップ方法を教えてください RRS feed

  • 質問

  • Visual Studio 2017 Professional Editionを使っています。

    bootstrapのバージョンが、3.0.0であったため、4.1.0へバージョンUPしようとしたのですが、

    依存関係を解決できません。とエラーが出てしまいます。

    bootstrap3.0.0をアンインストールしようとしても、AspNet.ScriptManager.bootstrap3.0.0が依存しているため、bootstrap3.0.0をアンインストールできません。とエラーが出てしまいます。

    具体的な解決方法についてご教授いただきたく、よろしくお願い致します。

    2018年4月27日 2:38

回答

  • ASP.NET Web Forms アプリの話ですか? (そのあたりの情報はきちんと書いていただきたく)

    そうであれば・・・

    > bootstrap3.0.0をアンインストールしようとしても、AspNet.ScriptManager.bootstrap3.0.0が依存しているため、bootstrap3.0.0をアンインストールできません。とエラーが出てしまいます。

    Visual Studio のテンプレートで Web Forms アプリを作ると、多分、AspNet.ScriptManager.bootstrap 3.0.0 と bootstrap 3.0.0 の NuGet パッケージがインストール済みではないかと思います。

    その場合、Visual Studio の NuGet パッケージ管理画面を開いて、両方を更新してはいかがですか?

    Visual Studio 2017 持っていないし、試したわけでもないのでハズレかもしれませんが、その場合はすみません。

    2018年4月27日 3:33

すべての返信

  • ASP.NET Web Forms アプリの話ですか? (そのあたりの情報はきちんと書いていただきたく)

    そうであれば・・・

    > bootstrap3.0.0をアンインストールしようとしても、AspNet.ScriptManager.bootstrap3.0.0が依存しているため、bootstrap3.0.0をアンインストールできません。とエラーが出てしまいます。

    Visual Studio のテンプレートで Web Forms アプリを作ると、多分、AspNet.ScriptManager.bootstrap 3.0.0 と bootstrap 3.0.0 の NuGet パッケージがインストール済みではないかと思います。

    その場合、Visual Studio の NuGet パッケージ管理画面を開いて、両方を更新してはいかがですか?

    Visual Studio 2017 持っていないし、試したわけでもないのでハズレかもしれませんが、その場合はすみません。

    2018年4月27日 3:33
  • 早々に返信いただき、ありがとうございます。

    はい、ASP.NET Web Forms アプリの話です。

    教えていただいたとおり、AspNet.ScriptManager.bootstrap 3.0.0を更新したら、バージョンアップできました!

    ありがとうございました!

    2018年4月27日 9:09
  • 質問者さんの問題が解決して、この件に関する質問がなければこのスレッドはクローズしてください。

    2018年4月28日 1:46