none
Custom Action RRS feed

  • Domanda

  • Salve a tutti,
    ho utilizzato le custom action tramite sharepoint designer 2010 e funziona tutto bene su una semplice lista. Se provo però a crearle su una lista con field particolari, le custom action non vengono proprio visualzzate (sia list item, display ribbon, ecc.). Ho letto un po' in giro che forse c'è un problema nel farle legare a liste che hanno campi di tipo "personalizzato", ma non ho capito molto bene. Come posso risolvere? Grazie
    martedì 20 settembre 2011 10:54

Risposte

  • Ho risolto mettendo nella custom action di quella lista invece che {ItemId} il {SelectedItemId} che a differenza del primo viene recuperato correttamente
    • Contrassegnato come risposta Pasqualino Raso martedì 20 settembre 2011 17:12
    martedì 20 settembre 2011 17:11

Tutte le risposte

  • Sono riuscito dopo vari tentativi (non so esattamente come) a far apparire la custom action nel View Ribbon. Il problema è che non mi recupera più l'ItemId. L'URL da me impostato è: "...?id={ItemId}&ListID={ListId}&Source={Source}" .

    Nella semplice lista di test sui cui avevo provato precedentemente la custom action funzionava perfettamente, ma adesso non mi recupera più {ItemId}. Come output viene fuori "...?id=%7BItemId%7D&ListID=%7B00f14a5a-5dd1-4169-b7e3-3fdd71147749%7D&Source=http%3A%2F%2Fsharepoint2010%2Fgestionale%2FLists%2FAnagrafiche%2FAllItems%2Easpx" .

    Ho controllato la sintassi ed è corretta!A cosa è dovuto questo errore?! Grazie

    martedì 20 settembre 2011 14:31
  • Ho risolto mettendo nella custom action di quella lista invece che {ItemId} il {SelectedItemId} che a differenza del primo viene recuperato correttamente
    • Contrassegnato come risposta Pasqualino Raso martedì 20 settembre 2011 17:12
    martedì 20 settembre 2011 17:11