none
VB 2010 aspx :webconfig in sottodirectory RRS feed

  • Domanda

  • Ho preparato un sito su un mio dominio e ora voglio inserirlo in una sottodirectory e farlo partire da li

    per poter fare un altro programma nello stesso sito su una diversa diorectory

    Dalla pagina master ho tolto la gestione degli account e li ho gestiti con una tabella del DB

    dalla cartella principale il programma parte.

    Se inserito nella sottodirectory dà errore nella sezione config: <authentication mode="Windows" />

    ho provato con <authentication mode="None" />

    ho provato a toglierlo e non so cosaltro.

    come fare?

    grazie in anticipo.


    Francesco Zordan

    domenica 30 settembre 2012 04:57

Risposte

  • Lo devi inserire se (come tipicamente avviene), nel sito figlio hai delle impostazioni in più o diverse rispetto a quelle del sito padre. Io ti ho semplicemente fatto notare che il problema può derivare dal fatto che le impostazioni "superiori" vengono automaticamente ereditate.

    Mi hai mostrato solo la riga in cui viene segnalato l'errore, ma non il messaggio di errore preciso (ovvero la sua spiegazione).


    Marco Minerva [MCPD]
    Blog: http://blogs.ugidotnet.org/marcom
    Twitter: @marcominerva

    • Contrassegnato come risposta Francesco.Zordan lunedì 1 ottobre 2012 09:08
    • Contrassegno come risposta annullato Francesco.Zordan lunedì 1 ottobre 2012 09:09
    • Contrassegnato come risposta Irina Turcu martedì 9 ottobre 2012 17:50
    lunedì 1 ottobre 2012 08:42
    Postatore
  • Ora penso di avere capito. Nel config figlio ci devo mettere le cose che cambiano o sono aggiunte ma non può entrare in conflitto con quanto dichiarato nel config padre.

    ora il programma gira.

    grazie


    Francesco Zordan

    • Contrassegnato come risposta Irina Turcu martedì 9 ottobre 2012 17:50
    lunedì 1 ottobre 2012 09:12

Tutte le risposte

  • I siti che si trovano in sottodirectory ereditano le impostazioni del file web.config "padre". Puoi mostrare l'esatto errore che ottieni?

    Marco Minerva [MCPD]
    Blog: http://blogs.ugidotnet.org/marcom
    Twitter: @marcominerva

    lunedì 1 ottobre 2012 07:58
    Postatore
  • ma allora non devo inserire un altro webconfig?

    Line 29: 				<add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
    Line 30: 				<add assembly="System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></assemblies></compilation>
    Line 31:     <authentication mode="Forms">
    Line 32:       <forms loginUrl="~/VITELLONI/Account/Login.aspx" timeout="2880"/>
    Line 33:     </authentication>


    Francesco Zordan

    lunedì 1 ottobre 2012 08:34
  • Lo devi inserire se (come tipicamente avviene), nel sito figlio hai delle impostazioni in più o diverse rispetto a quelle del sito padre. Io ti ho semplicemente fatto notare che il problema può derivare dal fatto che le impostazioni "superiori" vengono automaticamente ereditate.

    Mi hai mostrato solo la riga in cui viene segnalato l'errore, ma non il messaggio di errore preciso (ovvero la sua spiegazione).


    Marco Minerva [MCPD]
    Blog: http://blogs.ugidotnet.org/marcom
    Twitter: @marcominerva

    • Contrassegnato come risposta Francesco.Zordan lunedì 1 ottobre 2012 09:08
    • Contrassegno come risposta annullato Francesco.Zordan lunedì 1 ottobre 2012 09:09
    • Contrassegnato come risposta Irina Turcu martedì 9 ottobre 2012 17:50
    lunedì 1 ottobre 2012 08:42
    Postatore
  • Ora penso di avere capito. Nel config figlio ci devo mettere le cose che cambiano o sono aggiunte ma non può entrare in conflitto con quanto dichiarato nel config padre.

    ora il programma gira.

    grazie


    Francesco Zordan

    • Contrassegnato come risposta Irina Turcu martedì 9 ottobre 2012 17:50
    lunedì 1 ottobre 2012 09:12