locked
App su Store non parte RRS feed

  • Domanda

  • Salve volevo porvi il mio problema.

    Ho finito di sviluppare la mia prima app, tramite la distribuzione su Visual Studio l'app partiva e funzionava, una volta fatto il package ho caricato appxupload su Devcenter, adesso l'app è nello Store, però quando la scarico non parte. Come mi devo comportare, dove ho sbagliato?

    martedì 8 marzo 2016 10:01

Risposte

  • Ritorno per dirti che ho risolto il problema grazie al ritorno dell'exception con questa implementazione. L'errore era un "access denied" e dopo varie ricerche ho capito che si presentava perchè creavo una cartella all'interno della directory di installazione (non sapendo che erano zone in cui non si poteva modificare nulla), quindi mi è bastato crearla nella zona di scrittura che mi forniva stesso lui (tramite ApplicationData.Current.LocalFolder).

    Grazie per l'aiuto.

    giovedì 10 marzo 2016 08:48

Tutte le risposte

  • Ciao,

    hai provato a lanciare la tua app in release  sull'emulatore o su un device fisico (meglio) per vedere se il problema si verifica ugualmente?

    Ciao

    Alessio

    martedì 8 marzo 2016 10:38
  • Si, sia in release e sia sul mio smartphone
    martedì 8 marzo 2016 10:44
  • Hai anche provato ad installare il pacchetto che viene generato nella cartella AppPackages per provare?

    Di che tipo di app stai parlando? windows phone 8.1, UWP ecc?

    io in questi casi nelle mie app mi aggancio all'evento UnhandledException

    App.Current.UnhandledException += Current_UnhandledException;

    nel costruttore di App e mi faccio mandare una mail con tutti i dettagli per vedere cosa può essere successo

    private void Current_UnhandledException(object sender, UnhandledExceptionEventArgs e)
            {
                var mailto = new Uri("mailto:?to=miamail@gmail.com&subject=[DEBUG] " + e.Exception.Message + "&body=" + e.Exception.StackTrace);
                Windows.System.Launcher.LaunchUriAsync(mailto);
            }

    Ciao


    martedì 8 marzo 2016 10:53
  • il pacchetto generato lì è un appxupload che non posso installare, e non posso intallare nemmeno appx interni alla cartella test generata...

    Proverò ad aggiungere questo controllo collegando la mail.

    Un'altra cosa strana è che la mia fidanzata riesce ad avviarla.

    martedì 8 marzo 2016 17:16
  • Questo fà quindi pensare ad un problema nella tua app per qualcosa che non c'è sul tuo terminale, un file che manca, la conessione o qualche altra cosa.

    Cmq se aggiungi il codice che ti ho segnalato dovresti riuscire a vedere l'errore che hai sul tuo terminale.

    Ciao

    martedì 8 marzo 2016 18:58
  • Ritorno per dirti che ho risolto il problema grazie al ritorno dell'exception con questa implementazione. L'errore era un "access denied" e dopo varie ricerche ho capito che si presentava perchè creavo una cartella all'interno della directory di installazione (non sapendo che erano zone in cui non si poteva modificare nulla), quindi mi è bastato crearla nella zona di scrittura che mi forniva stesso lui (tramite ApplicationData.Current.LocalFolder).

    Grazie per l'aiuto.

    giovedì 10 marzo 2016 08:48
  • Ottimo,

    se hai risolto segna il post come risposta in modo che il thread possa considerarsi chiuso

    Ciao!

    giovedì 10 marzo 2016 09:06
  • Ciao,

    se tutto è risolto ricordati segnalare un post come risolto per chiudere il thread!

    Ciao

    sabato 12 marzo 2016 15:09