none
Impossibilità di effettuare una ricerca in Sharepoint 2010 RRS feed

  • Domanda

  • Ciao,

    ho installato Sharepoint Server 2010 su un server virtuale Windows Server 2008 R2 con SQL Server 2008 Enterprise (anceh se sharepoint si è installato in SQL Express 2008).

    Ho creato un elenco di contatti, ma se vado nell'opzione "cerca nel sito" mi viene visualizato l'errore:

    Eccezione per errore interno del server:

     

    Risoluzione dei problemi relativi a Microsoft SharePoint Foundation.

    ID correlazione: c150de0a-8c8e-4900-b9f4-05a75c95333c

    Data e ora: 13/10/2010 12:37:03


    ###############

     

    Cosa può essere? Sapete come risolvere il problema?

     

    Grazie

    Diego

    mercoledì 13 ottobre 2010 15:44

Risposte

Tutte le risposte

  • Ciao Diego,

    immagino tu abbia effettuato un'installazione standalone e, sopratutto, senza utilizzare utenti di AD. In questo caso il search (by design) non si attiva correttamente. Puoi facilmente verificare il problema dalla search administration dove, in topology, troverai il "Query component" perennemente in stato "Initializing": il search non funzionerà fino a quedo non sarà in stato online.

    Qui puoi trovare un workaround per risolvere il problema.

    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    mercoledì 13 ottobre 2010 19:51
  • Ciao Patrizia,

    ho installato SharePoint su un server appartenente ad un dominio, anche se l'AD è installata ed operativa su un altro server, ma con Windows Server 2003 R2. Avrei dovuto fare altrimenti?

     

    Grazie

    giovedì 14 ottobre 2010 07:16
    • Proposto come risposta Gabriele Del Giovine giovedì 14 ottobre 2010 07:53
    • Contrassegnato come risposta diegogeid venerdì 15 ottobre 2010 06:52
    giovedì 14 ottobre 2010 07:52
  • Ciao Diego,

    è corretto che l'AD sia su di un server diverso rispetto a quello sul quale hai installato SharePoint, come pure è corretto che quest'ultimo sia integrato nel dominio. L'errore che hai fatto è nell'installazione di SharePoint: hai effettuato un'installazione standalone (completa) al posto di un'installazione farm (ecco perché ti ha installato SQL Express, che pone dei limiti rispetto ad SQL Server); in caso di installazione standalone SharePoint viene considerato come ambiente di test e non sono totalmente disponibili alcune funzionalità.

    Ora puoi:

    • disinstallare SharePoint e reinstallarlo correttamente (assolutamente da fare se il tuo è un server di produzione)
    • oppure applicare la soluzione che ti ho proposto (o quella di Grabriele, che è la stessa ma scritta in italiano) per attivare il search, se il tuo rimane un server di test

    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    • Contrassegnato come risposta diegogeid venerdì 15 ottobre 2010 06:51
    giovedì 14 ottobre 2010 12:27
  • Ciao,

    avevi ragione Patrizia, ho disinstallato tutto e reinstallato, ora sembrerebbe funzionare.

     

    Grazie

    Ciao

    venerdì 15 ottobre 2010 06:51
  • Ciao,

    Sono OT e comunque aggiungo il mio grazie a Patrizia e Gabriele, e nello stesso tempo a tutti coloro che danno vita a questo forum SharePoint IT Pro con le loro risposte!

    Ciao.


    Anca Popa
    Follow ForumTechNetIt on Twitter
    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie Microsoft. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte di Microsoft.
    venerdì 15 ottobre 2010 07:52
  • Ottimo!

    Grazie per il riscontro.
    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    venerdì 15 ottobre 2010 18:22