none
INLINE EXPRESSIONS (Variabili su Markup) RRS feed

  • Domanda

  • Buongiorno,
    non riesco a parametrizzare il markup di una pagina ...

    Nei seguenti due casi
    a)
    background-color: #05074b;">NO</p>
    background-color: #05074b;"><%= Variabile %></p>
    /// tutto regolare

    b)
    vertical-align: middle;">Novara</p>
    vertical-align: middle;"><%= Variabile %></p>
    /// tutto regolare

    ma se vado ad inserire la variabile all'interno della proprietà di un ImageButton (all'interno delle virgolette)
    ImageUrl="~/Images/LogoNO76x76.png" PostBackUrl="~/frmEntity.aspx?prv=no&type=" ToolTip="Novara" />
    con
    ImageUrl="<%= imgUrl %>" PostBackUrl="<%= navUrl %>" ToolTip="<%= tip %>" />

    mi dà errore, crea l'oggetto senza selezionare l'immagine, con un link errato e senza tooltip.

    Dove sbaglio ?
    Grazie
    Alessandro Lupi
    martedì 15 febbraio 2022 09:16

Risposte

Tutte le risposte

  • Salve Alessandro,

    Posso suggerirti di controllare i link di sotto, siccome vedo che si tratta di errore tipo <%=...%>

    ASP.NET inline expressions 

    DisplayingFromASP.NET


    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto fornito “as is“ non comporta alcuna responsabilità da parte dell’azienda.

    martedì 15 febbraio 2022 13:28
    Moderatore
  • Grazie molte, il link lo conoscevo, ho provato in tutti i modi e non riesco a venirne a capo 
    martedì 15 febbraio 2022 14:21
  • mi dà errore, crea l'oggetto senza selezionare l'immagine, con un link errato e senza tooltip.
    Potresti fornire una screenshot/immagine del errore ed il problema? 

    • Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto fornito “as is“ non comporta alcuna responsabilità da parte dell’azienda.

    mercoledì 16 febbraio 2022 14:08
    Moderatore

  • mi dà errore, crea l'oggetto senza selezionare l'immagine, con un link errato e senza tooltip.

    Dove sbaglio ?
    Ciao Alessandro,
    con un controllo ImageButton non puoi usare delle property, ma devi fare il binding per assegnarli i valori.


    Paolo Pranzo

    sabato 19 febbraio 2022 14:04