none
Ricerca in SharePoint Foundation 2010: Impossibile trovare l'applicazione Web RRS feed

  • Domanda

  • Salve a tutti,

    non riesco a capire il motivo per il quale non funziona la ricerca in foundation 2010.

    La mia è una installazione su server singolo con DB integrato.

    Saluti

     



    • Modificato Anca Popa giovedì 28 aprile 2011 07:50 typo
    mercoledì 20 aprile 2011 12:59

Risposte

  • No, quello è il servizio windows.
    Apri la central administration e seleziona la voce "Manage services on server". In quella pagina poi, cerca il servizio "SharePoint Foundation Search" e controlla se è avviato. Se non è avviato, avvialo a mano.
    Fatto questo, dovresti aspettare un'indicizzazione in base al numero di minuti/ore/giorni che hai configurato nella pagina di configurazione del servizio.
    Facci sapere se così funziona.

    A presto
    Peppe


    Giuseppe Marchi - SharePoint MVP
    www.peppedotnet.it
    www.dev4side.com
    www.sharepointcommunity.it
    Twitter: @PeppeDotNet
    • Proposto come risposta Mila Daniel Ovidiu mercoledì 27 aprile 2011 14:33
    • Contrassegnato come risposta Anca Popa giovedì 28 aprile 2011 07:53
    domenica 24 aprile 2011 13:58
  • Ok allora basta che aggiungi quell'indirizzo all'interno dell'Alternate Access Mapping che trovi all'interno della Central Administration > Application management (dal menu di sinistra) > Configure alternate access mappings > Add internal URLs

    Cmq, ti consiglio di creare un nuovo nome di DNS per esporlo su internet senza utilizzare l'indirizzo IP.

    A presto
    Peppe


    Giuseppe Marchi - SharePoint MVP
    www.peppedotnet.it
    www.dev4side.com
    www.sharepointcommunity.it
    Twitter: @PeppeDotNet
    • Proposto come risposta Mila Daniel Ovidiu mercoledì 27 aprile 2011 14:33
    • Contrassegnato come risposta Anca Popa giovedì 28 aprile 2011 07:54
    martedì 26 aprile 2011 09:16

Tutte le risposte

  • Ciao
    Il servizio di ricerca è avviato ?
    Quando fai una ricerca cosa ti ritorna ? Nessun risultato ? Un errore ?
    Giuseppe Marchi - SharePoint MVP
    www.peppedotnet.it
    www.dev4side.com
    www.sharepointcommunity.it
    Twitter: @PeppeDotNet
    mercoledì 20 aprile 2011 14:06
  • Ciao,

    grazie per la risposta.

    Ma come faccio a controllare se il servizio di ricerca è avviato?

    questo l'errore dopo una ricerca:

    Impossibile trovare l'applicazione Web all'indirizzo http://192.168.2.7/. Verificare che l'URL digitato sia corretto. Se è previsto che l'URL visualizzi contenuto esistente, l'amministratore di sistema potrebbe dover aggiungere un nuovo mapping di URL per la richiesta nell'applicazione specifica.
    Grazie

    giovedì 21 aprile 2011 20:27
  • Ciao Scusa,

    il servizio SharePoint Foundation Search V4 è avviato.

     

    ciao

     

    giovedì 21 aprile 2011 20:31
  • No, quello è il servizio windows.
    Apri la central administration e seleziona la voce "Manage services on server". In quella pagina poi, cerca il servizio "SharePoint Foundation Search" e controlla se è avviato. Se non è avviato, avvialo a mano.
    Fatto questo, dovresti aspettare un'indicizzazione in base al numero di minuti/ore/giorni che hai configurato nella pagina di configurazione del servizio.
    Facci sapere se così funziona.

    A presto
    Peppe


    Giuseppe Marchi - SharePoint MVP
    www.peppedotnet.it
    www.dev4side.com
    www.sharepointcommunity.it
    Twitter: @PeppeDotNet
    • Proposto come risposta Mila Daniel Ovidiu mercoledì 27 aprile 2011 14:33
    • Contrassegnato come risposta Anca Popa giovedì 28 aprile 2011 07:53
    domenica 24 aprile 2011 13:58
  • Ciao GIuseppe,

    il servizio SharePoint Foundation Search è già avviato, la configurazione e quella  predefinita ovvero:

    Account servizio, predefinito account locale

    Account accesso al contenuti,  predefinito servizio locale

    Database di ricerca, autenticazione di windows 

    Pianificazione indicizzazione ogni 5 minuti.

    Comunque non funziona.

    Grazie


    lunedì 25 aprile 2011 09:26
  • Ciao ,

    scusa, ho capito il problema.

    Se nel browser ci metto l'url composto dal nome ovvero http://nomeserver  la ricerca funziona,

    se apro sharepoint con l'ip ovvero http://ipserver la ricerca mi restituisce questo error:

    Impossibile trovare l'applicazione Web all'indirizzo http://192.168.2.7/. Verificare che l'URL digitato sia corretto. Se è previsto che l'URL visualizzi contenuto esistente, l'amministratore di sistema potrebbe dover aggiungere un nuovo mapping di URL per la richiesta nell'applicazione specifica.
    Strano, perchè potrei anche utilizzare il nome per aprire scharepoint, ma dall'esterno se voglio pubblicarlo?
    Grazie

    lunedì 25 aprile 2011 09:54
  • Ok allora basta che aggiungi quell'indirizzo all'interno dell'Alternate Access Mapping che trovi all'interno della Central Administration > Application management (dal menu di sinistra) > Configure alternate access mappings > Add internal URLs

    Cmq, ti consiglio di creare un nuovo nome di DNS per esporlo su internet senza utilizzare l'indirizzo IP.

    A presto
    Peppe


    Giuseppe Marchi - SharePoint MVP
    www.peppedotnet.it
    www.dev4side.com
    www.sharepointcommunity.it
    Twitter: @PeppeDotNet
    • Proposto come risposta Mila Daniel Ovidiu mercoledì 27 aprile 2011 14:33
    • Contrassegnato come risposta Anca Popa giovedì 28 aprile 2011 07:54
    martedì 26 aprile 2011 09:16
  • eSATTO,

    è QUELLO CHE HO FATTO.

    A cosa ti riferisci quando dici " ti consiglio di creare un nuovo nome di DNS per esporlo su internet senza utilizzare l'indirizzo IP."

     

    Grazie

     

    domenica 1 maggio 2011 09:28
  • Eh, che devi aggiungere un nuovo record nel DNS che ci sarà nella tua rete, così da poter raggiungere il sito sharepoint senza utilizzare l'ip ma utilzizando un nome.
    Qunidi, nel DNS devi aggiungere un nuovo CNAME del tipo "intranet" mappandolo a quel tuo indirizzo IP. Così puoi raggiungere il sito SharePoint tramite l'indirizzo http://intranet
    Giuseppe Marchi - SharePoint MVP
    www.peppedotnet.it
    www.dev4side.com
    www.sharepointcommunity.it
    Twitter: @PeppeDotNet
    lunedì 2 maggio 2011 11:48
  • Eh, che devi aggiungere un nuovo record nel DNS che ci sarà nella tua rete, così da poter raggiungere il sito sharepoint senza utilizzare l'ip ma utilzizando un nome.
    Qunidi, nel DNS devi aggiungere un nuovo CNAME del tipo "intranet" mappandolo a quel tuo indirizzo IP. Così puoi raggiungere il sito SharePoint tramite l'indirizzo http://intranet
    Giuseppe Marchi - SharePoint MVP
    www.peppedotnet.it
    www.dev4side.com
    www.sharepointcommunity.it
    Twitter: @PeppeDotNet


    ciao Giuseppe,

    ho visto sul tuo sito che sei stato allo Smau di Bologna, c'ero pure io ma soprattutto dov'ero quando c'è stato il tuo intervento??? cmq ho visto le slide ; )))

    ti volevo chiedere in merito alla sopracitata citazione (scusa il gioco di parole), potresti spiegarmi la procedura? attualmente accedo dall'esterno tramite indirizzo internet... volendo accedere tramite un nome?

    Grazie 1000 anticipatamente

    venerdì 17 giugno 2011 14:02