none
Portale E-learning problemi di visualizzazione con IE10. E' possibile intervenire sul codice di sviluppo senza passare sul pulsante "VISUALIZZAZIONE COMPATIBILITA' " RRS feed

  • Domanda

  • Ciao a tutti,

    Mi presento, mi chiamo Dario lavoro per una società che si occupa di Formazione per lavoratori in ambito assicurativo e bancario.

    Gestiamo vari portali E-learning, ognuno contenente svariati moduli suddivisi per argomenti (spesso con video lezioni tenute dal docente).

    Ogni utente (dipendente) entra nel portale e segue il corso a cui è iscritto.

    Premesso questo, ecco il mio problema.

    Quando gli utenti utilizzano browser come Firefox o Google Chrome tutto viene visualizzato in modo corretto senza errori. Mentre quando utilizzano IE10 prima dell'inizio del modulo appare una finestra di errore (a volte può capitare che riescono a visualizzare interamente il modulo, ma la spunta verde che indica il corretto completamento del corso non appare). Se l'utente invece, attiva l'opzione "IMPOSTAZIONE VISUALIZZAZIONE COMPATIBILITA'" tutto ciò non accade e il modulo viene visualizzato e completato correttamente. 

    Mi è stato comunicato nella sezione Microsoft TechNet e Microsoft Community di rivolgermi in questa sezione visto che è più specifica per gli sviluppatori.

    Ora la mia domanda è questa visto che i portali E-learning (in genere) e le pagine web devono rispettare gli standard W3C per funzionare in maniera corretta con tutti i moderni browser, c'è modo di intervenire sul codice di sviluppo del portale per risolvere il problema senza passare per il pulsante "IMPOSTAZIONE VISUALIZZAZIONE COMPATIBILITA' " di Internet Explorer 10? 

    Spero di ottenere una soluzione.

    Grazie a tutti della disponibilità

    Un saluto

    Dario

    giovedì 29 agosto 2013 08:49

Risposte

Tutte le risposte

  • Buongiorno Dario,

    quanto richiesto passa per l'impostazione, nel codice HTML della pagina, dei cosiddetti Legacy Document Modes. In sostanza, tramite una particolare istruzione posta come primo tag della sezione <head>, sarà possibile richiedere automaticamente al browser di utilizzare la visualizzazione compatibilità verso una specifica versione di IE.

    In codice, si traduce in qualcosa di questo tipo:

    <html>
    <head>
      <!-- In questo caso, viene utilizzato lo Standard Mode di IE9 -->
      <meta http-equiv="x-ua-compatible" content="IE=9">
    </head>
    
    <body>
      ...
    </body>
    
    </html> 

    Puoi trovare un documento esaustivo sui Legacy Document Modes a questo indirizzo: http://msdn.microsoft.com/en-us/library/ie/jj676915.aspx

    Un saluto,


    Emiliano Musso

    giovedì 29 agosto 2013 08:55
  • Gent.le Emiliano Musso,

    la ringrazio della tempestiva risposta.

    Incomincerò con un test.

    Nel caso ci fossero dei problemi, posso interfacciarmi con lei?

    Un cordiale saluto

    Dario

    giovedì 29 agosto 2013 10:22
  • Se sarò in grado di rispondere, ben volentieri. In ogni caso, qui c'è una nutrita schiera di professionisti, sono sicuro che tra tutti troveremo una soluzione al problema.

    Buona giornata


    Emiliano Musso

    giovedì 29 agosto 2013 13:01
  • Gent.le Emiliano Musso,

    ahimè nulla da fare le spiego gli step con cui ho proceduto:

    1 Ho creato il pacchetto denominato SCORM (oggetto LMS/ didattico) compresso in rar

    2 Ho estratto il file di SCORM e sono intervenuto sul file HTML (con Notepad++) inserendo l'istruzione come da lei indicato.


    <meta http-equiv="x-ua-compatible" content="IE=9" />


    3 Ho ricreato il pacchetto rar e provato ad uplodare all'interno del portale.

    4 Ahimè non carica il file

    PS Ho provato a far partire il file html con internet explorer prima di comprimerlo e funziona senza quell'errore.

    Manca qualcosa ma ci siamo quasi

    Confido su di lei 

    Grazie della disponibilità

    Un cordiale saluto

    Dario

    giovedì 29 agosto 2013 14:31
  • Buongiorno,

    credo sia importante definire meglio il punto 3, ovvero cosa significhi il mancato caricamento del file: riceve errori o segnalazioni di qualche tipo?

    Non credo che il problema risieda nell'HTML, piuttosto è possibile che vi sia qualcosa nella creazione del pacchetto. Può dettagliare meglio gli eventuali avvisi?


    Emiliano Musso

    venerdì 30 agosto 2013 06:57
  • Buongiorno,

    intanto la ringrazio della disponibilità.

    Mi spiego bene:

    Quando esporto il mio oggetto didattico/SCORM da Adobe Captivate (software interamente dedicato alla creazione di oggetti per E-learning), tale oggetto è zippato. 

    A questo punto estraggo tutto il suo contenuto e tra vari file, intervengo sul file HTML con Notepad ++, inserendo l'istruzione come in figura.

    Salvo il tutto, riseleziono tutti i file e ricreo un pacchetto zip con il file HTML modificato.

    Accedo al portale E-learning provo a caricare l'oggetto e mi appare questa schermata di errore

    Niente da fare. 

    Sbaglio in qualcosa?

    Saluti

    Dario

    venerdì 30 agosto 2013 09:47
  • Un errore che noto sull'HTML (ma che non può pregiudicare un upload) è il doppio segno di minore davanti al tag META, e sarebbe da correggere. Tuttavia, come dicevo, dal momento che il problema è sull'upload di uno zip, penso che ci possano essere problematiche riguardanti i permessi dell'utente remoto che esegue il caricamento sul server, o comunque qualche anomalia dovuta al modulo di upload stesso.

    Consiglierei di provare ad eseguire semplicemente un download di un pacchetto qualunque, e successivo ri-upload, senza alcuna modifica, per vedere se si manifesta l'errore. Se il procedimento va a buon fine, dovrebbe allora provare a scaricare un file, scompattarlo, rizipparlo e uploadarlo di nuovo, per vedere se il problema è nella fase di compressione. Sono piuttosto convinto che il problema possa cadere nell'upload o nella produzione del pacchetto stesso (ma per conferma o smentita, è necessario fare questi test). 

    Emiliano Musso

    venerdì 30 agosto 2013 10:00
  • Interverrò immediatamente con l'istruzione HTML.

    Per quanto riguarda i test ho provato come ha specificato lei.

    Ho preso un pacchetto qualunque, l'ho scompattato (senza modificare il file HTML), rizippato e mi dà lo stesso problema. 

    Quindi il problema si genera in fase di compressione. Come mai? Procedimento errato?

    Qualche consiglio

    Un saluto

    Dario


    venerdì 30 agosto 2013 10:30
  • Immaginavo.

    Purtroppo si entra nello specifico di SCORM e di Adobe Captivate, e su questo non so fornirle informazioni. Ho trovato una discussione in rete, di cui allego URL, in cui si accenna ad un errore simile al suo: spero che possa servire come "indizio".

    http://www.docebo.com/community/doceboCms/forum/4_0/message/idThread_6321/errore_upload_file_scorm.html

    Un saluto


    Emiliano Musso

    • Proposto come risposta Irina Turcu martedì 3 settembre 2013 09:34
    • Contrassegnato come risposta Irina Turcu mercoledì 25 settembre 2013 12:39
    venerdì 30 agosto 2013 13:24
  • Provo a dargli un'occhiata.

    Grazie infinite della disponibilità. Nel caso di nuove news vi aggiorno.

    Un saluto e buona giornata

    lunedì 2 settembre 2013 07:19
  • Gent.le Emiliano Musso,

    Seguendo i suoi consigli e quelli correlati ad altri forum ebbene, immettendo l'istruzione all'interno del portale LMS (docebo nel mio caso) e non nel singolo oggetto didattico il problema è risolto. 

    Ancora stento a crederci.

    Sono davvero contento e le chiedo per l'ennesima volta grazie infinite. E' stato davvero gentile.

    Un ringraziamento è rivolto a tutto il Vostro Team Tecnico Microsoft per l'ottima considerazione e audacia nei confronti dei vostri clienti.

    Cordiali saluti

    Dario

    martedì 3 settembre 2013 09:21