none
Ajax Control Toolkit 3.5 RRS feed

  • Domanda

  • Ciao a tutti,
    sto sviluppando un sito internet asp.net con la versione di ajax 3.5
    Non posso utilizzare la versione di ajax successiva perchè lo spazio web non la supporta.
    Il mio problema è che non vedo l'effetto dei controlli ajax, cioè la pagina mi funziona, ma se per esempio aggiungo ad una text box il controllo ajax ValidatorCallOutExtender non vedo l'effetto. Come questo anche per altri controlli ajax.
    Mi funziona solo UpdatePanel
    Inoltre in alto alla pagina inserisco :

    <%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="asp" %>

    e dopo <form runat="server">

    aggiungo questo :

    <asp:ScriptManager ID="ScriptManager1" runat="server"></asp:ScriptManager>

    se provo ad aggiungere

    <asp:ToolkitScriptManager ID="ToolkitScriptManager1" runat="server"></asp:ToolkitScriptManager>

    va in errore

    Il server web di aruba mi da questo errore :

    Unable to load one or more of the requested types. Retrieve the
    LoaderExceptions property for more information

    Dove sbaglio ?


    • Modificato kio2008 mercoledì 13 novembre 2013 17:47
    mercoledì 13 novembre 2013 17:40

Risposte

  • Prova ad utilizzare il toolkit facendo drag e drop dalla toolbox di visual studio e verifica che il framework utilizzato nel website sia lo stesso che hai su aruba.

    Ciao


    Luca Congiu (congiuluc)
    Personal Blog: blogs.dotnetcode.it

    Se hai trovato la soluzione all'interno del Forum, ricorda di segnalare il post come risposta, in alternativa puoi postare la soluzione da te adottata. Questo aiuterà altri utenti, che hanno riscontrato la stessa problematica, ad identificare rapidamente la soluzione/risposta corretta.

    • Proposto come risposta Irina Turcu martedì 26 novembre 2013 15:57
    • Contrassegnato come risposta Irina Turcu venerdì 29 novembre 2013 13:52
    mercoledì 13 novembre 2013 18:18
    Moderatore

Tutte le risposte

  • Prova ad utilizzare il toolkit facendo drag e drop dalla toolbox di visual studio e verifica che il framework utilizzato nel website sia lo stesso che hai su aruba.

    Ciao


    Luca Congiu (congiuluc)
    Personal Blog: blogs.dotnetcode.it

    Se hai trovato la soluzione all'interno del Forum, ricorda di segnalare il post come risposta, in alternativa puoi postare la soluzione da te adottata. Questo aiuterà altri utenti, che hanno riscontrato la stessa problematica, ad identificare rapidamente la soluzione/risposta corretta.

    • Proposto come risposta Irina Turcu martedì 26 novembre 2013 15:57
    • Contrassegnato come risposta Irina Turcu venerdì 29 novembre 2013 13:52
    mercoledì 13 novembre 2013 18:18
    Moderatore
  • Ho dimenticato di dire che uso visual studio 2010, vale lo stesso quello che mi dici ?
    giovedì 14 novembre 2013 12:39
  • Si

    Luca Congiu (congiuluc)
    Personal Blog: blogs.dotnetcode.it

    Se hai trovato la soluzione all'interno del Forum, ricorda di segnalare il post come risposta, in alternativa puoi postare la soluzione da te adottata. Questo aiuterà altri utenti, che hanno riscontrato la stessa problematica, ad identificare rapidamente la soluzione/risposta corretta.

    giovedì 14 novembre 2013 14:45
    Moderatore
  • Ciao Kio2008,

    Hai risolto il problema?


    Luca Congiu (congiuluc)
    Personal Blog: blogs.dotnetcode.it

    Se hai trovato la soluzione all'interno del Forum, ricorda di segnalare il post come risposta, in alternativa puoi postare la soluzione da te adottata. Questo aiuterà altri utenti, che hanno riscontrato la stessa problematica, ad identificare rapidamente la soluzione/risposta corretta.

    lunedì 18 novembre 2013 15:03
    Moderatore