none
Classic ASP in IIS 8 on Windows Server 2012 RRS feed

  • Question

  • Does anybody know of a good source about how to activate Classic ASP on IIS 8?

    There is some material out there saying Classic ASP is now included in the installation, except you have to create MIME type, etc.  But the new server is a little bit different than IIS 7.5 or 7.0 approach.

    Please do not send us your clever comments about why and how ASP.NET is better and superior to Classic ASP.  We don't want to hear that at the moment.

    ps. I wish there was a Forum for IIS/Web only .... every other forum is sort of mixed with development vs. IIS admin.


    Travis McGee

    Sunday, October 14, 2012 2:00 AM

Answers

All replies

  • Hi

    Please check this about running Applications on IIS 7 and IIS 8.

    You could  post this thread on IIS Forum for better solution.

    hope it helps you.

    Regards

    Monday, October 15, 2012 9:32 AM
    Moderator
  • No, the title "Running Classic ASP Applications on IIS 7 and IIS 8" is bogus.

    It should have been 7.0 and 7.5 as the subtitle says.

    IIS 2012 is entirely different.

    Can somebody else try figuring it out?


    Travis McGee

    Saturday, November 3, 2012 1:07 AM
  • Hi Travis - I wonder if you found an answer to your question?

    I am also trying to install Classic ASP using IIS8 on Windows Server 2012, and cannot find out how to do it.

    There is an article here http://technet.microsoft.com/en-us/library/hh831387.aspx which gives simple step-by-step instructions apparently exactly for this situation but, frustratingly, where the guide says you simply choose "ASP" and "ISAPI Extensions" in the IIS Configuration section, these two options are not there to be chosen in my version.

    Any feedback appreciated.

    John


    JohnRC


    Monday, December 17, 2012 12:40 PM
  • From: http://technet.microsoft.com/en-us/library/hh831387.aspx

    On step #7 under the "To install IIS on Windows Server 2012 by using the UI" section, you have to expand the Application Development item to see the "ASP" and "ISAPI Extensions."

    Joe

    Friday, December 21, 2012 11:54 PM
  • Hmmm. . . . there is no "Application Development" item visible in the list either. I must be looking at the wrong dialog...


    JohnRC

    • Proposed as answer by mfread Sunday, December 30, 2012 9:52 AM
    • Unproposed as answer by mfread Sunday, December 30, 2012 9:53 AM
    • Proposed as answer by J818 Thursday, July 18, 2013 9:40 AM
    Saturday, December 22, 2012 9:58 AM
  • Hello I had the same problem please see under
    Server Roles
    Web Server (IIS)
    Web Server
    Application Development
    ASP ...
    Wednesday, January 30, 2013 2:06 PM
  • Expand the Web Server (IIS) item. / Julian Wong (HK)



    • Edited by J818 Thursday, July 18, 2013 9:45 AM add my name
    • Proposed as answer by J818 Thursday, July 18, 2013 9:53 AM
    Thursday, July 18, 2013 9:43 AM
  • OMG. This fixed my problem. Thanks a bunch.

    patricia hartman

    Saturday, October 11, 2014 7:01 PM
  • On our Windows Server 2012 machine, these checkboxes were already ticked, but disabled.

    And when I try to get my website to link to a (legacy) .asp, it just gives me a HTTP Error 500.

    None of the links provided here, suggested what else to try.

    Wednesday, June 8, 2016 8:54 AM
  • I discovered that I had to create an application pool - Classic .ASP - no managed code/classic and then set the enable 32-bit to true.  I then set the classic .asp folders to the new application pool.  It works now!
    Monday, March 20, 2017 2:23 PM
  • You're the fuc**ng master. I was about to go crazy. Your solution is the real one. Thank you. Thank you. Thank you.
    Tuesday, June 13, 2017 7:22 PM