none
IE9 Warning Blocks Javascript RRS feed

  • Question

  • PROBLEM: I developed a web page (called "simple.html") containing some javascript and its local on my computer (Win7).
    In IE9 I have Active scripting Enabled, so that I can run web pages containing javascript.
    When I open the file for the web page it doesn't run the javascript and there is a warning message at the bottom of IE9 saying,
    "Internet Explorer restricts this webpage from running scripts and active X controls"
    How can I get rid of this warning and have IE9 just run the Web page javascript?
    HISTORY: I posted this same problem "IE9 Warning Blocks Javascript" on
    http://answers.microsoft.com/en-us/ie/forum/ie9-windows_7/ie9-warning-blocks-javascript/e5149294-4eb4-4550-b37e-34c945131e33
    Answers were provided for the case where IE9 access a web page with javascript on a remote site. I don't have this problem. No warning message appears when a web page with javascript comes from a remote site -- only when the web page is local on my computer.  
    Finally, I was instructed to post this problem on another forum:
    http://social.technet.microsoft.com/Forums/en-US/ieitprocurrentver/thread/c38361c3-c845-49ed-b5fa-c1bc5db35f64/
    Again unhelpfull answers were provided, and I was asked to post this problem on this forum.
    REPRODUCE: Below is the web page file ("simple.html") I developed. It can be copied to the desktop and opened with IE9 to reproduce the problem cited above. The other forums did not tell me if they could reproduce this problem. It would be useful to know.
    <html><head>
    <title>Test</title>
    <script type="text/javascript">
    window.onload = showIt;
    function showIt() {
    alert("This is javascript");
    }
    </script>
    </head>
    <body>
    <h2>You should see an alert</h2>
    </body></html>

    Cheldark
    Thursday, December 15, 2011 10:13 PM

Answers

  • Internet Options, Advanced tab, check "Enable Active content to run in files on 'My Computer'".

    Regards.

     


    Rob^_^
    • Marked as answer by Cheldark Sunday, December 18, 2011 11:13 PM
    Friday, December 16, 2011 5:54 AM