none
Dynamics Tiles but... RRS feed

  • Question

  • Hi !

    I want to create dynamics tiles from my web site to pin it on my windows phone.

    But...

    on my index.php, i have:

    <!-- Pinned Site IE11 Code -->
    <meta name="application-name" content="Gourmands et cie" />
    <meta name="msapplication-config" content="IEconfig.xml" />
    <!-- End of Pinned Site IE11 Code -->

    On my "IEconfig.xml"

    <?xml version="1.0" encoding="utf-8"?>
    <browserconfig>
      <msapplication>
        <tile>
          <square70x70logo src="images/smalltile.png"/>
          <square150x150logo src="img/mediumtile.png"/>
          <wide310x150logo src="img/widetile.png"/>
          <square310x310logo src="images/largetile.png"/>
          <TileColor>#9FE855</TileColor>
        </tile>
        <notification>
          <polling-uri  src="rsc/wp/notifications/contoso1.xml"/>
          <polling-uri2 src="rsc/wp/notifications/contoso2.xml"/>
          <polling-uri3 src="rsc/wp/notifications/contoso3.xml"/>
          <frequency>720</frequency>
          <cycle>1</cycle>
        </notification>
      </msapplication>
    </browserconfig>


    And a "contoso.xml"...(This file is in PHP because i create it with php and with an htaccess :

    RewriteEngine on
    RewriteRule ^contoso1\.xml$ contoso1.php
    RewriteRule ^contoso2\.xml$ contoso2.php
    RewriteRule ^contoso3\.xml$ contoso3.php

    I can write .xml

    <?php
    header('Content-type: application/xhtml+xml');
    setlocale (LC_TIME, 'fr_FR.utf8','fra'); /* Langue française, pour récuperer le jour */
    $jour=ucfirst((strftime("%A"))); /* Jour d'aujourd'hui avec une majuscule */
    $jourj=(strftime("%A")); /* IDEM sans majuscule */
    include('rsc/connecttobdd.php');
    $requete=$bdd->query("SELECT titre FROM *************** WHERE jour='$jour'");
    $donnees=$requete->fetch();
    $titre=$donnees['titre'];
    ?>
    <tile>
    <visual lang="en-US" version="2">
      
    <binding template="TileSquare150x150PeekImageAndText04" branding="name">
    <image id="1" src="../../../img/header1.jpg"/>
    <text id="1"><?php echo $titre; ?></text>
    </binding>
      
    <binding template="TileWide310x150ImageAndText01" branding="name">
    <image id="1" src="../../../img/header1.jpg"/>
    <text id="1"><?php echo $titre; ?></text>
    </binding>
      
    <binding template="TileSquare310x310ImageAndText01" branding="name">
    <image id="1" src="../../../img/header1.jpg"/>
    <text id="1"><?php echo $titre; ?></text>
    </binding>
      
    </visual>
    </tile>
    

    So, it doesn't work...why ? My XML is bad ?

    With buildmypinnedsite.com it work but why it doesnt work my my files ??? :'(

    Can you help ? Thx

    Wednesday, May 6, 2015 5:26 PM

Answers

All replies