none
Non-admin users cannot view embedded video in html page RRS feed

  • Question

  • I've got a .wmv file that is good. Its hosted on my web server. i've created a very simple page to embed the video for viewing by other users on an internal network only.  It works for me and any pc i go to (i'm a domain admin). Standards users get the WMP player window with controls and a black screen. no video will play.

    This is not a codec issue. i feel its a permissions issue because i can launch IE as myself under a standard user's account and the video will play. permission on the files and directories are good. I've searched the web for days now to no avail.  Please  help!

    These machines are ALL identical, win7x64, WMP 12.  

    I greatly appreciate it.

    Friday, January 10, 2014 1:06 PM

Answers

  • I'm not sure i follow BUT...i did get this all working with the HTML5 <video> tag.

    Which i had tried several times to no avail until i figured out the meta tag i was missing.

    In IE9 at least,<meta http-equiv="X-UA-Compatible" content="IE=9"/> is practically required for this to work reliably. So there you have it, the fix.

    Thank you all very much for the guidance!

    Cheers,

    B

    • Marked as answer by Yanping Wang Friday, January 17, 2014 9:47 AM
    Wednesday, January 15, 2014 12:45 PM

All replies

  • Tools>Internet Options>Security tab, Intranet zone... Scripting of ActiveX controls.

    File>Properties to view what IE security zone your page maps to. In IE11 Enhanced Protected Mode is enabled by default.... for the Internet and Restricted zones. though non-admin security zone setting seems the likely cause since the MP displays but does not play.


    Rob^_^

    Friday, January 10, 2014 11:45 PM
  • ok so i added our intranet site to the intranet zone, double checked all settings to be sure all activex is allowed (enable)....still no go.

    Still just media player window and black screen. I'm at a total loss here and have never seen issues like this, very strange.

    Monday, January 13, 2014 12:56 PM
  • tools>Manage addons>Show all Addons... locate

    Windows Media Player... both x64 and x86 versions should be enabled.

    Check the users profile (using GPO) for any Allowed ActiveX controls exceptions.


    Rob^_^

    Tuesday, January 14, 2014 12:11 AM
  • ok so i added our intranet site to the intranet zone, double checked all settings to be sure all activex is allowed (enable)....still no go.

    Still just media player window and black screen. I'm at a total loss here and have never seen issues like this, very strange.

    Show me the money...
    Wednesday, January 15, 2014 3:58 AM
  • I'm not sure i follow BUT...i did get this all working with the HTML5 <video> tag.

    Which i had tried several times to no avail until i figured out the meta tag i was missing.

    In IE9 at least,<meta http-equiv="X-UA-Compatible" content="IE=9"/> is practically required for this to work reliably. So there you have it, the fix.

    Thank you all very much for the guidance!

    Cheers,

    B

    • Marked as answer by Yanping Wang Friday, January 17, 2014 9:47 AM
    Wednesday, January 15, 2014 12:45 PM
  • It means that we saw the description but we never saw the "cache".
    That is, nothing can fix the code it can't touch. - But it seems that you've finally found your way around. Cheers.
    Wednesday, January 15, 2014 6:25 PM