none
IE 11, Set Compatibility Through Meta Data, JavaScript Code, or IIS Custom Header or Web.Config

    Question

  • This IE 11 (desktop version) drives me crazy.  We have a production site which holds all those legacy codes accumulated for many years. There were compatibility issues before since IE 10, but we can manage to using http-equiv="X-UA-Compatible" content="IE=9" to resolve the issues and management has been happy about it. After some end-user updated to Windows 8.1 and using IE 11, the production site stops working which end users only see a blank page! (I do know to let the user to go to Tools -- Compatibility View Settings to add our site to compatibility list, but this is not the solution for most of the users. When most of users see blank page, users start to panic).  While I realize that there are many bad coding practices in the application, but refactoring codes cannot be happened in one night, it will take time and end-users can not wait. I simply want to IE 11 supports the same features or give some documents which allow developers to work around the issues (Like using meta data to support compatibility features or any methods which can support such features). But IE 11 provides neither. I have been trying to find documents and related topics or those solutions, none of them work (tried: through Meta Data as mentioned above, JavaScript Code, or IIS Custom Header or Web.Config). Even worse, the IE 11 F12 tool is also not working consistently with Compatibility View Settings tool. When legacy site is set through Compatibility View Settings tool, the site is working. When I use F12 to switch among different version of IEs, none of them work. As developer, I am really frustrated, because I think this is such important and fundamental features (there are lots of old legacy web apps out there, but end-users update to IE11), IE 11 should take care of it at minimum. Can this forum send our frustration to Microsoft IE team???
    Saturday, November 02, 2013 4:37 PM

Answers

  • click for full size



    Tada.  I changed the content-type from application/xhtml+xml to text/html and all our troubles went away.  I didn't even change the xhtml Doctype in the file.  (I tried that first then put it back, it solved nothing).  It even came up in IE11 edge mode, all by itself.  It's strange how that xhtml+xml content-type prevents the documentMode from being reduced beneath 9.  Is that how it's supposed to work?

    Saturday, November 09, 2013 8:27 PM

All replies

  • Hi,

    Please supply a link to your website for us to investigate...

    You could try turning on ActiveX filtering to disable legacy ActiveX controls from being loaded.

    IE11 runs in EPM by default.


    Rob^_^

    Sunday, November 03, 2013 3:24 AM
  • Hello,  Rob

    Thank you for your information. Yes, I did disabled/removed ActiveX components, still IE 11 does not work without manually setup Compatibility View Settings.

    Here is our site,

    https://integ.brinkercapital.com/Brinker/Portal/Web/CMS/Home.aspx

    Please advise if you have any insights. As I mentioned before, I would like to solve the problems from coding wise without asking users to do anything as I described above.

    Thank you and really appreciate your help!

    Xiaoli Qin

    Tuesday, November 05, 2013 1:36 AM
  • Have you tried http-equiv="X-UA-Compatible" content="IE=7"?

    Thanks

    Mark.


    Mark Feetham Senior Program Manager Internet Explorer Product Quality

    Thursday, November 07, 2013 2:20 PM
  • Hello, Mark,

    Yes, I did. As I described before, except through built-in Compatibility View Setting, none of others works.

    PS: This text editor is not working properly in IE 11.

    1. "Undo" is not working properly. It does nothing sometimes, sometimes wipes off some of typed contents. This happens sometimes randomly.

    bold), wipe off some of the contents. This happens sometimes randomly. 

    Thanks

    Thursday, November 07, 2013 3:29 PM
  • Hi Xiaoli

    If that works and the site renders as expected I'd add the meta tag to your site/page as appropriate.

    Thanks

    Mark.


    Mark Feetham Senior Program Manager Internet Explorer Product Quality

    Thursday, November 07, 2013 3:33 PM
  • Mark,

    Thank you for your response.

    I should elaborate my statements.

    Set http-equiv="X-UA-Compatible" content="IE=7"  meta data does NOT work.

    When I said it worked only through built-in Compatibility View Settings tool, it only meant that when users go to Tools --> Compatibility View Settings --> add our site to compatibility list, users can see the "home" page, because of IE 7, many features cannot displayed properly anymore. So this is not the solution we are looking for. As I described before, we just want IE 11 behaves the same as IE 10 in terms of compatibility settings. With the minimum, like IE 10, we want to compatibility falling back to IE 9, not IE 7. Plus we want to set the compatibility through meta data, web config, even IIS, but NOT asking users to do themselves.

    Key things:

    1. Compatibility View Setting: falling back to IE 7, this is not acceptable

    2. Compatibility settings through meta data, IIS custom header, web.config, group policy: None of these work.

    Thanks!

    Xiaoli

    Thursday, November 07, 2013 4:24 PM
  • Thanks for the detail Xiaoli.

    We believe the fix lies in updating ASP.NET and, in general to modernize by using feature detection instead of browser sniffing. If you modify the UA string to a custom that includes a version of Firefox then your site renders.

    Take a look at http://blogs.msdn.com/b/ieinternals/archive/2013/09/21/internet-explorer-11-user-agent-string-ua-string-sniffing-compatibility-with-gecko-webkit.aspx

    To get the developer tools to show an emulation try this:
    1. Navigate to a site that stays in the same iexplore.exe process (e.g. slashdot.org).
    2. Clear your browser history.
    3. Close/Reopen IE once finished deleting history.
    4. Open F12 Developer Tools and change UA to custom and add the following:
    Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko/20100101 Firefox/22.0

    Please let me know how you get on.

    Regards

    Mark


    Mark Feetham Senior Program Manager Internet Explorer Product Quality


    Thursday, November 07, 2013 6:13 PM
  • Mark, Rob, Max

    I checked our production site yesterday that the site is working as before without setting up through Compatibility View Settings.  We really appreciate you helped to put our domain in your compatibility list to make our site(s) working, thank you very much!

    As a developer, while I am using Visual Studio to run the application, the problems are still there. I will review and check the list and the information you provided during this weekend, I will give the feedbacks if I find something.

    Thanks!

    Xiaoli

    Saturday, November 09, 2013 3:30 PM
  • Max:

    I played around your suggestion, yes, it does work! I checked around the Microsoft document, did not find anywhere mentioned we should do this way. But as summary:

    1. When setting following as you mentioned: "text/html", the site is working.

    2. The Document Type stays as "Edge(Default)" as change content-type.

    3. None of meta data set in the file(s) work. (Change any meta data setting, the site returns blank)

    4. Change UA string to Custom by putting IE 11 agent string does not work. (still give back blank page)

    5. From my IE 11, if I don't do any header content-type changes, the Document Mode stay as "Edge", not IE 9.

    Thank you very much! I will mark your response as answer.

    Xiaoli

    Sunday, November 10, 2013 6:10 PM
  • Xiaoli Can you please explaine the steps that you took again in details as we are having a same problem on IE 11.

    thanks


    • Edited by sabaadil Wednesday, December 04, 2013 2:43 PM
    Wednesday, December 04, 2013 2:42 PM
  • The "fix" that works for my site is to manually set document mode to Edge OR 10 OR 9  AND set the UA to:

    Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko/20100101 Firefox/22.0

    Can this be set server-side in IIS 7.5?

    How?

    Thanks,

    Ken

    Wednesday, December 04, 2013 10:58 PM
  • Hi Ken,

    In your IIS, select your application, in the feature view open "HTTP Response Headers"

    Then click on Add and enter these 

    Name:X-UA-Compatible

    Value:IE=Your desired IE version

    Thanks,

    Rakesh

    • Proposed as answer by Hasthi007 Thursday, April 24, 2014 11:42 AM
    Thursday, January 30, 2014 2:50 PM
  • This IE 11 (desktop version) drives me crazy.  We have a production site which holds all those legacy codes accumulated for many years. There were compatibility issues before since IE 10, but we can manage to using http-equiv="X-UA-Compatible" content="IE=9" to resolve the issues and management has been happy about it. After some end-user updated to Windows 8.1 and using IE 11, the production site stops working which end users only see a blank page! (I do know to let the user to go to Tools -- Compatibility View Settings to add our site to compatibility list, but this is not the solution for most of the users. When most of users see blank page, users start to panic).  While I realize that there are many bad coding practices in the application, but refactoring codes cannot be happened in one night, it will take time and end-users can not wait. 


    Friday, February 28, 2014 5:48 AM
  • Please give me the Exact Code 

    Friday, February 28, 2014 6:24 AM
  • Hi Rakesh,

    This works for me. Thank you very much.

    Hasthi

    Thursday, April 24, 2014 11:43 AM
  • Hello Guys,

    Hope you are doing Good.

    I am facing same issue while setting compatibility view settings through meta/header code.

    I have to avoid manual steps of applying compatibility to each user though browser setting.

    So please give me some suggestion How I can manage IE-11 Edge compatibility setting though code.

    Any help is Appreciated!

    Please help me It's urgent.

    Thanks,

    Monday, April 06, 2015 7:23 AM